View Issue Details

IDProjectCategoryView StatusLast Update
0005685ScribusUsabilitypublic2008-02-08 13:22
Reporteralexandre Assigned Tochristoph_s  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.3.5svn 
Target VersionFixed in Version 
Summary0005685: Uniform approach to selection of text
DescriptionScribus needs a uniform approach to selection of text in both text frames and StoryEditor.

double click -- selects a word
shift + double click -- selects a word and a trailing space

triple click -- selects current line
shift + triple click -- selects current paragraph
TagsNo tags attached.
Patch

Relationships

duplicate of 0004303 confirmed More mouse selection possibilities (triple and quad clicks) 
related to 0002777 closedcbradney Better Selection of Items for Copying 
has duplicate 0006207 closedchristoph_s feature request: clicks 
child of 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

slash-rus

2007-06-22 00:54

reporter   ~0016624

IMHO, selecting one line is never needed in typesetting. I offer the next shortcuts:

double click -- selects a word

shift + double click -- selects a word and any trailing character (dots, commas, colons, semicolons, etc...)

triple click -- selects current paragraph.

ctrl + double click -- selects text with the same attributes (size, bold, underline, italic, color, etc...) I.e. all text to left and to right from current with all the same text attributes.

ctrl + triple click -- selects all _independent_ paragraphs that have the same paragraph style (if I want to change attributes for all subheads, for example, but don't want changing attributes of style).

shift + triple click -- selects all _independent_ text that has the same character style.

ctrl + shift + select by mouse -- begin the new _independent_ selection chain.

Issue History

Date Modified Username Field Change
2007-05-16 01:49 alexandre New Issue
2007-05-16 01:50 christoph_s Relationship added related to 0002777
2007-06-22 00:54 slash-rus Note Added: 0016624
2008-02-05 23:55 christoph_s Relationship added has duplicate 0006207
2008-02-05 23:56 christoph_s Relationship added child of 0003157
2008-02-05 23:57 christoph_s Status new => acknowledged
2008-02-06 16:48 christoph_s Relationship added duplicate of 0004303
2008-02-06 16:48 christoph_s Status acknowledged => closed
2008-02-06 16:48 christoph_s Resolution open => duplicate
2008-02-08 13:22 christoph_s Status closed => resolved
2008-02-08 13:22 christoph_s Assigned To => christoph_s
2008-02-08 13:22 christoph_s Status resolved => closed