View Issue Details

IDProjectCategoryView StatusLast Update
0005846ScribusOS-Win32public2016-12-08 21:39
Reporterchristoph_s Assigned Tojghali  
Status closedResolutionduplicate 
Platformx86OSWindowsOS VersionXP SP2
Product Version1.3.4 
Target Version1.5.3 
Summary0005846: Scribus doesn't recognise type 1 fonts under windows
DescriptionAs above. Mentioned in the German Scribus forum:,2365.msg2955.html#msg2955 and confirmed by ExScite on IRC.
TagsNo tags attached.


duplicate of 0003861 closedjghali Scribus + Adobe Type Manager 
related to 0005643 acknowledged Activation of freshly installed fonts without app restart 



2007-06-06 23:24

administrator   ~0016473

Trying ps version of urw fonts and they are perfectly detected here...


2007-06-07 22:44

viewer   ~0016483

I just tested on Windows 2000 with a bunch of different good Type 1 fonts.. not an issue.


2007-06-08 09:32

administrator   ~0016487

Christoph, i guess we need more detail on how to reproduce...


2007-06-08 12:00

administrator   ~0016491

jghali, this issue has been reported by several users in the German forum, and it has been confirmed by ExScite on IRC. I was just reporting it.


2007-06-08 13:25

administrator   ~0016492

Tested against fonts provided with our rip software, works too..


2007-06-09 08:16

reporter   ~0016496

Last edited: 2007-06-09 08:17

Found your notes when trying to identify source of problem in which my printing service tell me fonts that I embedded in my PDF files are identified as missing by their checking software. I was using Scribus 1.3.4 Release, which I installed 2007-06-02 on MS Windows 2000 SP4 system. I assumed either my incompetence (despite nearly two decades of amateur DTP experience) or MS Windows compatibility issues and so I checked "Save as PDF" > "Fonts" to ensure all embedded. Resulting PDF viewed using Acrobat Reader on my PC or my laptop displayed text and in "Properties" listed all fonts embedded in line with options I selected. Eventually found Ingo Schmoekel's PDF-Analyzer and discovered that for problem PDF files, fonts are listed as being embedded, but a blank page is displayed when clicking "Preview", which as I understand things is a contradiction. Apologies if I'm missing the point (and please say), but I've begun to wonder if I've stumbled across a bug in the software (which I very much like).


2007-06-09 13:32

administrator   ~0016497

raqliph : unfortunately yes, you completely miss the point. We are speaking of a supposed issue preventing availability of type 1 fonts in font list and not about font embedding. If you however think there's a but somewhere feel free to open a new issue. In your case we'll probably need your sla document.


2007-06-09 15:59

reporter   ~0016500

Last edited: 2007-06-09 16:01

Apologies! I think I'll keep investigating my particular problem from my end before opening a new issue. Thanks.


2007-06-11 10:43

reporter   ~0016513

Hi everybody,

I also have a problem with Type1-Fonts (Win2K, SP4, Scribus 1.3.4). In my case Scribus recognizes fonts, i can use them, but the text gets truncated after one or two lines. I can still see the full text in the story editor, but it is not in the document. Changing the font (any True Type) makes it visible.

Maybe that helps



2007-06-13 07:59

reporter   ~0016523

Last edited: 2007-06-13 08:02

I'm having the same trouble: Win XP SP2, Scribus 1.3.4, Type 1 Font Thesis The Mix. The Text gets truncated. But other Type1 Fonts work, even Thesis TheSans or Adobe Frutiger. No Problems on Linux, and it worked under Windows XP with Scribus After trying to change back to the older Version, Scribus couldn't open the file. I'm sending you parts of my Document: It's type1bug.sla.But the Fonts are Copyright-Protected so I can't send you these. Oh, i just found out that the Font which isn't displayed right is missing the .afm-Files(Adobe Font Metrics)! Maybe that's an information.

2007-06-13 08:01


type1bug.sla (66,973 bytes)


2007-06-13 08:11

administrator   ~0016524

sventernet : Scribus cannot open 1.3.4 files and this is not a bug.


2007-06-13 14:45

administrator   ~0016527

I added a new issue for truncated text (0005873). It's not limited to Windows.


2007-08-10 15:09

reporter   ~0017008

We just tried installing using the .exe install on 3 separate machines running XP SP2.

On all three machines the Type 1 fonts were not recognised. Most of our fonts are professional from the major foundries. We use a number of other publishing apps that use the fonts without problems.

We appreciate that your priority must be the Linux version, but this is a killer bug for Windows users, so you will hopefully be able to give it some priority.


2007-08-10 16:23

administrator   ~0017009

You should read note attached to 0005873 which give some tips. Here are others :
1) Scribus scans for fonts :
       a) on startup
       b) when deleting or add font folder in preferences with *no* doc open
2) Scribus does not use system font cache (ie system memory resident fonts)
3) Consequently any font management performed with a third party tool while scribus is opened won't be taken into account before scribus is restarted (0005643)


2007-08-10 17:17

reporter   ~0017010

jghali, thanks for the quick response. As suggested in the note you referred to, setting the path to the PSFONTS directory explicitly in the preferences fixed the problem, and so far they seem to be behaving correctly in use.

Still feel that this requires some attention, though, as none of the other graphics applications we are using have had this problem locating the fonts.

The fonts were installed with ATM - perhaps this is the cause - though they show up fine in the Windows XP native font manager.


2008-07-24 16:54

administrator   ~0020032

Duplicate of 0003861 per last note

Issue History

Date Modified Username Field Change
2007-06-06 22:51 christoph_s New Issue
2007-06-06 23:24 jghali Note Added: 0016473
2007-06-06 23:38 jghali Description Updated
2007-06-07 22:44 plinnell Note Added: 0016483
2007-06-08 09:32 jghali Note Added: 0016487
2007-06-08 12:00 christoph_s Note Added: 0016491
2007-06-08 13:25 jghali Note Added: 0016492
2007-06-09 08:16 raqliph Note Added: 0016496
2007-06-09 08:17 raqliph Note Edited: 0016496
2007-06-09 13:32 jghali Note Added: 0016497
2007-06-09 15:59 raqliph Note Added: 0016500
2007-06-09 16:01 raqliph Note Edited: 0016500
2007-06-11 10:43 thr Note Added: 0016513
2007-06-13 07:59 sventernet Note Added: 0016523
2007-06-13 08:00 sventernet Note Edited: 0016523
2007-06-13 08:01 sventernet File Added: type1bug.sla
2007-06-13 08:02 sventernet Note Edited: 0016523
2007-06-13 08:11 jghali Note Added: 0016524
2007-06-13 14:45 avox Note Added: 0016527
2007-08-10 15:09 gcaplan Note Added: 0017008
2007-08-10 16:23 jghali Note Added: 0017009
2007-08-10 17:17 gcaplan Note Added: 0017010
2008-07-24 16:54 jghali Note Added: 0020032
2008-07-24 16:54 jghali Relationship added duplicate of 0003861
2008-07-24 16:54 jghali Duplicate ID 0 => 3861
2008-07-24 16:54 jghali Status new => resolved
2008-07-24 16:54 jghali Resolution open => duplicate
2008-07-24 16:54 jghali Assigned To => jghali
2008-07-24 16:54 jghali Status resolved => closed
2014-10-08 18:38 Kunda Category Win32 => OS-Win32
2016-12-07 12:31 Kunda Relationship added related to 0005643
2016-12-08 21:39 cbradney Target Version => 1.5.3