View Issue Details

IDProjectCategoryView StatusLast Update
0000612ScribusUser Interfacepublic2010-10-27 20:26
Reporterjo-hannes Assigned Tofschmid  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformAMD Athlon 1000MHzOSSuse LinuxOS Version9.0
Product Version1.3 
Target VersionFixed in Version1.5.0svn 
Summary0000612: the order of the colors
Descriptionnow the colors in the drop down menu are arranged alphabetically i think, but it would be better if they are arranged by color, dont know exactly how, but now i have nearly the same colors in different positions
TagsNo tags attached.
Patch

Relationships

has duplicate 0007830 closedcbradney Order colors in the palettes not by names but by columns 
has duplicate 0008858 closedcbradney order colors, styles according to name alphabetically 
related to 0002167 closedfschmid Spot colours 
related to 0003759 feedback Separate document colors from palettes. 
related to 0006122 assignedale I prefer colour wheel and sliders than infinite long colour list 

Activities

ringerc

2004-09-05 19:31

reporter   ~0002304

It might also be worth considering placing Black and White at the top of the menu either only or as well as in the main list.

jo-hannes

2004-09-06 10:06

developer   ~0002322

yes, thats even better...b/w at the top.

jo-hannes

2004-09-28 07:27

developer   ~0002553

is a translation of the colours possible too?

cbradney

2004-09-28 07:34

administrator   ~0002556

Not at this point in time.

louisdesjardins

2004-09-28 12:58

developer   ~0002558

Colors not in alphabetical order? hmmmmm... This is going to be a change in habits of a lot of people. Just see how other DTP programs do it when color are named. The list is short because we're talking about CMYK + RGB + White + Registration, so 9 colors, plus the ones created by the user. As for the other colors, the most widely used system among professionnals is Pantone where all color are numbered. So they are listed in numerical order. That way, colors are generally grouped together (there are some weird things in the system, one of which is PMS 485, a deep dark red that is not in the 200 range of reds — but this doesn't prove the system wrong!).

BTW are there any discussions going on with the Pantone people in order to get their color system licenced in a way Scribus could use it?

jo-hannes

2004-09-28 13:14

developer   ~0002559

louis, i see what you mean and youre right that non-aphabetical order could be confusing, too. i thought of the the one color set in scribus where there are lots of named colors. But integrating Pantone would really be great, also because of the numbered (and not named) colors.
but taking black and white to the top of the list is still a suggestion i would support.

packetbell

2004-09-28 16:08

reporter   ~0002560

>>> The list is short because we're talking about CMYK + RGB + White + Registration, so 9 colors, plus the ones created by the user.

It would be very handy to place all colors *used* in a document on top, followed by the CMYK/RGB/White/Registration section and then the alphabetical list.

cbradney

2004-09-28 20:59

administrator   ~0002564

Ok, so lets forget the current request, but keep it open for various colour sets.
Louis, what would you propose for a CMYK set, RGB set etc?

cbradney

2004-09-28 22:32

administrator   ~0002565

To be changed in 1.3.

kirun0

2004-10-01 23:41

reporter   ~0002609

Here's what I did while sorting the list of X11 colours. After various attempts, it looks fairly reasonable, but is not perfect (a few colours still looked out of place).

First, all greyscale colours were moved to the end of the list.
Then, I converted all colours to HSL colourspace.
The colours were grouped by hue, into chunks of about 30 degrees.
They were then sorted by sat+lum, so the darker colours came first, followed by the bold colours, and the light and washed out ones last (within the group)

This was, of course for a single fixed set, the parameters will probablary need tweaking for any other given set.

ringerc

2005-09-17 07:26

reporter   ~0006623

One thing that might help here is splitting the colour display into two panes. One would display colours used in the document, one would display all colours defined (app or doc). A filter for "All spaces", "CMYK", "Spot colours", or "RGB" (that filtered both lists) would help further.

christoph_s

2005-09-17 22:31

administrator   ~0006635

One thing that might be worth considering is the reduction of colours available in a standard installation. Quark offers a reasonable approach IMHO by only offering a basic set of colours, with the exception of spot colour palettes. The latter are sorted by their name/number, which might or might not be grouped by colours, as Louis described.

By "forcing" users to create colours themselves as a default, a lot of confusion and wasted time could be avoided. In case more is desired, users could select the current default X11 colour set, or any other they might wish to.

Olivier

2007-01-29 22:12

reporter   ~0015043

By default, the colour list is alphabetically sorted. Is it possible to disable this? In some swatches, the colour order is quite significant... and it would be great if it was possible to show the colours in the order they are listed in the swatch file.

And I'm with Craig Ringer on the idea of separating document colours and example swatches.

faramond

2007-01-31 12:11

reporter   ~0015052

Something along the lines of kirun0's idea would be good.

As long as the drop-downs are coded correctly, the user should be able to jump to a desired named color by typing the first few letters of its name (like in a file manager.) The drop-downs could also be modified such that typing in a number jumps to color with the same number. This way, you could sort by as kirun0 proposes but still maintain quick access to both named and numbered colors.

hfinger

2008-01-18 05:21

reporter   ~0018633

Also add Registration as a choice at the top of the list with Black and White.

Issue History

Date Modified Username Field Change
2004-05-07 06:27 jo-hannes New Issue
2004-09-05 19:31 ringerc Note Added: 0002304
2004-09-06 10:06 jo-hannes Note Added: 0002322
2004-09-28 07:27 jo-hannes Note Added: 0002553
2004-09-28 07:34 cbradney Note Added: 0002556
2004-09-28 12:58 louisdesjardins Note Added: 0002558
2004-09-28 13:14 jo-hannes Note Added: 0002559
2004-09-28 16:08 packetbell Note Added: 0002560
2004-09-28 20:59 cbradney Note Added: 0002564
2004-09-28 22:32 cbradney Note Added: 0002565
2004-09-28 22:32 cbradney Product Version => 1.3
2004-10-01 23:41 kirun0 Note Added: 0002609
2005-06-30 15:58 ringerc Relationship added related to 0002167
2005-09-17 07:26 ringerc Note Added: 0006623
2005-09-17 07:26 ringerc Status new => acknowledged
2005-09-17 22:31 christoph_s Note Added: 0006635
2006-05-08 16:27 mhanski Relationship added related to 0003759
2007-01-29 22:12 Olivier Note Added: 0015043
2007-01-31 12:11 faramond Note Added: 0015052
2007-08-26 11:50 louisdesjardins Relationship added related to 0006122
2008-01-18 05:21 hfinger Note Added: 0018633
2009-02-25 22:16 cbradney Relationship added has duplicate 0007830
2010-02-20 15:35 cbradney Relationship added has duplicate 0008858
2010-10-27 19:08 fschmid Status acknowledged => resolved
2010-10-27 19:08 fschmid Fixed in Version => 1.5.0svn
2010-10-27 19:08 fschmid Resolution open => fixed
2010-10-27 19:08 fschmid Assigned To => fschmid
2010-10-27 20:25 christoph_s Status resolved => closed