View Issue Details

IDProjectCategoryView StatusLast Update
0007006ScribusTypographypublic2019-06-04 20:56
Reporteruser2155Assigned Tojghali  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformAllOSAllOS Version
Product Version1.3.5svn 
Target VersionFixed in Version1.5.5.svn 
Summary0007006: Drop Cap little too large causing text baseline misalignment
DescriptionDrop Cap is little to big in scribus. This causes missalignment of text baselijnes in two column layout. Drop Cap's cap line should be on the height of first text row cap line and now it's higher.
Additional InformationScreenshot in attachment
Tagsdropcap
PatchNo

Relationships

has duplicate 0004830 closedavox Problem with vertical text alignment when using first letter capitalized in coloumn layout 
has duplicate 0014719 closedjghali Drop cap letter too large 

Activities

2008-05-06 05:53

 

scribus1.3.5.jpg (308,254 bytes)
scribus1.3.5.jpg (308,254 bytes)

user2155

2008-11-15 20:47

  ~0020659

Setting first line ascent to "font ascent" seems to resolve the problem. At least in column layout.

Kunda

2016-05-24 13:26

manager  

Kunda

2016-05-24 13:26

manager  

dropcap-issues.sla (15,017 bytes)

Eneen

2018-09-08 07:35

reporter   ~0045447

There's workaround for this: define character style for drop caps and reduce letter width and height by same amount there. 85% works flawlessly for me. It's also possible to adjust vertical position, so all controls are possible. But still default drop-caps letter size should be smaller.

jghali

2018-09-11 18:32

administrator   ~0045455

The method for computing drop cap size has been changed so that adding/removing a drop cap to a paragraph will not modify the text baseline anymore. Due to how default first line offset works, it is however still best for multi-column layout to use "font ascent" as first line offset.

Eneen

2018-09-17 13:27

reporter   ~0045466

Drop caps style is always assigned, even if I use NoStyle it's switched into Default. Qestion here: is it possible to allow NoStyle, so just paragraph style is used do drop caps and no character style is assigned to drop caps character?

Issue History

Date Modified Username Field Change
2008-05-06 05:53 user2155 New Issue
2008-05-06 05:53 user2155 File Added: scribus1.3.5.jpg
2008-06-03 16:25 jghali Relationship added has duplicate 0004830
2008-06-03 16:26 jghali Status new => confirmed
2008-11-15 20:47 user2155 Note Added: 0020659
2016-01-23 13:18 Kunda Tag Attached: dropcap
2016-05-24 13:26 Kunda File Added: Screenshot 2016-05-24 08.25.43.png
2016-05-24 13:26 Kunda File Added: dropcap-issues.sla
2017-04-05 13:20 jghali Relationship added has duplicate 0014719
2018-09-08 07:35 Eneen Note Added: 0045447
2018-09-11 18:19 jghali Summary Drop Cap little to large causing text baseline missalignment. => Drop Cap little too large causing text baseline missalignment.
2018-09-11 18:19 jghali Patch => No
2018-09-11 18:24 jghali Summary Drop Cap little too large causing text baseline missalignment. => Drop Cap little too large causing text baseline misalignment
2018-09-11 18:32 jghali Assigned To => jghali
2018-09-11 18:32 jghali Status confirmed => resolved
2018-09-11 18:32 jghali Resolution open => fixed
2018-09-11 18:32 jghali Fixed in Version => 1.5.5.svn
2018-09-11 18:32 jghali Note Added: 0045455
2018-09-17 13:27 Eneen Note Added: 0045466
2019-06-04 20:56 cbradney Status resolved => closed