View Issue Details

IDProjectCategoryView StatusLast Update
0008235ScribusImport / Exportpublic2016-12-02 20:48
Reporterkguciek Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status feedbackResolutionreopened 
PlatformPCOSLinuxOS VersionDebian Lenny
Product Version1.3.5svn 
Target VersionFixed in Version 
Summary0008235: Ability to embed font in PDF depends on unchecking "subset" field
DescriptionBefore I could select a font for embedding in PDF export dialog, I had to go to Font Preview, find that font and uncheck "subset". Until I did that, Scribus forced the fonts to be converted to curves.
Even if that's the expected behavior (?) there's info on this missing in the export window.
TagsNo tags attached.
Patch

Relationships

related to 0001413 closedFahad Support for OpenType alternate glyphs 

Activities

jghali

2009-07-02 20:59

administrator   ~0022066

Otf fonts cannot be embedded only subsetted in PDF versions supported by scribus, and fonts which contains more than 2048 glyphs are subsetted by default for pdf size reasons. So that's expected behavior.

kguciek

2009-07-03 07:47

reporter   ~0022087

""" Otf fonts cannot be embedded only subsetted in PDF versions supported by scribus """

So why was I able to embed them, and wasn't able to subset them?

It's the opposite of what you are telling.

Also, when user presses "Embed All" and not all fonts can be embedded, a message should be displayed saying why is it so.

jghali

2009-07-03 09:00

administrator   ~0022088

Otf fonts with TrueType outlines cannot be embedded as OpenType fonts in PDF versions supported by Scribus. They are embedded as *TrueType* fonts. Otf fonts with PostScript outlines cannot be embedded at all in PDF < 1.6. So i confirm what i wrote : otf fonts cannot be embedded in PDF versions supported by Scribus. Otf format is lost in all cases.

kguciek

2009-07-03 10:31

reporter   ~0022092

It appears to me that there are two distinct settings:

- if the font is embedded as a whole, or only a subset of it is embedded
- if the font is converted to True Type before embedding, or is't embedded at all

My question is, why are they anyhow connected?
Why cannot a font be converted to True Type AND subsetted?

jghali

2009-07-03 16:09

administrator   ~0022098

>> why are they anyhow connected?

Because embedded otf fonts are not supported by PDF versions supported by scribus.

>> if the font is converted to True Type before embedding, or is't embedded at all

That second setting cannot be a user choice because the behavior to adopt depends directly on the kind of outlines a specific otf font use. If otf font use TrueType outlines, we can embed the font as TrueType because getting a TrueType font from such a font is straightforward and such font is supported by pdf <= 1.5. If otf font use PostScript outlines, then we have no choice, the font *cannot* be embedded as is, that's pdf specs. For mathematical reasons otf fonts with PostScript outlines cannot be converted to TrueType with sufficient reliability and guarantee of quality. In general case those fonts cannot be converted as a Type1 font either, because of limitation in the number of glyphs a type1 font can contain. Consequence : otf fonts with PostScript outlines have to be subsetted. We convert such fonts as Type3 subsets. Direct consequence : for those fonts, embedding font as a whole or subsetting them cannot be a user choice either.

Font which contains more than 2048 glyphs and whose format allow them to be embedded... may be embedded by unchecking the "subset" field. However embedding them as a whole may have negative effect on pdf size.

kguciek

2009-07-04 07:23

reporter   ~0022110

It would be desirable to inform a user what actually will happen with each of the fonts. It could be put in parenthesis after each font name displayed on lists in the export window.

joolsr

2009-07-07 08:33

reporter   ~0022131

I think informing the user what is happening, ie for the case when fonts cant be embedded is a simple but useful bit of help here. I've been caught out by this myself many moons ago.

Kunda

2016-12-02 12:10

updater   ~0042600

@fahad can you weigh in on this? I'm just trying to ascertain what is CTL related. Thanks!

Fahad

2016-12-02 13:17

developer   ~0042603

@kunda this is not related to CTL.

Issue History

Date Modified Username Field Change
2009-07-02 20:09 kguciek New Issue
2009-07-02 20:59 jghali Note Added: 0022066
2009-07-02 20:59 jghali Status new => resolved
2009-07-02 20:59 jghali Resolution open => no change required
2009-07-02 20:59 jghali Assigned To => jghali
2009-07-02 20:59 jghali Status resolved => closed
2009-07-03 07:47 kguciek Note Added: 0022087
2009-07-03 07:47 kguciek Status closed => feedback
2009-07-03 07:47 kguciek Resolution no change required => reopened
2009-07-03 09:00 jghali Note Added: 0022088
2009-07-03 10:31 kguciek Note Added: 0022092
2009-07-03 16:09 jghali Note Added: 0022098
2009-07-03 23:10 jghali Assigned To jghali =>
2009-07-04 07:23 kguciek Note Added: 0022110
2009-07-07 08:33 joolsr Note Added: 0022131
2016-04-05 00:26 Kunda Relationship added related to 0001413
2016-12-02 12:09 Kunda Tag Attached: scribusctl
2016-12-02 12:10 Kunda Note Added: 0042600
2016-12-02 13:17 Fahad Note Added: 0042603
2016-12-02 20:48 Kunda Tag Detached: scribusctl