View Issue Details

IDProjectCategoryView StatusLast Update
0001413ScribusStory Editor / Text Framespublic2016-12-05 20:28
Reporterlouisdesjardins Assigned ToFahad  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSMandrakeOS Version10
Product Version1.3.0cvs 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0001413: Support for OpenType alternate glyphs
DescriptionIt would be super cool if we could have the possibility to select and automatically apply to a given text the alternate glyphs OpenType have in fonts such as Adobe Garamond Pro (real small caps, lowercase numbers, ligatures) instead of having to go through the long process of accessing these through the Extras>Insert Special menu.
Tags#please_test, fixed, HOST-Oman, scribusctl
PatchNo

Relationships

related to 0003661 closedavox Kerning works only for Postscript Type 1 Fonts 
related to 0008235 feedback Ability to embed font in PDF depends on unchecking "subset" field 
related to 0007241 closedFahad Add to styles check mark for automatic replacing some letters by ligatures. 
related to 0001851 closedavox Implement real automatic kerning 
related to 0009363 closedFahad Support 'smcp' small caps character substitution table 

Activities

uproar

2005-01-01 14:38

reporter   ~0003309

and it also would be great if they will be placed into the PDF and not converted to outlines...

plinnell

2005-04-06 13:41

viewer   ~0004093

moving to 1.3 as it is a feature request and is being worked on

mhanski

2005-05-08 18:40

developer   ~0004550

Does this feature include automatic ligature substituting with Type1 fonts, or should we submit a new RFE?

cbradney

2005-05-08 18:50

administrator   ~0004552

Yes, it does.

christoph_s

2005-09-21 22:37

administrator   ~0006668

From the mailing list (h++p://nashi.altmuehlnet.de/pipermail/scribus/2005-September/012967.html) by John Jordan:
"In the currrent version of InDesign there are several ligature options. You can turn on the f-ligatures, you can turn on "discretionary" ligatures (ct, st, etc.),
and/or you can turn on swash alternates."

Might be worth keeping in mind for further development.

PLucAuclair

2006-01-27 22:26

reporter   ~0008403

I don't know how much knowledge this part manager has on OpenType features. This document might be of interest.

http://www.fontshop.com/vFileStore/shop/info/FF/FF_OTF_user_guide.pdf

I really hope the whole feature set gets included. Thanks!

rabauke

2006-10-22 09:01

reporter   ~0013076

Does this issue include the full handling of ligatures?

Quoting fromhttp://www.opensubscriber.com/message/scribus%40nashi.altmuehlnet.de/1665857.html

----------
That's how Adobe did it in InDesign. The text is held internally
without ligatures. Thus, copying and pasting it to another
application pastes the non-ligatured text. Hyphenation and spelling
still work because they work on the internal text. The ligatures are
there just for display and printing (including PDF export).
  
Adobe did it so cleverly that the hyphenation changes even when
you have a ligature that needs to change to another ligature. E.g,
suppose you have a line ending in "official," but it's all on the same
line, so the ligature displayed is "ffi." You add a word in the middle
of the line and suddenly it needs to break as of-ficial. The line will
then end on of-, and the rest of the word on the next line will start
with the fi ligature, followed by "cial."
-----------

cbradney

2006-10-22 11:57

administrator   ~0013081

Scribus 1.3.4cvs stores the text internally as glyphs and will eventually render ligatures and glyph combinations separately. This is part of the major change in 1.3.4cvs - the new text system. It wont be complete in 1.3.4 though, but will form the base for the system.

Hellstorm

2008-01-01 17:35

reporter   ~0018451

In Xetex this works the following way:

If the Opentype font has ligatures enabled, all “Default“ ligatures are automatically written with Ligatures. If you don’t want a ligature at a given position, you have to insert a ZWNJ.

I think, this would be the best way.

Mike

2010-10-23 21:25

reporter   ~0024697

Is anybody working on that?

Mike

2010-10-23 21:45

reporter   ~0024698

Related topics: 0007241 and 0008164

christoph_s

2010-10-24 04:32

administrator   ~0024702

>>Is anybody working on that?

Yes, and we had to create a separate branch that's not even publically accessible, because major parts of the code have to be torn apart and rewritten. The changes are so big that we're currently glad if the code can be built, which doesn't mean that it already works as expected. Expect first usable results next year, at the earliest, when the dust has settled.

Mike

2010-10-24 09:01

reporter   ~0024709

Wow... nice to see that someone is working on this key feature :-)

josefec

2012-08-27 21:05

reporter   ~0028875

Has this come to any success or is it stalled?

ale

2012-08-28 10:01

manager   ~0028879

there has been work done on the oif branch by a contributor.

we are still testing how far he got...

let's hope for the best!
a.l.e

gabriel

2013-09-14 21:32

reporter   ~0030590

I know it's and old thread, but i'm wondering what's the state of this issue/feature

Kunda

2015-04-08 00:23

manager   ~0034849

http://ilovetypography.com/2014/10/22/better-ui-for-better-typography-adobe-petition/

Some fellow on twitter started(?) a 1000 pound bounty on this issue: https://twitter.com/notHennesBender/status/571328372170731520

Pander

2015-04-08 10:38

reporter   ~0034855

Please see https://www.bountysource.com/ and perhaps more people will make a donation for specific functionality. Important is to connect with Bounty Source via issue tracker.

JLuc

2015-09-01 16:22

developer   ~0036131

Last edited: 2015-09-01 16:22

View 2 revisions

some links :
- http://lists.freedesktop.org/mailman/listinfo/create mailinglist is about sharing resources between Free and Open Source Creative Projects.
- http://ilovetypography.com/2014/10/25/why-a-better-opentype-user-interface-matters/ why a better opentype UI matters
- http://blog.mmiworks.net/2015/06/designing-opentype-intro.html UI expert POV
- https://github.com/opensource-opentype/features features
- http://libregraphicsmeeting.org/2015/program/##nathan-willis-bringing-opentype-features-to-open-source

KrasnayaPloshchad

2015-12-09 06:04

reporter   ~0037887

Last edited: 2015-12-22 21:10

View 2 revisions

I think the ScribusCTL project will fix this bug.

Kunda

2016-04-10 04:22

manager   ~0039998

We need to test this when CTL is merged

user5122

2016-05-07 04:02

  ~0040859

Support for OpenType features (including but not limited to alternates support) has been added as part of the CTL work for a while, and we have a basic OPenType font features widget that allows controlling a selection of features and will need to be polished a bit. The underlying code supports any arbitrary font feature tag.

Kunda

2016-12-02 12:07

manager   ~0042599

Changed target version to 1.5.3 due to CTL release.

Issue History

Date Modified Username Field Change
2004-12-19 15:54 louisdesjardins New Issue
2005-01-01 14:38 uproar Note Added: 0003309
2005-04-06 13:41 plinnell Note Added: 0004093
2005-04-06 13:41 plinnell Product Version 1.2.1cvs => 1.3.0cvs
2005-05-08 18:40 mhanski Note Added: 0004550
2005-05-08 18:50 cbradney Note Added: 0004552
2005-06-26 07:59 ringerc Status new => acknowledged
2005-09-21 22:37 christoph_s Note Added: 0006668
2006-01-27 22:26 PLucAuclair Note Added: 0008403
2006-04-14 14:46 mhanski Relationship added related to 0001851
2006-04-16 17:14 mhanski Relationship added related to 0003661
2006-10-22 09:01 rabauke Note Added: 0013076
2006-10-22 11:57 cbradney Note Added: 0013081
2008-01-01 17:35 Hellstorm Note Added: 0018451
2008-02-12 12:32 plinnell Status acknowledged => assigned
2008-02-12 12:32 plinnell Assigned To => avox
2010-10-23 21:25 Mike Note Added: 0024697
2010-10-23 21:45 Mike Note Added: 0024698
2010-10-24 04:32 christoph_s Note Added: 0024702
2010-10-24 09:01 Mike Note Added: 0024709
2012-08-27 21:05 josefec Note Added: 0028875
2012-08-28 10:01 ale Note Added: 0028879
2013-09-14 21:32 gabriel Note Added: 0030590
2015-04-08 00:23 Kunda Note Added: 0034849
2015-04-08 10:38 Pander Note Added: 0034855
2015-09-01 16:22 JLuc Note Added: 0036131
2015-09-01 16:22 JLuc Note Edited: 0036131 View Revisions
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2015-12-09 06:04 KrasnayaPloshchad Note Added: 0037887
2015-12-22 21:10 Kunda Note Edited: 0037887 View Revisions
2015-12-22 21:10 Kunda Patch => No
2015-12-22 21:10 Kunda Target Version => Future Release - Nice to have
2015-12-22 21:11 Kunda Tag Attached: scribusctl
2016-04-04 23:47 Kunda Relationship added related to 0009363
2016-04-05 00:26 Kunda Relationship added related to 0008235
2016-04-05 00:27 Kunda Relationship added related to 0007241
2016-04-05 00:27 Kunda Relationship added related to 0008164
2016-04-05 00:51 Kunda Relationship deleted related to 0008164
2016-04-10 04:22 Kunda Tag Attached: #please_test
2016-04-10 04:22 Kunda Tag Attached: fixed
2016-04-10 04:22 Kunda Tag Attached: HOST-Oman
2016-04-10 04:22 Kunda Note Added: 0039998
2016-05-07 04:02 user5122 Note Added: 0040859
2016-12-02 12:07 Kunda Target Version Future Release - Nice to have => 1.5.3
2016-12-02 12:07 Kunda Note Added: 0042599
2016-12-05 20:26 cbradney Assigned To avox => Fahad
2016-12-05 20:26 cbradney Status assigned => resolved
2016-12-05 20:26 cbradney Resolution open => fixed
2016-12-05 20:26 cbradney Fixed in Version => 1.5.3.svn
2016-12-05 20:28 cbradney Status resolved => closed