View Issue Details

IDProjectCategoryView StatusLast Update
0001851ScribusStory Editor / Text Framespublic2006-04-25 23:35
ReporterplinnellAssigned Toavox  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Product Version1.3 
Target VersionFixed in Version 
Summary0001851: Implement real automatic kerning
Description Implement real automatic kerning (harder) from 0001677
TagsNo tags attached.
Patch

Relationships

related to 0001677 closedcbradney Change "Kerning" to "Tracking" in UI to more accurately reflect function 
related to 0001413 closedFahad Support for OpenType alternate glyphs 
related to 0001425 assignedavox Manual kerning dialogue shows automatic FreeType kerning choices... 
related to 0001424 acknowledged Manual kerning of letters at beginning and end of paragraph... 
related to 0001423 acknowledged Single key-stroke to kern letters... 
related to 0003661 closedavox Kerning works only for Postscript Type 1 Fonts 
related to 0001680 closedavox Automatic Kerning by user-defined pairs wanted 

Activities

avox

2005-10-10 23:50

administrator   ~0007030

Oh? Scribus already does kerning based on the tables in font files.

Maybe some kind of optical kerning? But then we'd need a patent-free algorithm how to do that...

avox

2006-04-25 23:34

administrator   ~0010454

Ok, this is either

* already implemented (using font kerning tables),
* a duplicate of 0001680, or
* a wontfix, since we don't have a free algorithm for optical kerning.

Closing.

Issue History

Date Modified Username Field Change
2005-04-08 06:00 plinnell New Issue
2005-04-08 06:00 plinnell Relationship added related to 0001677
2005-04-08 06:02 cbradney Summary Implement real automatic kerning (harder) => Implement real automatic kerning
2005-04-08 06:02 plinnell Severity minor => feature
2005-04-08 06:02 plinnell Product Version => 1.3
2005-04-08 06:02 plinnell Summary Implement real automatic kerning => Implement real automatic kerning (harder)
2005-04-08 06:02 cbradney Summary Implement real automatic kerning (harder) => Implement real automatic kerning
2005-04-16 09:41 cbradney Category Default => Story Editor / Text Frames
2005-10-10 23:50 avox Note Added: 0007030
2006-04-14 14:46 mhanski Relationship added related to 0001413
2006-04-14 14:48 mhanski Relationship added related to 0001425
2006-04-14 14:48 mhanski Relationship added related to 0001680
2006-04-14 14:48 mhanski Relationship added related to 0001424
2006-04-14 14:49 mhanski Relationship added related to 0001423
2006-04-16 17:10 mhanski Relationship added related to 0003661
2006-04-17 01:03 plinnell Relationship deleted related to 0001680
2006-04-17 11:04 mhanski Relationship added related to 0001680
2006-04-25 23:34 avox Note Added: 0010454
2006-04-25 23:34 avox Status new => resolved
2006-04-25 23:34 avox Resolution open => no change required
2006-04-25 23:34 avox Assigned To => avox
2006-04-25 23:35 avox Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames