View Issue Details

IDProjectCategoryView StatusLast Update
0008334ScribusOS-MacOSXpublic2009-08-11 22:15
ReporterTynstar Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformMacOSMac OSOS Version10.5
Product Version1.3.5 
Target VersionFixed in Version 
Summary0008334: Document windows are not independent on Mac
DescriptionDespite the commendable work on the native Mac version, Scribus still includes one major UI flaw:

The document windows are displayed inside one "main" window, which also holds the toolbars. The document windows are not minimised to the Dock, but "iconify" to the lower right corner of the main window. One has to be careful not to move document windows out of the viewport of the main window. All in all, this is simply the classic multiple document interface (MDI) used on the Windows platform.

On a Mac, though, this interface feels foreign. For example, in a native Mac application, one can use the hotkey "Command-<" to switch between document windows, and one can use Expose to quickly find misplaced document windows.

I guess that for Scribus, the main window has to go away and the toolbars have to be moved to the document windows (or to a separate palette window, which seems to be the more popular choice).
TagsNo tags attached.
Patch

Relationships

duplicate of 0001926 closedale Single-document interface mode 

Activities

jghali

2009-08-11 22:15

administrator   ~0022312

This is a duplicate of issue 0001926

Issue History

Date Modified Username Field Change
2009-08-11 22:08 Tynstar New Issue
2009-08-11 22:15 jghali Note Added: 0022312
2009-08-11 22:15 jghali Relationship added duplicate of 0001926
2009-08-11 22:15 jghali Duplicate ID 0 => 1926
2009-08-11 22:15 jghali Status new => resolved
2009-08-11 22:15 jghali Resolution open => duplicate
2009-08-11 22:15 jghali Assigned To => jghali
2009-08-11 22:15 jghali Status resolved => closed
2014-10-08 18:37 Kunda Category Mac OS => OS-MacOSX