View Issue Details

IDProjectCategoryView StatusLast Update
0001926ScribusUser Interfacepublic2016-05-15 22:53
ReporterringercAssigned Toale  
PrioritynoneSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Platformx86 LinuxOSFedora CoreOS Version3
Product Version 
Target VersionFixed in Version 
Summary0001926: Single-document interface mode
DescriptionLots of people don't like MDIs (Multiple Document Interfaces). It would be interesting if Scribus could be run with a one-window-per-document interface, either with floating tools & menus (GIMP, Photoshop for Mac, Quark and InDesign for mac, etc style) or with tools & menus on each document.
Tagsindigodock
Patch

Relationships

has duplicate 0008334 closedjghali Document windows are not independent on Mac 
related to 0002028 acknowledged Fullscreen mode 
related to 0007018 new Single instance per user support 
child of 0007017 acknowledged Metabug: Multiple instance safety / single-instance-per-user support 

Activities

fschmid

2005-04-27 16:31

administrator   ~0004441

Maybe we can use the qt-ext-mdi extension for this.

ringerc

2005-04-30 07:42

reporter   ~0004459

Seems to be part of KDevelop ... I couldn't find much info on using it as a standalone lib. It's pretty large at some 17,000 lines. It also appears to rely on KDE code.

Permit me to say "drat."

ringerc

2005-04-30 07:53

reporter   ~0004460

QWorkSpace looks like its deprecated in Qt4; there's no replacement yet (we can just use Q3WorkSpace for now and depend on the Qt3 support library) but it looks like they're thinking of one for Qt4.1.

I think it might be a good time to ask TrollTech about QWorkSpace being capable of MDI or "real managed window" modes somewhat like qextmdi . I'll drop them a note.

http://doc.trolltech.com/4.0/porting4.html#qworkspace
http://doc.trolltech.com/4.0/q3workspace.html

(Hope mantis doesn't butcher those URLs too)

Kunda

2016-05-14 04:03

manager   ~0041014

self-evident and already mostly implemented in 1.5.x
Also devs are talking about integrating indigoDock in 1.5.4...
Resolving this ticket.

Issue History

Date Modified Username Field Change
2005-04-27 07:27 ringerc New Issue
2005-04-27 07:33 ringerc Status new => acknowledged
2005-04-27 16:31 fschmid Note Added: 0004441
2005-04-30 07:42 ringerc Note Added: 0004459
2005-04-30 07:53 ringerc Note Added: 0004460
2005-06-01 22:21 ringerc Relationship added related to 0002028
2006-04-20 23:28 cbradney Status acknowledged => assigned
2006-04-20 23:28 cbradney Assigned To => cbradney
2008-05-11 16:38 ringerc Relationship added related to 0007018
2008-05-11 16:39 ringerc Relationship added child of 0007017
2009-08-11 22:15 jghali Relationship added has duplicate 0008334
2010-05-18 12:47 cbradney Assigned To cbradney =>
2010-05-18 12:47 cbradney Status assigned => acknowledged
2016-05-14 04:03 Kunda Note Added: 0041014
2016-05-14 04:03 Kunda Status acknowledged => resolved
2016-05-14 04:03 Kunda Resolution open => fixed
2016-05-14 04:03 Kunda Assigned To => ale
2016-05-14 04:04 Kunda Tag Attached: indigodock
2016-05-15 22:53 cbradney Status resolved => closed