View Issue Details

IDProjectCategoryView StatusLast Update
0008969ScribusStory Editor / Text Framespublic2014-07-10 03:26
Reporterzoffix Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformPCOSUbuntuOS Version9.10
Product Version1.3.7svn 
Target VersionFixed in Version 
Summary0008969: Crash When Pasting into Story Editor
DescriptionI'm experiencing Scribus crashing with this message: "Scribus crashes due to Signal 0000011 Segmentation fault"

I've experienced this crash before with random amounts of text (not sure if it was always the same font)

Today, I isolated the problem and am able to always reproduce it in the attached file.
Steps To Reproduce1) Install the font attached and open the Scribus file.

2) There are six products on that one page. I can always reproduce the crash with the product 0000004 named "Mepiform® Self-Adherent Scar Care Dressing".

3) The crash is reproduced with the *description* of that product that right now starts with "Hypergel® effectively debrides...."

4) Open the attached "text-to-paste" file and do "Select all" and copy into the clipboard. The crash actually happens when pasting the very first line in that file, which I assume is a new-line character.

5) select the text frame with product's description, as mentioned above, and press CTRL+T to bring up story editor.

6) Press CTRL+V to paste the text that we have copied.

7) Crash occurs.
TagsNo tags attached.
Patch

Activities

zoffix

2010-03-25 13:52

reporter  

scribus-file.sla (131,362 bytes)

zoffix

2010-03-25 13:53

reporter  

Helios.PFB (33,496 bytes)

zoffix

2010-03-25 13:53

reporter  

text-to-paste (504 bytes)
Topical silicone has empirically been shown to have positive impact on hypertrophic scars and keloids. It may take from 3 months up to a year or more to improve an old scar, depending on the condition of the scar tissue. Mepiform shall optimally be worn 24 hours a day. It is recommended that Mepiform is removed once a day, e.g. when showering or bathing, for inspection and washing of the skin. For prophylactic treatment, Mepiform shall be used for 2-6 months depending on the condition of the scar.
text-to-paste (504 bytes)

zoffix

2010-03-25 13:55

reporter   ~0023608

Umm.. didn't expect Mantis to parse the numbers like this, as bug report numbers..

The signal number is eleven. And the product is number four. It's in the middle row on the right.

Kunda

2014-07-08 17:13

updater   ~0032593

Unable to reproduce on current 1.5svn (r19331)
Firash was unable to reproduce on 1.4.5svn
zoffix, does this issue still persist for you?

owencook

2014-07-10 03:24

reporter   ~0032650

Last edited: 2014-07-10 03:25

View 2 revisions

Unable to reproduce with Rev 19332

Kunda

2014-07-10 03:26

updater   ~0032651

Closing. If OP can reproduce then they're welcome to re-open the issue. Thanks for the report

Issue History

Date Modified Username Field Change
2010-03-25 13:52 zoffix New Issue
2010-03-25 13:52 zoffix File Added: scribus-file.sla
2010-03-25 13:53 zoffix File Added: Helios.PFB
2010-03-25 13:53 zoffix File Added: text-to-paste
2010-03-25 13:55 zoffix Note Added: 0023608
2014-07-08 17:13 Kunda Note Added: 0032593
2014-07-08 17:13 Kunda Status new => feedback
2014-07-10 03:24 owencook Note Added: 0032650
2014-07-10 03:25 Kunda Note Edited: 0032650 View Revisions
2014-07-10 03:26 Kunda Note Added: 0032651
2014-07-10 03:26 Kunda Status feedback => closed
2014-07-10 03:26 Kunda Resolution open => unable to reproduce
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames