View Issue Details

IDProjectCategoryView StatusLast Update
0009546ScribusFontspublic2019-03-14 13:58
Reporterale Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0009546: Don't silently discard bad fonts, but show them as non selectable
DescriptionWe have many users who come to the mailing list and the IRC channels and complaining that Scribus can't find their fonts.

It would probably be helpful if Scribus could list all fonts that it finds and mark the bad one as unusable. Those fonts should at least be shown in the Preferences and maybe also in the Font list*


* We probably need also a way to reduce the number of fonts shown in the PP and style editor... but this will be the subject of a separate request...
Tagsfont selection
PatchNo

Relationships

duplicate of 0015550 closedjghali Add a tab to Preferences > Fonts with the rejected fonts 
related to 0004892 new not all fonts shown up in dropdown list of storyeditor 
related to 0012985 assignedavox Improve font-checking script: discards potentially dangerous fonts during launch 
related to 0008721 new changing the upper/lowercase-spelling of fonts confuses scribus 

Activities

Kunda

2015-04-13 11:59

manager   ~0034918

Re-categorizing as 'Fonts'

jghali

2019-03-14 13:58

administrator   ~0046009

Resolved by 0015550

Issue History

Date Modified Username Field Change
2010-12-01 19:14 ale New Issue
2015-04-13 11:59 Kunda Patch => No
2015-04-13 11:59 Kunda Note Added: 0034918
2015-04-13 11:59 Kunda Category General => Fonts
2015-04-13 12:02 Kunda Relationship added related to 0004892
2016-04-04 20:04 Kunda Relationship added related to 0012985
2016-04-04 20:04 Kunda Relationship added related to 0008721
2016-04-04 22:43 Kunda Tag Attached: font selection
2019-01-24 15:38 ale Relationship added related to 0015550
2019-03-14 13:58 jghali Assigned To => jghali
2019-03-14 13:58 jghali Status new => resolved
2019-03-14 13:58 jghali Resolution open => duplicate
2019-03-14 13:58 jghali Note Added: 0046009
2019-03-14 13:58 jghali Relationship replaced duplicate of 0015550
2019-03-14 13:58 jghali Status resolved => closed