View Issue Details

IDProjectCategoryView StatusLast Update
0009574ScribusUser Interfacepublic2012-01-03 19:16
Reporterchocobanana Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.3.9 
Target VersionFixed in Version 
Summary0009574: Lots of vertical pixels wasted in 1.3.9 interface
DescriptionScribus 1.3.9's UI can be better optimized to save on vertical pixels usage. Since documents are mostly vertically distributed, this is a crucial concern.

The 1st area of improvement are the status bars. They could be either merged or made both option, the user should have the choice.

The 2nd improvement is placing the toolbar vertically on the left side of the screen.

The 3rd area for improvement concerns Mac OS only and it involves attaching the toolbars to the document windows instead of having a master Scribus container window, therefore eliminating the pixel waste from a second window title bar.

I attached a screenshot that shows how could Scribus UI be best optimized for screen real estate without possibly involving huge implementation efforts. It was made on Mac OS.
TagsNo tags attached.
Patch

Relationships

duplicate of 0007368 closedcbradney Redesign bottom part of workspace 

Activities

chocobanana

2010-12-10 19:48

reporter  

ale

2010-12-10 20:10

manager   ~0025051

1/ no option, please: the two toolbars have to be merged!

2/ you can already do that... just drag the toolbar in there...

3/ it may or may not be possible... i fear it depends on qt...

cbradney

2010-12-10 21:52

administrator   ~0025053

Changing priority and severity to something reasonable.

subeditor

2010-12-10 22:31

reporter   ~0025055

Posted 4 years ago, already assigned: http://bugs.scribus.net/view.php?id=7368

zerubbabel

2012-01-02 11:29

reporter   ~0027428

I was very disappointed to see that in 1.4 the status bar area was still not condensed. It is such a huge waste of precious vertical pixels, especially for laptop users. PLEASE up the priority of this improvement!

Mike

2012-01-03 07:55

reporter   ~0027433

I think that's duplicate of 0007368

Issue History

Date Modified Username Field Change
2010-12-10 19:45 chocobanana New Issue
2010-12-10 19:48 chocobanana File Added: Scribus UI vertical space optimization.jpg
2010-12-10 20:10 ale Note Added: 0025051
2010-12-10 21:52 cbradney Note Added: 0025053
2010-12-10 21:52 cbradney Priority high => normal
2010-12-10 21:52 cbradney Severity major => minor
2010-12-10 22:31 subeditor Note Added: 0025055
2012-01-02 11:29 zerubbabel Note Added: 0027428
2012-01-03 07:55 Mike Note Added: 0027433
2012-01-03 19:16 cbradney Relationship added duplicate of 0007368
2012-01-03 19:16 cbradney Status new => resolved
2012-01-03 19:16 cbradney Resolution open => duplicate
2012-01-03 19:16 cbradney Assigned To => cbradney
2012-01-03 19:16 cbradney Status resolved => closed