View Issue Details

IDProjectCategoryView StatusLast Update
0007368ScribusUser Interfacepublic2014-04-06 18:36
ReporterMike Assigned Tocbradney  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version1.3.5svn 
Target VersionFixed in Version1.5.0svn 
Summary0007368: Redesign bottom part of workspace
DescriptionRedesign bottom part of workspace. Two lines are (from my point of view) too much for 15" monitors.

Additional Information - maybe would be better to reduce a scale of bottom icons? or
 - add a possibility to show/hide second line (position of cursor with indicator of saving)
TagsNo tags attached.
Patch

Relationships

has duplicate 0009574 closedcbradney Lots of vertical pixels wasted in 1.3.9 interface 
related to 0008441 closedale A better use of status bar 
related to 0009042 closedcbradney Unused space in status bar area 
related to 0009177 new Feature Request -- full path for Image in the Properties Dialog and/or Context Menu>Information 

Activities

2008-09-06 07:47

 

bottom.png (42,754 bytes)
bottom.png (42,754 bytes)

ale

2008-09-06 11:34

manager   ~0020201

Last edited: 2008-09-06 12:52

i wonder if all those icons are needed in the status bar or if some of them would better fit in own toolbars which would then be optional.

proposal:

!zoom

* create a zoom toolbar with the three icons (+ 1 -) for the beginners
* let advanced user use shortcuts and hide the icons
* leave only the text box with arrows in the status bar
* change the increment of the arrows to the ones used also by the + - buttons (which are the same as the one applied by ctrl+mouseweel)
* if there is a need for other steps, give an option to set the step in the preferences

!page browsing

* leave only the drop down list in the status bar
* create a toolbar with |< < [page|v] > ]

!preview mode

* use a drop down button (the way it's done for the color management button) instead of a button and a select box

!x/y position

* use only one box for both coordinates
* if the extra workload due to the need to update both coordinates for every mouse movement is noticeable, leave two boxes, but only one label
* since the position is never shown when a status message appears, the position could be written in the "message/status" area of the status bar.


voilĂ : just a few thoughts

ps.: ... should i do it?

2008-09-06 12:13

 

bottom_oneline.png (15,995 bytes)
bottom_oneline.png (15,995 bytes)

ale

2008-09-06 13:40

manager   ~0020203

editing the screenshot in the gimp, my went to the gimp's status bar, and since gimp is well known for its progressive user interface (well, i'm on the side of the ones who likes it!), i've developed further my proposal (with a new screenshot:

* on the left side unit and zoom like in the gimp
* in the middle the message bar with the mouse position when nothing else is shown
* the progress bar is shown over the whole message bar
* on the right side first the page number, then layer and further general input and, at the end, all the small icons for specific tasks

and now? what you think about it?

2008-09-06 13:42

 

bottom_oneline_2.png (16,352 bytes)
bottom_oneline_2.png (16,352 bytes)

cbradney

2008-09-06 17:37

administrator   ~0020206

Any changes here require a rewrite of the whole of window management. No chance for this in 1.3.5.

ale

2008-09-06 20:19

manager   ~0020207

i've never thought of a change before 1.3.5 is out! :-)

Mike

2008-09-07 07:04

reporter   ~0020208

I think that bottom oneline 2 is perfect.
I only suggest small improvement:

 - the position of cursor seems to not so good looking (comma between numbers disturbs me :-)
 - the better one is from bottom oneline

 - or my idea: X/Y Pos: 143.678 / 231.246 mm
 - short complete title
 - space between number and virgule is important because of readability
 - unit is only for control

I will look forward to changes ;-)

Mike

2009-02-23 00:16

reporter   ~0021200

I will give some other improvement.

I think that would be great to change zoom step from +/- 1 to similar like has Inkscape. There is changing. When the number is small the step is 1 and is increasing with magnification.

avox

2009-02-23 21:29

administrator   ~0021218

1) what about just "x:12.34 y:43.21"?
2) pagenumber box needs to be larger so we can show page names / masterpage names in the future

Mike

2009-02-24 14:39

reporter   ~0021220

Both improvement included. I create new layout.

2009-02-24 14:39

 

bottom_oneline3.png (21,399 bytes)
bottom_oneline3.png (21,399 bytes)

subeditor

2010-04-24 09:41

reporter  

statusbar.png (26,208 bytes)
statusbar.png (26,208 bytes)

subeditor

2010-04-24 09:45

reporter   ~0023799

Last edited: 2010-04-24 09:53

View 3 revisions

I moved here from http://bugs.scribus.net/view.php?id=9042

Well, some propositions. Lets think in "purpose" approach.
I draw 1280 pixels wide canvas (resolution that most of LCDs are able to show).
(http://bugs.scribus.net/file_download.php?file_id=4721&type=bug - sorry for ex?es space on picture)

I arranged items on status bar by theirs purposes. There is lot space still.

1. Tools status area. Here I placed buttons/icons to indicate modes that are not indicated in any other way (by mouse shape, frame details or etc). Cause we have some space, may be it would be nice (in future) to place here some customizable buttons.
2. Zoom area.
3. Page navigation area.
4. Active layer indicator/selection.
5. View modes.
6. Coordinates (combined with the units selector).

Progress indicator are not very helpful imo, it may be implemented in Quark style (where it appears only while saving).

If any elements will be added/removed they should be arranged by purposes, imo.

Mike

2010-04-24 11:28

reporter   ~0023803

Layout is very nice. I think the best of all suggestions.

Some notes:
 - Progress indicator would be ok for me.
 - But there is one icon missing - Preview mode menu (Normal vision, Protanopia etc.)

Proposition: What about add this menu hidden into icon of eye by small arrow? By the identical way like configure CMS which is next to it.

ale

2010-04-24 12:10

manager   ~0023805

hi subeditor && mike,

please consider that i plan to remove as many items as possible from the status (and eventually add some which are not there yet).

we have to put in the status bar the things that everybody should always have on his monitor + some notices on the status.

we have to think about what the function of a status bar is...

please read my first comment: i plan to move several elements to their own toolbars.
this will almost certainly happen with the zoom buttons (only a the text fields with arrows will survive) and the page browser (i plan to keep the text field (with or without drop down; with or without information on the page name and/or its master page).
there will be a toolbar for the zoom and one for the page browser with -- at least -- the same elements as the ones which are currently in the status bar.

also: there will be a bigger notification area which certainly be used by the progress bar.
it's standard (when nothing special happens) content may be the coordinates of the mouse.
or we could implement a similar hint system like in inkscape...

finally, 1280 is a realistic width, but it should imo be the target width, not the minimal one.

ah, and the status information on guides, undo and co: i'm not sure yet, which information is useful and how to show it... i think this proposition needs some more work...

subeditor

2010-04-25 14:46

reporter   ~0023814

As I already wrote main function of a status bar is to display statuses/switches that
- should be visible all the time, are "OVERALL" (ie actual in all/most cases);
- are not displayed in any other way (by mouse pointer shape, frame details etc).

+1 for combine preview and preview mode buttons.
+1 for compact zoom area - numeric indicator is enough.
Minimal resolution is 1024, I think.

cbradney

2010-04-25 17:47

administrator   ~0023815

We need the status bar messages .. a lot messages are planned for future versions,

Issue History

Date Modified Username Field Change
2008-09-06 07:47 Mike New Issue
2008-09-06 07:47 Mike File Added: bottom.png
2008-09-06 11:34 ale Note Added: 0020201
2008-09-06 12:13 ale File Added: bottom_oneline.png
2008-09-06 12:52 ale Note Edited: 0020201
2008-09-06 13:40 ale Note Added: 0020203
2008-09-06 13:42 ale File Added: bottom_oneline_2.png
2008-09-06 17:37 cbradney Note Added: 0020206
2008-09-06 20:19 ale Note Added: 0020207
2008-09-07 07:04 Mike Note Added: 0020208
2009-02-23 00:16 Mike Note Added: 0021200
2009-02-23 21:29 avox Note Added: 0021218
2009-02-24 14:39 Mike Note Added: 0021220
2009-02-24 14:39 Mike File Added: bottom_oneline3.png
2009-03-15 01:41 christoph_s Status new => acknowledged
2009-09-18 21:40 ale Relationship added related to 0008441
2010-04-22 22:02 ale Relationship added related to 0009042
2010-04-24 07:36 ale Status acknowledged => assigned
2010-04-24 07:36 ale Assigned To => ale
2010-04-24 09:41 subeditor File Added: statusbar.png
2010-04-24 09:45 subeditor Note Added: 0023799
2010-04-24 09:50 subeditor Note Edited: 0023799 View Revisions
2010-04-24 09:53 subeditor Note Edited: 0023799 View Revisions
2010-04-24 11:28 Mike Note Added: 0023803
2010-04-24 12:10 ale Note Added: 0023805
2010-04-25 14:46 subeditor Note Added: 0023814
2010-04-25 17:47 cbradney Note Added: 0023815
2010-06-19 21:09 ale Relationship added related to 0009177
2012-01-03 19:16 cbradney Relationship added has duplicate 0009574
2014-04-06 10:36 cbradney Assigned To ale => cbradney
2014-04-06 10:36 cbradney Status assigned => resolved
2014-04-06 10:36 cbradney Fixed in Version => 1.5.0svn
2014-04-06 10:36 cbradney Resolution open => fixed
2014-04-06 18:36 christoph_s Status resolved => closed