View Issue Details

IDProjectCategoryView StatusLast Update
0010079ScribusTypographypublic2016-05-28 10:02
ReporterMerton Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status newResolutionopen 
PlatformOSMicrosoft Windows 7OS Version
Product Version1.4.0svn 
Target VersionFixed in Version 
Summary0010079: Form fields show strange characters when read by Adobe Reader X
DescriptionI've been a Scribus user for about a year now, but am having an issue with reading PDFs in Adobe Reader X (the latest version at this time). I have a PDF with text frames and form fields (text fields and a push button), but the text of the form fields displays as weird characters. It's almost as if there is a problem in the character set.

      I noticed this problem while using Scribus 1.3.3.13 and upgraded to 1.4.0.rc5, but this didn't help. The PDF opens perfectly in Adobe 9 (I had Adobe v9.4.5 before upgrading), but not in Adobe X (v10.1.0). There is no such problem in a PDF made in Adobe Acrobat Pro (version 9) using both Adobe Reader 9 and X, so it's only the PDFs I've made in Scribus, and only with Adobe Reader X. I'm running the latest version of Scribus and GhostScript v9.02 on Windows 7, though the same problem occurs when reading the PDF on Windows Vista systems. Additionally, I'm not using any crazy or rare fonts: the PDF fields use Verdana, though I have tried the standard Times New Roman as well.
Steps To Reproduce1. Create new SLA document
2. Add form fields (text field or push button)
3. Export to PDF
4. Open PDF in Adobe Reader X
5. Type into text fields (not required for push button)
Additional InformationI've also noticed a few differences between the PDFs made in Scribus and Adobe Acrobat Pro which may account for this, but I have no idea. My Scribus PDF says it's not a "Tagged PDF," has a lower "PDF Version" than the Adobe PDF (1.4 compared with 1.7), and has "Page Extraction" allowed. I'm getting these options by clicking "File -> Properties" in Adobe Reader X and am not sure if they actually contribute to my problem, I just figured more information couldn't hurt.

I had originally used the PDF 1.4 Compatibility option, but I have tried PDF 1.5 with no improvement. Also, the text fields within my PDF default to Helvetica, though I have tried both Times and Courier. None of these has affected the issue.
Tags#please_test, acrobat
Patch

Relationships

has duplicate 0010148 closedjghali PDF Fields problem with Acrobat 10.1.0 
has duplicate 0010224 closedjghali Exporting PDF forms does not work with Adobe Reader, when exporting 1.4 or 1.5 
related to 0009159 new PDF form fields don't import correctly 
related to 0012887 new PDF Form multi-line text fields error 
child of 0003831 acknowledged Metabug: PDF Forms 

Activities

Merton

2011-06-27 14:58

reporter  

strangechars.png (354,530 bytes)
strangechars.png (354,530 bytes)

Merton

2011-06-27 14:58

reporter  

employment_application.sla (679,369 bytes)

Merton

2011-06-27 14:59

reporter  

employment_application.pdf (1,256,976 bytes)

Kunda

2016-05-27 14:09

updater   ~0041481

Peter, when you have a moment, would you test this?

PeterBenedek

2016-05-28 10:02

developer   ~0041496

Ubuntu 16.04 it does not exits already Adobe Reader.

I cannot test! :-(

Issue History

Date Modified Username Field Change
2011-06-27 14:58 Merton New Issue
2011-06-27 14:58 Merton File Added: strangechars.png
2011-06-27 14:58 Merton File Added: employment_application.sla
2011-06-27 14:59 Merton File Added: employment_application.pdf
2011-07-27 16:11 jghali Relationship added has duplicate 0010148
2011-08-28 13:18 jghali Relationship added has duplicate 0010224
2016-03-08 05:49 Kunda Relationship added related to 0009159
2016-03-08 05:49 Kunda Relationship added related to 0012887
2016-03-08 05:54 Kunda Relationship added child of 0003831
2016-03-30 22:04 Kunda Tag Attached: acrobat
2016-03-30 22:40 Kunda Tag Attached: #please_test
2016-05-27 14:09 Kunda Note Added: 0041481
2016-05-28 10:02 PeterBenedek Note Added: 0041496