View Issue Details

IDProjectCategoryView StatusLast Update
0013487ScribusStory Editor / Text Framespublic2020-04-30 09:30
ReporterLaser Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSArchlinuxOS Versionuptodate
Product Version1.5.1svn 
Target VersionFixed in Version1.5.6.svn 
Summary0013487: Removing lines in numbered lists doesn't reorder numbers
DescriptionIf you remove a line from a numbered list, the number gets lost.
Steps To ReproduceYou have a numbered list like:
1.
2.
3.

Now remove line 2 in the editor and you get:
1.
3.

Any change (moving to a, b, c or Level 2) will order correct again to:
a. (or 01.)
b. (or 02.)

Change back:
1.
2.
TagsHOST-Oman, lists
PatchYes

Relationships

related to 0013489 closedKunda Differences in levels in numbered lists 
related to 0013731 closedjghali Numerated Lists: refresh bug 
related to 0013728 resolvedjghali Issue when undoing numbered lists 
related to 0013730 new Numerated Lists: no whitespace between list item number and text of that list item 
related to 0012006 new Cannot easily delete bullets within a bullet list Paragraph Style 
has duplicate 0013729 closed Numerated Lists: injecting list item between 2 current existing ones doesn't update correctly 

Activities

JLuc

2015-11-01 16:33

developer   ~0037145

To update numbering, one has to use "Extra > Update document" option.
Maybe the need could detected and the update automated ?

Some changes are allready automatically done when editing a numbered list.
Sometimes also, scribus detects that the number should be changed after some edit, but scribus doesnt do the update : a '?' is used to temporarily replace the number. I think scribus should call the update instead of replacing with '?'.

cbradney

2015-11-03 17:23

administrator   ~0037195

This bug is just about not having to run Update Document manually.. this was obviously missed in the code when updating styles.

anood

2015-11-05 05:12

reporter   ~0037235

I'm working on it =)

anood

2015-11-10 11:56

reporter   ~0037381

as JLuc said , it turns out that when click update the text frame doesn't update document and numbers
so I called
        m_doc->updateNumbers(true);
    m_doc->updateMarks(true);
    m_doc->regionsChanged()->update(QRect());

 in the function: updateTextFrame() to update every things

I don't know why scribus use "?" then replace it with "@" ,
and " Default Paragraph Style" is the same as " no Style " , because when I wrote any text and I didn't choose any style , it always choose the "Default Paragraph Style " .

anood

2015-11-10 11:57

reporter  

issue13487.patch (468 bytes)
Index: scribus/ui/storyeditor.cpp
===================================================================
--- scribus/ui/storyeditor.cpp	(revision 20483)
+++ scribus/ui/storyeditor.cpp	(working copy)
@@ -2998,6 +2998,9 @@
 	m_textChanged = false;
 	seActions["fileRevert"]->setEnabled(false);
 	seActions["editUpdateFrame"]->setEnabled(false);
+	m_doc->updateNumbers(true);
+	m_doc->updateMarks(true);
+	m_doc->regionsChanged()->update(QRect());
 	emit DocChanged();
 }
 
issue13487.patch (468 bytes)

JLuc

2015-11-10 22:31

developer   ~0037406

Last edited: 2015-11-10 22:33

View 3 revisions

various answers :

- marks update has allready been recently improved in http://scribus.net/websvn/listing.php?repname=Scribus&sc=1&rev=20528
Are you sure its required to add a one more call to updateMark ?
- as for updating numbered lists, it seems improved, but it still takes several/some sort of actions for a numbered list to get updated after deleting a line. Dont you meet that behaviour ?

- as for ? : testing the numbered list feature shows that it appears in the canvas display when scribus first creates a new numbered paragraph inside an existing list. I'm not sure why it's not displayed immediately as a number. That can/should possibly be improved.

- I guess the @ is used for the story editor view ?

- I dont think "Default Paragraph Style" is the same as "no Style", execpt when your frame has a default paragraph style set to "Default Paragraph Style"; but how is this related to this issue ?

JLuc

2015-11-11 07:40

developer   ~0037415

It would be nice when, instead of displaying a ? when adding a line, a call to m_doc->updateNumbers(true); would enable to display the correct number.

+ it would be nice when deleting a numbered line would immediately call m_doc->updateNumbers(true); so the numbering is correctly adapted.

+ it would be perfect when m_doc->updateNumbers(true); is only called when strictly required. That's because the CPU cost could be high on big document, and calling it too often when not necessary could lead to slow scribus.

So first detect that it really should be called (have we suppressed a numbered paragraph ? have we added a to-be-numbered paragraph) before calling it.

anood

2015-11-11 09:39

reporter   ~0037417

I dont think "Default Paragraph Style" is the same as "no Style", execpt when your frame has a default paragraph style set to "Default Paragraph Style"; but how is this related to this issue ?
it's not related to this issue. I have noticed that when I changed paragraph effects for "Default Paragraph Style" to numbering effects , and I wrote any things in story editor with out chosen any style , it takes the default style .
see the attached image
I think that I will change from "no style" to the "Default Paragraph Style" .

anood

2015-11-11 09:41

reporter   ~0037418

I'll try to find where is the best place to call m_doc->updateNumbers(true);
thanks for your replay :)

anood

2015-11-11 09:41

reporter  

JLuc

2015-11-23 11:49

developer   ~0037603

any progress on this anood ?

Kunda

2016-04-20 16:16

updater  

Numerated-lists.gif (92,275 bytes)
Numerated-lists.gif (92,275 bytes)

FirasH

2017-06-18 08:52

developer   ~0044060

I cannot reproduce this issue with 1.5.4.svn (22063).
Anyone can confirm?

PeterBenedek

2017-06-18 17:17

developer   ~0044063

Last edited: 2017-06-19 05:56

View 3 revisions

Tested: Linux Mint 18.1; r22072

Outside the style = work well

Inside the style = not work :-(
- Make new paragraph style (NumList)
- Paragraph Effect -- Enabled Numbered List
- Make new TextBox
- Apply NumList style in the TextBox
- Press: Enter - Enter - Enter etc.
- Appear: ?
-- Comment: If now apply "Export - Save as PDF" then, in the PDF document appear Instead of numbers: ?
- Extras - Update Document (The list is displayed)
- You delete some numbers.

The list is broken (original problem). :-(

jghali

2020-04-08 13:25

administrator   ~0047495

This issue should be retested against recent 1.5.6.svn build (at least r23535).

JLuc

2020-04-08 14:06

developer   ~0047497

Last edited: 2020-04-08 14:10

View 2 revisions

@jghali here is test result :
- when applying "numbered list" style localy, number is immediately computed and displayed and updated when one of the line is deleted
- when defining a paragraph style that is number-listed and applying it to a set of paragraphs, a '?' appears in place of the number. It requires "Extra>Update document" to compute the numbers and replace the ?. And then, deleting one of the lines doesnt update the following numbers.

Hmm but not so recent : Version de Scribus 1.5.6.svn 06 Novembre 2019. Too old ?

jghali

2020-04-08 15:04

administrator   ~0047498

Last edited: 2020-04-08 15:07

View 2 revisions

>> Hmm but not so recent : Version de Scribus 1.5.6.svn 06 Novembre 2019. Too old ?

Definitely too old. You must have at least build dated from March 31st 2020 to perform the test.

JLuc

2020-04-10 06:40

developer   ~0047499

Last edited: 2020-04-10 06:57

View 3 revisions

Okk YES it's fixed with 31 march build : deleting a numbered line in a list updates all numbers (even when property comes from a named style) Great !!
(not tested in real document editing but in short test document).

jghali

2020-04-10 11:23

administrator   ~0047500

Thanks for testing. I'm resolving this issue then.

FirasH

2020-04-30 09:30

developer   ~0047585

Fix confirmed!

Issue History

Date Modified Username Field Change
2015-11-01 13:55 Laser New Issue
2015-11-01 16:33 JLuc Note Added: 0037145
2015-11-03 17:23 cbradney Note Added: 0037195
2015-11-03 17:29 cbradney Status new => confirmed
2015-11-03 17:47 Kunda Relationship added related to 0013489
2015-11-05 05:11 anood Tag Attached: HOST-Oman
2015-11-05 05:12 anood Note Added: 0037235
2015-11-10 11:56 anood Note Added: 0037381
2015-11-10 11:57 anood File Added: issue13487.patch
2015-11-10 15:39 Kunda Patch No => Yes
2015-11-10 15:39 Kunda Summary Removing lines in numbered lists doesn't reorder numbers => [Patch] Removing lines in numbered lists doesn't reorder numbers
2015-11-10 22:31 JLuc Note Added: 0037406
2015-11-10 22:32 JLuc Note Edited: 0037406 View Revisions
2015-11-10 22:33 JLuc Note Edited: 0037406 View Revisions
2015-11-11 07:40 JLuc Note Added: 0037415
2015-11-11 09:39 anood Note Added: 0037417
2015-11-11 09:41 anood Note Added: 0037418
2015-11-11 09:41 anood File Added: Screenshot from 2015-11-11 12:25:30.png
2015-11-11 15:32 Kunda Sticky Issue No => Yes
2015-11-23 11:49 JLuc Note Added: 0037603
2016-03-27 01:32 Kunda Tag Attached: lists
2016-04-20 16:13 Kunda Relationship added related to 0013731
2016-04-20 16:15 Kunda Relationship added related to 0013729
2016-04-20 16:16 Kunda File Added: Numerated-lists.gif
2016-04-20 16:17 Kunda Relationship added related to 0013728
2016-04-20 16:21 Kunda Relationship added related to 0013730
2016-04-20 16:22 Kunda Relationship replaced has duplicate 0013729
2016-04-27 11:22 Kunda Relationship added related to 0012006
2017-06-18 08:52 FirasH Status confirmed => resolved
2017-06-18 08:52 FirasH Resolution open => fixed
2017-06-18 08:52 FirasH Fixed in Version => 1.5.4.svn
2017-06-18 08:52 FirasH Note Added: 0044060
2017-06-18 17:17 PeterBenedek Note Added: 0044063
2017-06-18 17:42 PeterBenedek Note Edited: 0044063 View Revisions
2017-06-18 17:42 PeterBenedek File Added: output.gif
2017-06-19 05:56 PeterBenedek Note Edited: 0044063 View Revisions
2017-06-19 05:58 PeterBenedek Assigned To => PeterBenedek
2017-06-19 05:58 PeterBenedek Status resolved => feedback
2017-06-19 05:58 PeterBenedek Resolution fixed => reopened
2017-06-19 05:59 PeterBenedek File Deleted: output.gif
2017-06-19 09:27 FirasH Assigned To PeterBenedek =>
2017-06-19 09:27 FirasH Status feedback => new
2017-06-19 09:27 FirasH Resolution reopened => open
2017-06-19 09:27 FirasH Fixed in Version 1.5.4.svn =>
2018-07-05 10:36 JLuc Tag Attached: #rottenpatch
2020-04-08 13:25 jghali Note Added: 0047495
2020-04-08 14:06 JLuc Note Added: 0047497
2020-04-08 14:10 JLuc Note Edited: 0047497 View Revisions
2020-04-08 15:04 jghali Note Added: 0047498
2020-04-08 15:07 jghali Note Edited: 0047498 View Revisions
2020-04-10 06:40 JLuc Note Added: 0047499
2020-04-10 06:51 JLuc Note Edited: 0047499 View Revisions
2020-04-10 06:57 JLuc Note Edited: 0047499 View Revisions
2020-04-10 11:23 jghali Assigned To => jghali
2020-04-10 11:23 jghali Status new => resolved
2020-04-10 11:23 jghali Resolution open => fixed
2020-04-10 11:23 jghali Fixed in Version => 1.5.6.svn
2020-04-10 11:23 jghali Note Added: 0047500
2020-04-10 11:23 jghali Summary [Patch] Removing lines in numbered lists doesn't reorder numbers => Removing lines in numbered lists doesn't reorder numbers
2020-04-10 11:24 jghali Tag Detached: #rottenpatch
2020-04-10 11:24 jghali Sticky Issue Yes => No
2020-04-30 09:30 FirasH Status resolved => closed
2020-04-30 09:30 FirasH Note Added: 0047585