View Issue Details

IDProjectCategoryView StatusLast Update
0013489ScribusStory Editor / Text Framespublic2016-04-20 17:31
ReporterLaser Assigned ToKunda  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformPCOSArchlinuxOS Versionuptodate
Product Version1.5.1svn 
Target VersionFixed in Version 
Summary0013489: Differences in levels in numbered lists
DescriptionFirst wish - more levels^^ (Important for e.g. science documents)

Second wish is the ability to mix in different levels.
For example first letter are numbers, second level are letters.
And to change prefix and suffix in different levels.
Additional InformationTarget:

1st level:
Prefix [Art. ]
Number
Suffix no

2nd level
Prefix [(]
Number
Suffix[) ]

3rd level
Prefix no
Letter
Suffix [) ]

Final:
Art. 25 (2) a)

This is the example to write the German constitution right.
Tagslists
PatchNo

Relationships

duplicate of 0013731 closedjghali Numerated Lists: refresh bug 
related to 0013488 confirmed Position of the number in numbered lists 
related to 0013487 closedjghali Removing lines in numbered lists doesn't reorder numbers 
related to 0013946 new Add autoindent to bullet/numbering in paragraph styles 
child of 0003896 acknowledged Metabug: Scientific Publishing 

Activities

JLuc

2016-03-23 17:26

developer   ~0039368

Last edited: 2016-03-23 17:27

View 2 revisions

I think it is possible to do what you wish.

All you got to do is define a paragraph style for each level and set the numbering options for paragraph effect accordingly to your wishes.

But UI is not so inviting...

JLuc

2016-03-25 20:29

developer   ~0039429

I tried and got the uploaded german constitution.

I'm not so proud of my german lesson's rememberances...

JLuc

2016-03-25 20:30

developer  

german constitution.jpg (81,771 bytes)
german constitution.jpg (81,771 bytes)

JLuc

2016-03-25 20:31

developer  

Numbering German constitution.sla (16,896 bytes)

JLuc

2016-03-25 20:37

developer   ~0039430

To reproduce
- create 3 paragraph styles, one for each level, with laser's described properties, and a dedicated 'set' which they all refer to
- do "Extra" > "reCompute document" each time you wanna update the display

Laser

2016-03-25 22:04

reporter   ~0039432

Can be closed - everything is possible, just the UI could be improved ;-)

Kunda

2016-04-20 16:04

manager   ~0040337

Laser, I think the UI improvement is in regards to 'Refreshing' right?
I have a similar refresh issue at 0013731

Laser

2016-04-20 16:15

reporter   ~0040341

No. Nothing to do with refresh.
I just didn't know the right workflow to get this result ;-)
I already explained it in the wiki.

JLuc

2016-04-20 17:24

developer   ~0040346

requested feature allready exists

Kunda

2016-04-20 17:31

manager   ~0040348

I was referring to the
do "Extra" > "reCompute document" each time you wanna update the display 

Crafty as it may be it is not an intuitive workaround

Issue History

Date Modified Username Field Change
2015-11-01 15:32 Laser New Issue
2015-11-03 12:23 Kunda Relationship added child of 0003896
2015-11-03 17:47 Kunda Relationship added related to 0013487
2016-03-23 14:33 Kunda Relationship added related to 0013488
2016-03-23 17:26 JLuc Note Added: 0039368
2016-03-23 17:27 JLuc Note Edited: 0039368 View Revisions
2016-03-25 17:48 Kunda Summary Differencies in levels in numbered lists => Differences in levels in numbered lists
2016-03-25 20:29 JLuc Note Added: 0039429
2016-03-25 20:30 JLuc File Added: german constitution.jpg
2016-03-25 20:31 JLuc File Added: Numbering German constitution.sla
2016-03-25 20:37 JLuc Note Added: 0039430
2016-03-25 22:04 Laser Note Added: 0039432
2016-03-27 01:31 Kunda Tag Attached: lists
2016-04-11 23:19 Kunda Relationship added related to 0013946
2016-04-20 16:04 Kunda Note Added: 0040337
2016-04-20 16:04 Kunda Relationship added related to 0013731
2016-04-20 16:06 Kunda Relationship replaced duplicate of 0013731
2016-04-20 16:06 Kunda Status new => resolved
2016-04-20 16:06 Kunda Resolution open => duplicate
2016-04-20 16:06 Kunda Assigned To => Kunda
2016-04-20 16:15 Laser Note Added: 0040341
2016-04-20 17:24 JLuc Note Added: 0040346
2016-04-20 17:24 JLuc Status resolved => closed
2016-04-20 17:31 Kunda Note Added: 0040348