View Issue Details

IDProjectCategoryView StatusLast Update
0015920ScribusLanguage Toolspublic2019-11-07 00:23
Reporterbinyomin Assigned Tojghali  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version18.04
Product Version1.5.6.svn 
Target VersionFixed in Version 
Summary0015920: Cannot get Hungarian hyphenation to work
Description(I tried it with the available 1.5.5 AppImage for Linux, for some unknown reason, I see no such option above for version.)

Improper hyphenation is provided for Hungarian input text.
Steps To Reproduce- New document
- Textbox, enter: asszonyt, nyugatról
- Set Language in Document properties to "Hungarian"
- Extras > Hyphenate text
- Resize box so it should hyphenate
Additional Information- For "asszonyt" it provides "ass-zonyt" instead of "asz-szonyt"
- For "nyugatról" it provides "nyuga-tról" instead of "nyugat-ról"

- See screenshot about hyphenation testing site ushuaia.pl, which uses same dictionary, and hyphenates correctly
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0003159 acknowledged Discretionary hyphenation support 

Activities

binyomin

2019-11-06 21:37

reporter  

jghali

2019-11-06 23:11

administrator   ~0047006

1) The kind of hyphenation used for word such as asszonyt is a the moment not supported
2) You are doing it wrong for setting document language, in the way you are doing it, the text you will have entered in text box will still use the language defined in File > Preferences. You have two options:

- Define document language in File > Preferences
- New document
- Textbox, enter: asszonyt, nyugatról
- Extras > Hyphenate text

or

- New document
- Open Edit > Styles
- Default Character Style > Advanced formatting > Language > Hungarian
- Textbox, enter: asszonyt, nyugatról
- Extras > Hyphenate text

jghali

2019-11-06 23:14

administrator   ~0047007

The case of "asszonyt" has in fact already an issue in the bug tracker. See 0003159 : Discretionary hyphenation support

jghali

2019-11-06 23:19

administrator   ~0047008

The case of of nyugatról is working properly if setting text language properly by one of the two ways I mentioned. I'm closing this issue as the other case has already issue 0003159 in the bug tracker.

binyomin

2019-11-06 23:43

reporter   ~0047010

Thank you, the way you describe it is indeed working – but for new textbox only.

Still, I think that there is an issue here, since currently there is no way to correct the long pages I edited already. Furthermore, I am unable to find this information (which you shared about how to set language correctly) documented anywhere.

I only found a bug report which seemingly complains about similar issue (I don't understand completely why was it deemed irreproducible):

https://bugs.scribus.net/view.php?id=7684

So, it would be great if either or both things could be corrected: 1. A way to correct textbox language afterwards and 2. proper documentation about setting language (or effective setting working, which affects changes, as normally expected by Document Settings).

I also tried to open the SLA file in text editor to compare the two text boxes (the properly and improperly hyphenated), but I see no difference which I could copy. Just one of them is working, the other is not – magic.

binyomin

2019-11-06 23:48

reporter   ~0047011

Let me put this much simpler: the problem is that I see no way to change the hyphenation language of an already existing textbox/paragraph. This sounds to me as real problem...

jghali

2019-11-07 00:21

administrator   ~0047012

First define default character style language as I already described. Then use Windows > Text Properties > Language if necessary. Please ask any other beginner question in the appropriate section of forums.scribus.net. This is not the place to do so.

Issue History

Date Modified Username Field Change
2019-11-06 21:37 binyomin New Issue
2019-11-06 21:37 binyomin File Added: Screenshot_2019-11-06_22-30-55.png
2019-11-06 21:37 binyomin File Added: Screenshot_2019-11-06_22-31-10.png
2019-11-06 21:37 binyomin File Added: Screenshot_2019-11-06_22-31-22.png
2019-11-06 23:11 jghali Note Added: 0047006
2019-11-06 23:14 jghali Note Added: 0047007
2019-11-06 23:16 jghali Relationship added related to 0003159
2019-11-06 23:19 jghali Note Added: 0047008
2019-11-06 23:20 jghali Assigned To => jghali
2019-11-06 23:20 jghali Status new => resolved
2019-11-06 23:20 jghali Resolution open => duplicate
2019-11-06 23:20 jghali Relationship replaced duplicate of 0003159
2019-11-06 23:22 jghali Status resolved => closed
2019-11-06 23:43 binyomin Status closed => feedback
2019-11-06 23:43 binyomin Resolution duplicate => reopened
2019-11-06 23:43 binyomin Note Added: 0047010
2019-11-06 23:48 binyomin Note Added: 0047011
2019-11-06 23:48 binyomin Status feedback => assigned
2019-11-07 00:21 jghali Note Added: 0047012
2019-11-07 00:22 jghali Status assigned => resolved
2019-11-07 00:22 jghali Resolution reopened => duplicate
2019-11-07 00:23 jghali Status resolved => closed