View Issue Details

IDProjectCategoryView StatusLast Update
0007684ScribusLanguage Toolspublic2016-11-11 22:54
Reporterbasvanschaik Assigned ToKunda  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformIntel64OSLinuxOS VersionUbutu Intrepid
Product Version1.3.3.12 
Target VersionFixed in Version 
Summary0007684: Hyphenation setting in "Document Setup" -> "Hyphenator" jumps back to "English" after having started the hyphenator
DescriptionIf I change the hyphenation language under Document setup -> Hypenator to "Dutch" it has switched back after using the hyphenator. And indeed, the text which I wanted Scribus to hyphenate seems to be hyphenated in English style, in stead of Dutch.

This is quite a grave bug, since it requires me to manually hyphenate _all_ texts in my > 80 pages booklet, which is just impossible. Especially since corrected hyphenation suggestions are not stored at all.

I would really be helped a lot if someone can help me fix this!
Steps To ReproduceChange hypnenation language in "Document Setup" -> "Hyphenator" and start the Hyphenator by selecting a textfield and clicking "Extras" -> "Hyphenate text". Go back to hyphenation settings in "Document Setup" and the language setting has been switched back to "English".
Tagshyphenation
Patch

Relationships

related to 0007808 closed Hyphenation settings apply only after re-opening 
has duplicate 0014095 closedjghali Hyphenation doesn't work as expected (needs more descriptive title) 
related to 0004967 closed Non switching translations 
child of 0003828 acknowledged Metabug: Hyphenation 

Activities

basvanschaik

2008-12-24 01:15

reporter   ~0020826

I have just fetched the latest version from SVN and this problem seems to be fixed: the selected hyphenation language in the preferences dialog does not change automatically.

However, when selecting "Dutch" from the list, it looks like Scribus still uses English style hyphenation?

jghali

2008-12-24 11:40

administrator   ~0020827

In 1.3.3.x hyphenation language is defined at the frame level and can be set using properties palette. In 1.3.4+ the hyphenation language is determined by the character style language. In both case changing the hyphenation language in document prefs won't miraculously change already defined frame language settings or character style language settings.

basvanschaik

2008-12-24 12:33

reporter   ~0020828

I know, but after setting all options to "Dutch" it still seems to apply English hyphenation patterns. At least it looks like English hyphenation, but I can be wrong.

IMO, this can be caused by two problems:
 1) Scribus applies the wrong patterns
 2) Dutch hyphenation in Scribus is just not perfect.

I wouldn't know how to find out what is wrong...

jghali

2008-12-24 14:50

administrator   ~0020832

I mean changing language in app/doc preferences is not enough as those settings do not affect language settings already defined. In 1.3.3.x you have to change language setting of each frame from text tab in properties palette. In 1.3.5svn you have to change the style languages from style manager. In both case dutch hyphenation is then clearly different from english hyphenation.

basvanschaik

2008-12-24 14:54

reporter   ~0020833

I meant to say that I have changed the style options in the style manager. Browsing the source code in hyphenator.cpp (and adding some debugging statements) made clear that the following statement:
  it->itemText.charStyle(firstC).language()

Does not return a language, but just some empty string. Now
  NewDict(it->itemText.charStyle(firstC).language());

fails to load the wanted dictionairy, but doesn't notice the user of that failure!

I'm debugging some more...

basvanschaik

2008-12-24 15:13

reporter   ~0020834

Just hardcoding the string "Dutch" in hyphenator.cpp does seem to work better (at least my debugging statements show a successful load), but the results are still a bit disappointing...

I'm still wondering if Scribus is actually /using/ the loaded hyph_nl dictionary.

Debugging some more...

jghali

2008-12-24 15:57

administrator   ~0020835

Last edited: 2008-12-24 15:58

It looks like 1.3.3.x documents loaded in 1.3.5svn do not have language infos set in character styles. Somewhat normal as 1.3.3.x did not have character styles but would be nice if we found a way to handle hyphenation more gracefully in such docs.

basvanschaik

2008-12-24 16:25

reporter   ~0020837

That's probably true, but I did set the correct values for character styles in my 1.3.5 document.

Kunda

2015-07-25 13:03

manager   ~0035888

jghali, i can't reproduce the the main issue of this bug. But it looks like there are other issues discovered through this bug. Please advise how to proceed?

Kunda

2016-03-30 20:17

manager   ~0039565

Peter, this as well :)
(last one for today, I promise)

PeterBenedek

2016-03-31 08:08

developer  

Dokumentum-1.sla (25,462 bytes)

PeterBenedek

2016-03-31 08:17

developer   ~0039610

Last edited: 2016-04-11 20:24

View 4 revisions

Hi Kunda!
I will gladly help! :-)

I do not know, I understand the problem?

Test: https://www.dropbox.com/s/yhi6nll883mmaav/example.avi?dl=0 (recommended download, dropbox blurred viewer)
Setting me will not change after reopen, but seems hyphenation sometimes incorrect.

Kunda

2016-04-05 19:46

manager   ~0039827

I think the name of this ticket needs to be revised. Seems has to do more with language infos set in the character style then with the language in the hyphenator menu changing.

Kunda

2016-04-11 21:26

manager   ~0040097

In other words, the title of this ticket which is what this report is mainly about is not reproducible.

The hyphenation problem is a different bug all together which this ticket is most likely a duplicate of
BTW, I like your screencast! Lets see if we can attach it to a more relevant hyphenation bug.

Kunda

2016-05-24 21:45

manager   ~0041400

This ticket was cloned to 0014095 as it is not reproducible anymore but contains a difficult issue to describe. I'm resolving this bug but asking for help clarrifying the issue in 0014095. Thank you and thanks to Peter for the testing work :)

Issue History

Date Modified Username Field Change
2008-12-24 00:29 basvanschaik New Issue
2008-12-24 01:15 basvanschaik Note Added: 0020826
2008-12-24 11:40 jghali Note Added: 0020827
2008-12-24 12:33 basvanschaik Note Added: 0020828
2008-12-24 14:50 jghali Note Added: 0020832
2008-12-24 14:54 basvanschaik Note Added: 0020833
2008-12-24 15:13 basvanschaik Note Added: 0020834
2008-12-24 15:57 jghali Note Added: 0020835
2008-12-24 15:58 jghali Note Edited: 0020835
2008-12-24 16:25 basvanschaik Note Added: 0020837
2014-07-21 06:25 Kunda Relationship added related to 0004967
2014-07-22 21:29 cbradney Relationship deleted related to 0004967
2014-08-23 12:56 Kunda Relationship added related to 0004967
2015-07-25 13:03 Kunda Note Added: 0035888
2015-07-25 13:07 Kunda Relationship added related to 0007808
2016-03-30 20:14 Kunda Relationship added child of 0003828
2016-03-30 20:16 Kunda Tag Attached: #please_test
2016-03-30 20:16 Kunda Tag Attached: hyphenation
2016-03-30 20:17 Kunda Note Added: 0039565
2016-03-31 08:08 PeterBenedek File Added: Dokumentum-1.sla
2016-03-31 08:17 PeterBenedek Note Added: 0039610
2016-03-31 08:21 PeterBenedek Note Edited: 0039610 View Revisions
2016-03-31 08:25 PeterBenedek Note Edited: 0039610 View Revisions
2016-04-05 19:46 Kunda Note Added: 0039827
2016-04-05 19:47 Kunda Tag Attached: discussion
2016-04-11 20:24 PeterBenedek Note Edited: 0039610 View Revisions
2016-04-11 21:26 Kunda Note Added: 0040097
2016-05-24 21:43 Kunda Issue cloned: 0014095
2016-05-24 21:43 Kunda Relationship added related to 0014095
2016-05-24 21:45 Kunda Note Added: 0041400
2016-05-24 21:45 Kunda Status new => resolved
2016-05-24 21:45 Kunda Resolution open => unable to reproduce
2016-05-24 21:45 Kunda Assigned To => Kunda
2016-05-24 21:45 Kunda Tag Detached: discussion
2016-05-24 21:45 Kunda Tag Detached: #please_test
2016-05-24 22:41 jghali Relationship replaced has duplicate 0014095
2016-11-11 22:54 cbradney Status resolved => closed