View Issue Details

IDProjectCategoryView StatusLast Update
0016802ScribusUser Interfacepublic2022-07-16 19:43
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version22.04
Product Version1.5.8 
Fixed in Version1.5.9.svn 
Summary0016802: Issues with "gtk2" application setting in AppImages
DescriptionOn ubuntu 22.04 dark theme with <empty> or "gtk2" scribus <theme or appearence> ("Apparence" in french UI) choice (but not "windows" or "fusion") :

- the "tick" next to "Insert (menu) / Sticky tools" option doesnt appear (maybe it's black tick on black), whether "1.5.1" or "1.5.1 dark" icons are choosen. (but it looks like clicking this options makes it work)

- all checkboxes have disappeared (same as HTML's "display: none"). Eg : Application's settings / Display / Page , or Album, or Hyphens usw ; or right-click-on-frame "lock frame" submenu options.

- dialog's input boxes have no border at all. When their content is empty, there is absolutely no hint that there is an input zone.




TagsNo tags attached.
PatchNo

Relationships

related to 0016803 resolvedjghali White on ivory hints cannot be read with "window" or "fusion" theme on dark Ubuntu 22.04 

Activities

jghali

2022-06-04 18:34

administrator   ~0049678

Unable to reproduce in my Ubuntu 22.04 VM.

Gtk2 platform theme is a legacy Qt theme which is not maintained anymore. Last commit in qtstyleplugins repo now dates from more than 5 years:
https://code.qt.io/cgit/qt/qtstyleplugins.git/

Last time I checked, the code would not compile with Qt 5.15. So... If you are using gtk2 theme, you are clearly looking for problems.

JLuc

2022-06-05 07:17

developer   ~0049679

When so bad and not maintened, then maybe the "gtk2" option shouldnt be proposed anymore ?

It should not be the default setting (It looks like the default = <empty> setting is in fact "gtk2")

jghali

2022-06-05 12:17

administrator   ~0049682

>> When so bad and not maintened, then maybe the "gtk2" option shouldnt be proposed anymore ?

The gtk2 theme is not installed by default on Ubuntu 22.04 in the first place. I had to install the qt5-style-plugins package manually to get it.

>> It should not be the default setting (It looks like the default = <empty> setting is in fact "gtk2")

We cannot to anything in this case. The default setting is decided by your system.

JLuc

2022-06-05 14:37

developer   ~0049683

? i didnt install it neither. Would appimage be responsible for packaging it ?

jghali

2022-06-09 14:51

administrator   ~0049689

Ah! You're using the appimage! It seems that the linuxdeployqt tool used to generate the AppImage indeed automatically bundle it whenever possible:
https://github.com/probonopd/linuxdeployqt/blob/master/tools/linuxdeployqt/shared.cpp#L1260

A few days ago, the bundling of all gtk related plugins was removed from the alternate linuxdeploy tool and its linux deploy qt plugin:
https://github.com/linuxdeploy/linuxdeploy-plugin-qt/commit/54d98870d28913b15d07094316d8fd5572a53b3f

I asked probono on IRC if he could fix linuxdeployqt to stop automatically bundling this gtk2 plugin. It would still be possible to include it with an --extra-plugin option.

jghali

2022-06-09 14:59

administrator   ~0049690

Last edited: 2022-06-09 15:00

I committed a first patch which removes gtk2 plugin from AppImages generated by CI. It should be ok as long as system images does not have gtk2 plugin pre-installed.

jghali

2022-07-16 19:43

administrator   ~0049730

Resolving, linuxdeployqt does not force anymore the inclusion of gtk2 theme in AppImages:
https://github.com/probonopd/linuxdeployqt/commit/d6ac06cab496b5066af13bdfe14f56a6e9c11732

Issue History

Date Modified Username Field Change
2022-06-03 12:50 JLuc New Issue
2022-06-03 14:39 JLuc Description Updated
2022-06-03 14:41 JLuc Description Updated
2022-06-04 15:46 JLuc Summary Issues with dark mode => Issues with "gtk2" application setting
2022-06-04 15:46 JLuc Description Updated
2022-06-04 18:34 jghali Note Added: 0049678
2022-06-05 07:17 JLuc Note Added: 0049679
2022-06-05 07:21 JLuc Relationship added related to 0016803
2022-06-05 12:17 jghali Note Added: 0049682
2022-06-05 14:37 JLuc Note Added: 0049683
2022-06-09 14:51 jghali Note Added: 0049689
2022-06-09 14:59 jghali Note Added: 0049690
2022-06-09 15:00 jghali Note Edited: 0049690
2022-07-16 19:43 jghali Assigned To => jghali
2022-07-16 19:43 jghali Status new => resolved
2022-07-16 19:43 jghali Resolution open => fixed
2022-07-16 19:43 jghali Fixed in Version => 1.5.9.svn
2022-07-16 19:43 jghali Note Added: 0049730
2022-07-16 19:43 jghali Summary Issues with "gtk2" application setting => Issues with "gtk2" application setting in AppImages