View Issue Details

IDProjectCategoryView StatusLast Update
0002756ScribusFontspublic2006-01-10 14:00
Reporteraamehl Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSdebianOS Versiontesting
Product Version1.3.2cvs 
Target VersionFixed in Version1.3.2cvs 
Summary0002756: Hebrew letters don't print correctly from scribus
DescriptionI am building a booklet, and on screen all looked fine.
When I printed out my work all text in Hebrew printed out uniformly wrong.
The most striking is the letter yud which is hidden under the letters to the left of it.

Since it happens to all the yuds as well as other letters I am assuming its a bug.


Steps To ReproduceI type any hebrew in scribus (I used at least two fonts Nachlieli and Druglin) the letter spacing is wacko, most pronounced is the yud.
Additional InformationIf I can get my scanner working I will upload scanned images so you can see whats wrong
TagsNo tags attached.
Patch

Relationships

related to 0002920 closedFahad Khmer script is rendered wrong 
related to 0001726 closedFahad hebrew vowels (and cantillation marks) not placed properly 
related to 0001547 closedFahad Support for Indic Scripts 
child of 0003965 acknowledged Metabug: Support for non-latin languages 

Activities

2005-10-23 13:24

 

debugnorfont.zip (311,838 bytes)

ringerc

2005-10-23 15:56

reporter   ~0007188

It's worth noting that support for scripts such as hebrew that require special character position for "supplimentary" characters is still largely absent in Scribus. There's ongoing work into a new text handling core for the application, and that should make better support for hebrew practical. Most indic and arabic languages are also poorly supported for similar reasons.

With regards to this specific bug, does the same problem appear if you save as PDF? If so, please attach the PDF.

2005-10-23 16:34

 

out0001.png (11,107 bytes)
out0001.png (11,107 bytes)

avox

2005-10-23 17:35

administrator   ~0007189

There's a discrepance between Scribus canvas (correct) and generated PDF (wrong spacing).

Note that the sample docs use Scribus only for the titles, not the lyrics.

avox

2005-10-23 17:36

administrator   ~0007190

The issue does not appear if the fonts are converted to outlines in PDF (export PDF -> Fonts -> subset all fonts)

avox

2005-10-23 17:50

administrator   ~0007191

Franz, I assigned to you since it looks as if Scribus and PDF differ on where the basepoints of glyphs in RTL text is.

ringerc

2005-10-23 18:01

reporter   ~0007192

Sorry, misunderstood the issue to be about the positioning of special accent chars, etc.

2005-10-23 19:29

 

habengimp.png (5,293 bytes)
habengimp.png (5,293 bytes)

2005-10-23 19:29

 

habengimpscaned.png (2,175 bytes)
habengimpscaned.png (2,175 bytes)

2005-10-23 19:30

 

habenscribus.pdf (41,326 bytes)

aamehl

2005-10-23 19:33

reporter   ~0007193

I added a title made in gimp and in scribus so that those who don't know hebrew can compare them.

2005-10-23 19:39

 

habenscribusscan.png (346 bytes)
habenscribusscan.png (346 bytes)

aamehl

2005-10-23 19:43

reporter   ~0007194

ok now there are pairs of exact matches made in gimp and scribus.

In scribus the final nun is to far left
the yud is way to far left and is underneath the Kuf
the yud in the word li is now part of the next word
the last yuud is underneath the final Mem ouch!

The fey is touching the resh.
In short the letters are missed spaced.
For reference look at the gimp example
Thanks
Aaron

fschmid

2005-12-29 09:45

administrator   ~0007854

Should be fixed now, at least the test files are ok now.

Issue History

Date Modified Username Field Change
2005-10-23 13:24 aamehl New Issue
2005-10-23 13:24 aamehl File Added: debugnorfont.zip
2005-10-23 15:56 ringerc Note Added: 0007188
2005-10-23 16:34 aamehl File Added: out0001.png
2005-10-23 17:35 avox Note Added: 0007189
2005-10-23 17:35 avox Status new => confirmed
2005-10-23 17:36 avox Note Added: 0007190
2005-10-23 17:48 avox Status confirmed => assigned
2005-10-23 17:48 avox Assigned To => fschmid
2005-10-23 17:50 avox Note Added: 0007191
2005-10-23 18:01 ringerc Note Added: 0007192
2005-10-23 19:29 aamehl File Added: habengimp.png
2005-10-23 19:29 aamehl File Added: habengimpscaned.png
2005-10-23 19:30 aamehl File Added: habenscribus.pdf
2005-10-23 19:33 aamehl Note Added: 0007193
2005-10-23 19:39 aamehl File Added: habenscribusscan.png
2005-10-23 19:43 aamehl Note Added: 0007194
2005-12-29 05:29 ringerc Relationship added related to 0002920
2005-12-29 05:29 ringerc Relationship added related to 0001726
2005-12-29 05:29 ringerc Relationship added related to 0001547
2005-12-29 09:45 fschmid Status assigned => resolved
2005-12-29 09:45 fschmid Fixed in Version => 1.3.2cvs
2005-12-29 09:45 fschmid Resolution open => fixed
2005-12-29 09:45 fschmid Note Added: 0007854
2006-01-10 14:00 cbradney Status resolved => closed
2006-07-02 21:57 mhanski Relationship added child of 0003965