View Issue Details

IDProjectCategoryView StatusLast Update
0001726ScribusNLSpublic2016-12-08 21:41
Reporterhcy Assigned ToFahad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSDebian SidOS Version
Product Version1.3.0cvs 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0001726: hebrew vowels (and cantillation marks) not placed properly
DescriptionHebrew vowels should be placed on top of Hebrew letters - centered horizontally - sometimes right inside the letter and sometimes below it. Instead, while the vertical placement seems correct, the horizontal placement is not - the vowels are placed *after* the letters (to their left, since it's RTL), not *in* them.
Steps To ReproduceUse the unicode font called "Ezra SIL SR" which I've kindly attached here. :) Once installed, try using the sample text which is attached here as a text file. Attached is a gif of how it *should* look. Attached is also a png of how it looks now in scribus - wrong.
Additional InformationOpenOffice and Mozilla / Firefox / Epiphany also do not display this properly. MS products like IE and Word do, as does KDE's Konqueror.
Tags#please_test, fixed, HOST-Oman, layout, RTL
PatchNo

Relationships

related to 0002920 closedFahad Khmer script is rendered wrong 
related to 0002756 closedfschmid Hebrew letters don't print correctly from scribus 
related to 0001547 closedFahad Support for Indic Scripts 
related to 0003680 closedFahad Devanagari (Unicode U+09xx) glyph formation (vowels and conjunct consonants) not proper 
child of 0003965 acknowledged Metabug: Support for non-latin languages 

Activities

2005-02-24 21:16

 

stuff.tar (286,720 bytes)

hcy

2005-02-27 08:49

reporter   ~0003832

Pango renders the sample text, with the Ezra SIL SR font, absolutely beautifully! Maybe you want to use Pango in Scribus?

plinnell

2005-04-07 19:49

viewer   ~0004119

Pango is not an option. This will get fixed in 1.3.x, along with Arabic.. It is a very high priority.

danielbu

2008-08-05 17:03

reporter   ~0020098

Same in Win32 (Scribus 1.3.3.11

mdoubez

2008-09-24 13:43

reporter   ~0020323

Same in 1.3.4 and 1.3.5svn (20sept2008) for vav+shuruq
See attached file scribus_hebrew.zip for relevant report

2008-09-24 13:44

 

scribus_hebrew.zip (1,139,008 bytes)

cbradney

2008-09-24 13:55

administrator   ~0020324

There is no plan to change this in 1.3.5, perhaps not in 1.3.6 either.

aharonium

2011-06-14 20:19

reporter  

Scribus 1.4rc4 bug report - Hebrew Diacritic Positioning.zip (180,225 bytes)

aharonium

2011-06-14 20:24

reporter   ~0026395

Last edited: 2011-06-14 20:26

View 2 revisions

This issue persists in Scribus 1.4rc4. See attached file: Scribus 1.4rc4 bug report - Hebrew Diacritic Positioning.zip (contains an image of text prepared with three fonts and Scribus 1.4rc4 and an image of the same text with OpenOffice 3.3.0.)

Is this issue getting tackled for Scribus 1.5?

Tested using open source Unicode Hebrew fonts (Cardo, Ezra SIL SR) supporting the full range of diacritics (as well as with the non-open source SBL Hebrew font).

(Download link for open source Unicode Hebrew fonts to test: http://opensiddur.org/2010/07/unicode-compliant-and-open-source-licensed-hebrew-fonts/ )

linuxrabbi

2012-12-19 11:48

reporter   ~0029453

This problem persists. What would it take to have it fixed? I may be willing to offer compensation to the programmer who fixes this and gets the fix accepted into the official distribution.

christoph_s

2012-12-20 07:25

administrator   ~0029464

Last edited: 2012-12-20 07:27

View 2 revisions

linuxrabbi: Yes, the problem persists, not only for Hebrew, but also for Arabic, both of which I consider to be real deficiencies of Scribus. Unfortunately, noone in the development team has any experience, not to mention expertise, with the typographic requirements of these RTL scripts. We don't have experience with Indic or CJK scripts either, but at least for Indic, Tamil or Japanese some volunteers showed up to work on support for their writing systems.

Which is to say: If you can find someone who has experience with Hebrew typography and font handling, as well as programming experience (preferably C++), by all means, encourage this person to contact the development team. There is some legacy code available, and cooperating with the external developers who are working on other non-European scripts might not be a bad idea.

As for compensation: If you find someone who can solve the issue, feel free offer a bounty (or whatever you want to call it), but the core development team simply lacks typographical expertise when it comes to Hebrew or Arabic, i.e., the most important RTL scripts.*

*) I refer to Hebrew and Arabic as scripts, because Arabic script covers a wide range of languages (including Farsi), and because Yiddish was also written in Hebrew script.

christoph_s

2012-12-22 06:37

administrator   ~0029482

aharonium, linuxrabbi: Completing the required information about Hebrew on our Wiki would be a good start: http://wiki.scribus.net/canvas/Complex_Script_Functionality#Hebrew_with_vowels_and_cantillation

aharonium

2012-12-26 07:59

reporter   ~0029486

Thanks Christoph. I've updated that section of the Scribus wiki.

christoph_s

2012-12-27 05:55

administrator   ~0029489

aharonium: Thanks a lot. Do you think you could upload screenshots with a higher resolution? The current resolution seems a bit low, which makes it a bit difficult to discern the details.

Also: The current issue is mostly related to glyph shaping and getting RTL scripts right. If you have a resource that provides further typographic details, it could help implementing typographic tools to deal with these requirements.

christoph_s

2012-12-27 06:01

administrator   ~0029490

aharonium, linuxrabbi: I don't know where you live, but Israel is one of the most advanced states in the world when it comes to the software industry. There must be someone, somewhere who is qualified and willing to help us with Hebrew ...

aharonium

2012-12-27 15:53

reporter   ~0029493

http://wiki.scribus.net/wiki/images/2/29/Comparing_Hebrew_diacritic_support_in_LibreOffice3.6.4_with_Scribus_1.4.1.png is too low resolution? Really?

I'm in the U.S., but I'm sure you're right. Given that these issues have already been solved in other open source projects (Firefox, Chromium, LibreOffice) isn't part of the problem a matter of reinventing the wheel?

What sort of coding of experience do you need in order to resolve this bug? I know open source Hebrew font makers who are familiar with the underlying font logic of diacritic positioning. John Hudson's font logic (used in his SBL Hebrew font) is MIT licensed. So too is the font logic used in the Culmus Project fonts (engineered by Maxim Iorsh and Yoram Gnat).

christoph_s

2012-12-28 03:05

administrator   ~0029501

Firefox et al. cannot serve as an example here, because in Scribus we need absolute precision up to 1/100 pt, although I must admit that I'd be happy if Scribus already had the precision of LibreOffice. This applies to the screen display as well as PostScript and PDF output. We also need the tools to create typographically beautiful texts. These may have to be different for non-European languages.

As for the coding experience: C++, Qt, font technology, PostScript, text layout. There was an (unfortunately unfinished) project to implement a new text engine using ICU, which is available here: svn://scribus.net/branches/ScribusOIF, which would be a good starting point.

As for ICU see: http://userguide.icu-project.org/layoutengine and http://www.d-type.com/page/text_layout. It may also be helpful to contact the team that is working on Indic language support to avoid double work. See: http://lists.scribus.net/pipermail/scribus/2012-August/047258.html

Kunda

2013-11-21 03:53

manager   ~0030863

Anybody working on this?
I'd like to help get this working. Also, if no one is working on it currently, perhaps we can announce on the facebook/g+/twitter request for help ?

mdoubez

2013-11-21 12:24

reporter   ~0030864

I remember looking into the code and I guess this would require to modify the way RTL languages are handled.
At this time, RTL is an option that invert the computation of the position of the glyphs, cursor ... I am not sure but something like bidi management should be used and then from that, the glyphs could be correctly positioned.

Kunda

2015-05-25 13:51

manager   ~0035242

Note: ScribusCTL is a project that is aimed at fixing Complex Text Layouts in Scribus. The announcement of a working group to encourage collaboration was made here: http://permalink.gmane.org/gmane.comp.graphics.scribus.devel/2485

If you'd like to support ScribusCTL please let us know via the github repo: https://github.com/andreas-vox/ScribusCTL

Kunda

2016-03-23 12:55

manager   ~0039357

According to HOST-Oman team, these issues are fixed in the new CTL branch!
See https://github.com/HOST-Oman/scribus/issues/75#issue-142809558
There will be a build provided soon to test this fix OR one can build their branch manually.

cbradney

2016-12-03 22:19

administrator   ~0042619

r21564

linuxrabbi

2016-12-04 11:22

reporter   ~0042647

Thank you and congratulations. Is this expected to be folded into the main branch or to be a fork / parallel build?

Kunda

2016-12-04 13:27

manager   ~0042655

@linuxrabbi the CTL branch was merged (in almost it's entirety so far) in to trunk. It was done so in r21563: https://www.scribus.net/websvn/comp.php?repname=Scribus&compare[]=/@21562&compare[]=/@21563

Issue History

Date Modified Username Field Change
2005-02-24 21:01 hcy New Issue
2005-02-24 21:11 hcy File Added: stuff.tar
2005-02-24 21:15 cbradney File Deleted: stuff.tar
2005-02-24 21:16 hcy File Added: stuff.tar
2005-02-27 08:49 hcy Note Added: 0003832
2005-04-07 19:49 plinnell Note Added: 0004119
2005-04-07 19:49 plinnell Product Version 1.2.1 => 1.3.0cvs
2005-12-29 05:27 ringerc Status new => acknowledged
2005-12-29 05:29 ringerc Relationship added related to 0002920
2005-12-29 05:29 ringerc Relationship added related to 0002756
2005-12-29 05:29 ringerc Relationship added related to 0001547
2006-04-20 16:58 mhanski Relationship added related to 0003680
2006-07-02 22:00 mhanski Relationship added child of 0003965
2008-08-05 17:03 danielbu Note Added: 0020098
2008-09-24 13:43 mdoubez Note Added: 0020323
2008-09-24 13:44 mdoubez File Added: scribus_hebrew.zip
2008-09-24 13:55 cbradney Note Added: 0020324
2011-06-14 20:19 aharonium File Added: Scribus 1.4rc4 bug report - Hebrew Diacritic Positioning.zip
2011-06-14 20:24 aharonium Note Added: 0026395
2011-06-14 20:26 aharonium Note Edited: 0026395 View Revisions
2012-12-19 11:48 linuxrabbi Note Added: 0029453
2012-12-20 07:25 christoph_s Note Added: 0029464
2012-12-20 07:27 christoph_s Note Edited: 0029464 View Revisions
2012-12-22 06:37 christoph_s Note Added: 0029482
2012-12-26 07:59 aharonium Note Added: 0029486
2012-12-27 05:55 christoph_s Note Added: 0029489
2012-12-27 06:01 christoph_s Note Added: 0029490
2012-12-27 15:53 aharonium Note Added: 0029493
2012-12-28 03:05 christoph_s Note Added: 0029501
2013-11-21 03:53 Kunda Note Added: 0030863
2013-11-21 12:24 mdoubez Note Added: 0030864
2014-04-07 15:06 JLuc Tag Attached: layout
2015-05-25 13:51 Kunda Note Added: 0035242
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2016-03-23 12:54 Kunda Tag Attached: #please_test
2016-03-23 12:54 Kunda Tag Attached: fixed
2016-03-23 12:54 Kunda Tag Attached: HOST-Oman
2016-03-23 12:54 Kunda Tag Attached: RTL
2016-03-23 12:55 Kunda Patch => No
2016-03-23 12:55 Kunda Category Story Editor / Text Frames => NLS
2016-03-23 12:55 Kunda Note Added: 0039357
2016-03-31 04:37 Kunda Severity major => minor
2016-12-03 22:19 cbradney Assigned To => Fahad
2016-12-03 22:19 cbradney Status acknowledged => resolved
2016-12-03 22:19 cbradney Resolution open => fixed
2016-12-03 22:19 cbradney Fixed in Version => 1.5.3.svn
2016-12-03 22:19 cbradney Note Added: 0042619
2016-12-04 11:22 linuxrabbi Note Added: 0042647
2016-12-04 13:27 Kunda Note Added: 0042655
2016-12-05 20:21 cbradney Status resolved => closed
2016-12-08 21:41 cbradney Target Version => 1.5.3