View Issue Details

IDProjectCategoryView StatusLast Update
0001547ScribusNLSpublic2016-12-08 21:41
ReporterSivaraj Assigned ToFahad  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSLinuxOS Version2.6
Product Version1.2 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0001547: Support for Indic Scripts
DescriptionScribus is not rendering indic scripts properly, though QT supports indic script rendering from version 3.2. Probably Scribus is not using QT's text rendering engine.

Attached files contain the rendering in Scribus and the correct rendering in gedit.
Steps To ReproducePaste any text in a indic script. For example the following Tamil text, and select a Tamil font (Lohit Tamil in Fedora core 3).

பகவத் கீதை
பாரதியாரின் முன்னுரை
Tags#please_test, CTL, fixed, HOST-Oman
Patch

Relationships

related to 0001726 closedFahad hebrew vowels (and cantillation marks) not placed properly 
related to 0002756 closedfschmid Hebrew letters don't print correctly from scribus 
parent of 0008305 closedjghali Ligature support 
parent of 0006004 closedFahad wishlist: set default Text Area's content direction to rtl 
has duplicate 0007140 closedplinnell Incorrect Rendering of Malayalam[Indic] in Scribus 
has duplicate 0012721 closedjghali Improper Rendering of Assamese Unicode Fonts in Scribus 1.4.4 and in former versions. 
has duplicate 0012813 closedjghali hindi, Devnagiri font not displaying in canvas 
has duplicate 0014054 closedjghali Tamil Unicode Font is not rendering properly 
has duplicate 0014271 closedjghali Problem in importing unicode (foreign language text) 
related to 0002920 closedFahad Khmer script is rendered wrong 
related to 0003928 closedFahad Support line breaking for Thai text 
related to 0011513 closedFahad Gujarati Language does not render properly on page. 
child of 0003965 acknowledged Metabug: Support for non-latin languages 

Activities

2005-01-16 10:59

 

cbradney

2005-01-16 15:05

administrator   ~0003485

Yes, we know. One day, maybe even soon-ish.

cbradney

2005-01-16 15:12

administrator   ~0003487

BTW, Qt doesnt get it ALL right for all Indic languages

plinnell

2005-01-18 09:17

viewer   ~0003504

Scribus uses its own rendering engine based on libart.

cbradney

2005-02-19 16:58

administrator   ~0003751

Please supply some test texts and perhaps a font if it is a shareable font.

2005-02-24 04:53

 

lohit_ta.ttf (64,760 bytes)

2005-02-24 04:59

 

sample_text.utf8 (1,568 bytes)

Sivaraj

2005-02-24 05:17

reporter   ~0003810

I have uploaded the Lohit Tamil font from Fedora Core 3 and some sample UTF-8 text for Tamil.

FC3 also comes with a font for Devanagari called Lohit Hindi.

UTF-8 sample texts for most indian languages are available from wikipedia.
e.g., hi.wikipedia.org (Hindi/Devanagari), bn.wikipedia.org (Bangla).

I will load additional fonts as I can get hold of them.

2005-02-24 05:20

 

lohit_hi.ttf (159,812 bytes)

omiazad

2005-06-21 15:04

reporter   ~0005086

Last edited: 2005-06-21 15:07

Well, as far I think if Scribus depends GTK2 or QT then all Indic languages will work fine. I'm a Bangla user and Bangla also doesn't work. If you'll design a new rendering engine, then there might be some problem. I found it depends on *libart* but how to sort the problem?

2005-06-21 15:09

 

SolaimanLipi.ttf (288,912 bytes)

omiazad

2005-06-21 15:10

reporter   ~0005087

Just uploaded "SolaimanLipi.ttf" which is a Bengali font. Please check.

cfynn

2008-07-29 10:14

reporter   ~0020063

(Support for Indic Scripts in Scribus)

Please go to http://wiki.scribus.net/index.php/Complex_Script_Functionality and add details for your script.

cfynn

2008-07-29 14:44

reporter   ~0020065

Plenty of fonts for complex scripts are listed at:
http://www.freedesktop.org/wiki/Software/Fonts and at
http://www.unifont.org/fontguide/

P.S. Wondering why Scribus is using a "rendering engine based on libart" rather than something like cairo which already has good support for complex-scripts?

sungkhum

2012-01-21 16:09

reporter  

Battambang-Regular_0.ttf (357,868 bytes)

sungkhum

2012-01-21 16:11

reporter  

Khmer-Sample.txt (774 bytes)
ទ្រង់​មិន​ចាំបាច់​នឹង​ថ្វាយ​យញ្ញ​ ​បូជា​ជា​រាល់ថ្ងៃ​ ​ដូចជា​​សំដេច​សង្ឃ​ ​ដែល​ថ្វាយ​ដោយ​ព្រោះ​បាប​ខ្លួន​ជាមុន​ដំបូង​ ​រួចមក​ដោយ​ព្រោះ​បាប​របស់​ជន​ទាំងឡាយ​នោះ​ទេ​ ​ត្បិត​ទ្រង់​បាន​ថ្វាយ​យញ្ញបូជា​នោះ១ដង​ជា​សម្រេច ​គឺ​ក្នុង​កាលដែល​ទ្រង់​ថ្វាយព្រះ​អង្គ​ទ្រង់​នោះ​ឯង
Khmer-Sample.txt (774 bytes)

sungkhum

2012-01-21 16:12

reporter   ~0027583

It would be wonderful if this could be fixed! Khmer also does not render correctly. Cairo would be great!

Thanks,
Nathan

jghali

2012-01-21 19:34

administrator   ~0027584

Cairo + pango do not provide the advanced typographic features needed by Scribus. So basically they are of little help here.

sivakumj

2012-01-31 13:58

reporter   ~0027632

Please let me know about your solution.
Thanks,
siva

sungkhum

2012-01-31 15:02

reporter   ~0027634

@jghali Thank you for your response - that helps us understand why a change has not been made over the past 7 years.

Might a concept like the "World Composer" in Adobe InDesign work for Scribus?
Meaning that a Cairo + Pango rendering engine could be used for a special "World Language" text box? That way Scribus could extend its user base, as well as continue to use its current rendering engine for the "advanced typographic features" it needs? I don't have any experience in this, so sorry if such a suggestion is absurd - I'm just trying to help push the need so many of us have :)

It really is a shame that there is currently no open-source unicode compatible desktop publishing software available.

jeffmcneill

2012-09-02 14:36

reporter   ~0028890

Any thoughts on when this might be put into the roadmap? I've got to work with Lao, Thai, Myanmar and Khmer fonts (all of which have positional vowels (some with positional tone marks). Your feature set is really maturing, but this non-latin/indic font support is required for our work out here in Chiang Mai. I can give example fonts/etc., if I knew that someone would be working on this. It seems to be the oldest bug in the database.

christoph_s

2012-09-03 04:56

administrator   ~0028894

A solution for Indic fonts has been submitted by an external developer/development team last month. It just takes some time to review and test, but if all works well, it is certainly to be expected in 1.6, and the original developer even offered to backport it to the 1.4x series.

sungkhum

2012-09-03 05:08

reporter   ~0028895

Wonderful news! Please let us know if the developers need anything (fonts, sample text, beta testers etc.), we would be happy to supply what we can.

sivakumj

2012-09-03 06:16

reporter   ~0028896

we are always waiting for the wonderful news. I can join with nathan, and help to you. Please let us know

christoph_s

2012-09-03 06:30

administrator   ~0028897

Here's the announcement, but please read the whole thread:

http://lists.scribus.net/pipermail/scribus/2012-August/047258.html

I'm pretty sure that many of you could help.

sungkhum

2012-09-03 06:45

reporter   ~0028898

Any way to get a Windows build for me to test with?

ale

2012-09-03 07:44

manager   ~0028900

no windows build from us yet.
but if you want to help out, we have an "indic" branch in our git servers:

http://wiki.scribus.net/canvas/Git

for the first tests, i think it's better to concentrate on linux and on people that can build their own scribus... our resources are scarce...

if you need help on compiling scribus, you can join us in the irc channel:
irc://irc.freenode.net/#scribus
or
http://wiki.scribus.net/canvas/Special:WebChat

it's possible to get a linux to work in a virtual machine and compile scribus there.

hth
a.l.e

Sabarish

2015-05-10 13:47

reporter   ~0035083

I too face the same issue.. Any help on this please?

Kunda

2015-05-11 04:05

manager   ~0035087

Sabarish, we don't anticipate this being fixed immediately. It has been an issue for many many years. But recently there has been some movement around getting this to work correctly in Scribus. Please see the recent post at: https://plus.google.com/u/0/b/109612024486187515483/109612024486187515483/posts/Dy86BFX4Gim

Kunda

2016-03-23 12:36

manager   ~0039350

According to HOST-Oman team, these issues are fixed in the new CTL branch!
See https://github.com/HOST-Oman/scribus/issues/75#issue-142809558
There will be a build provided soon to test this fix OR one can build their branch manually.

shreeshrii

2016-09-15 08:53

reporter   ~0042001

I installed Scribus 1.5.3-svn just now in the hope that Indic support will be included as suggested in the post by Kunda from March 2016.

However, still seeing issues with devanagari rendering for Hindi.

shreeshrii

2016-09-15 09:18

reporter   ~0042002

Please also note that Indic (Brahmic) scripts such as Devanagari, Bagla, Tamil etc are NOT RTL. This issue has been tagged incorrectly with RTL.

https://en.wikipedia.org/wiki/Brahmic_scripts

ale

2016-09-15 12:01

manager   ~0042003

the support for non latin languages is being worked on in this branch:

https://github.com/HOST-Oman/scribus/commits/ctl

merge in the svn trunk (and release of 1.5.3 with it) is planned for later this year.

shreeshrii

2016-09-15 15:59

reporter   ~0042007

>> Hi
>>If you can attach the source document we can test it for you. We'd need to know an appropriate font to use as well.
>>Thanks
>>Craig

Hi Craig,
Since the email did not show up in the thread, I am attaching the image which shows that devanagari is being rendered correctly in the Story Editor but not in the layout and also a text file with the devanagari text.

I have uninstalled scribus so don't have the 'source' scribus document, but you can copy the devanagari text to test.

I used Arial Unicode MS font on Windows 10. Other Devanagari fonts on windows are Mangal, Kokila, Aparajita. Lohit Devanagari is available from Fedora. Other fonts that could be used are Annapoorna SIL, Sanskrit2003, Siddhanta, Chandas, etc. Links to the ttf files can be found at https://sourceforge.net/p/tesseracthindi/wiki/OCR%20for%20Devanagari/

I have seen similar broken devanagari for conjuncts and combining mark for i when using Xetex - it is related to fontspec. When Script=Devanagari is declared for a newfontfamily it ativates the font's particular support for devanagari script.

I tried looking under preferences/options in scribus where I might be able to choose language/script but did not find it.

If you need more info, I will be happy to reinstall scribus and test further.

shreeshrii

2016-09-15 16:01

reporter   ~0042008

Looks like I can only attach one file at a time. Here is the devanagari text file.

scribus-devanagari.txt (785 bytes)
अंग्रेजी विकि तथा कुछ अन्य स्थानों पर पढ़ने को मिल रहा है कि स्क्राइबस  में भारतीय लिपियों को शुद्धतापूर्वक न दिखा पाने (रेण्डरिंग) की समस्या का समाधान हो गया है। यह तो बहुत शुभ समाचार है। ऐसा पढ़ने में आ रहा है कि अगस्त के मध्य में यह समाधान हुआ है।

क्या किसी को इसके बारे में नवीनतम जानकारी है?

--अनुनाद

cbradney

2016-09-15 19:23

administrator   ~0042010

Please check the new screenshot I just added. It has the rendered text from our CTL branch with your screenshot in front.

shreeshrii

2016-09-16 04:01

reporter   ~0042013

The devanagari text rendered from the CTL branch is correct.

Thanks to the development team which made it possible. This will go a long way in fulfilling the need for open source DTP for Hindi and other Indian and Indic languages.

Is there any possibility of a windows binary from the CTL branch? There would be a number of users willing to test and provide feedback.

Looking forward to 1.5.3 release.
Thanks!

cbradney

2016-12-03 22:18

administrator   ~0042618

r21564

Issue History

Date Modified Username Field Change
2005-01-16 10:59 Sivaraj New Issue
2005-01-16 10:59 Sivaraj File Added: scribus_error_screenshots.png
2005-01-16 15:05 cbradney Note Added: 0003485
2005-01-16 15:12 cbradney Note Added: 0003487
2005-01-18 09:17 plinnell Note Added: 0003504
2005-01-18 09:17 plinnell Severity major => feature
2005-02-19 16:58 cbradney Note Added: 0003751
2005-02-24 04:53 Sivaraj File Added: lohit_ta.ttf
2005-02-24 04:59 Sivaraj File Added: sample_text.utf8
2005-02-24 05:17 Sivaraj Note Added: 0003810
2005-02-24 05:20 Sivaraj File Added: lohit_hi.ttf
2005-06-21 15:04 omiazad Note Added: 0005086
2005-06-21 15:07 omiazad Note Edited: 0005086
2005-06-21 15:09 omiazad File Added: SolaimanLipi.ttf
2005-06-21 15:10 omiazad Note Added: 0005087
2005-06-21 23:30 ringerc Status new => acknowledged
2005-12-15 17:58 plinnell Relationship added related to 0002920
2005-12-29 05:29 ringerc Relationship added related to 0001726
2005-12-29 05:29 ringerc Relationship added related to 0002756
2006-07-02 21:50 mhanski Relationship added related to 0003928
2006-07-02 21:58 mhanski Relationship added child of 0003965
2007-01-04 09:09 cbradney Category Story Editor / Text Frames => NLS
2008-07-15 21:32 plinnell Relationship added has duplicate 0007140
2008-07-29 10:14 cfynn Note Added: 0020063
2008-07-29 14:44 cfynn Note Added: 0020065
2009-07-27 15:54 plinnell Relationship added parent of 0008305
2012-01-21 16:09 sungkhum File Added: Battambang-Regular_0.ttf
2012-01-21 16:11 sungkhum File Added: Khmer-Sample.txt
2012-01-21 16:12 sungkhum Note Added: 0027583
2012-01-21 19:34 jghali Note Added: 0027584
2012-01-31 13:58 sivakumj Note Added: 0027632
2012-01-31 15:02 sungkhum Note Added: 0027634
2012-09-02 14:36 jeffmcneill Note Added: 0028890
2012-09-03 04:56 christoph_s Note Added: 0028894
2012-09-03 05:08 sungkhum Note Added: 0028895
2012-09-03 06:16 sivakumj Note Added: 0028896
2012-09-03 06:30 christoph_s Note Added: 0028897
2012-09-03 06:45 sungkhum Note Added: 0028898
2012-09-03 07:44 ale Note Added: 0028900
2013-05-01 13:28 jghali Relationship added related to 0011513
2014-09-21 14:49 jghali Relationship added has duplicate 0012721
2014-11-16 14:10 jghali Relationship added has duplicate 0012813
2015-05-10 13:47 Sabarish Note Added: 0035083
2015-05-11 04:05 Kunda Note Added: 0035087
2016-03-23 12:36 Kunda Note Added: 0039350
2016-03-23 12:36 Kunda Tag Attached: RTL
2016-03-23 12:37 Kunda Tag Attached: fixed
2016-03-23 12:37 Kunda Tag Attached: #please_test
2016-03-23 12:38 Kunda Tag Attached: HOST-Oman
2016-03-26 13:38 Kunda Relationship added parent of 0006004
2016-05-14 09:56 jghali Relationship added has duplicate 0014054
2016-08-26 06:35 jghali Relationship added has duplicate 0014271
2016-09-15 08:53 shreeshrii Note Added: 0042001
2016-09-15 09:18 shreeshrii Note Added: 0042002
2016-09-15 12:00 ale Tag Detached: RTL
2016-09-15 12:01 ale Note Added: 0042003
2016-09-15 12:01 ale Tag Attached: CTL
2016-09-15 15:59 shreeshrii File Added: scribus-devanagari-error.png
2016-09-15 15:59 shreeshrii Note Added: 0042007
2016-09-15 16:01 shreeshrii File Added: scribus-devanagari.txt
2016-09-15 16:01 shreeshrii Note Added: 0042008
2016-09-15 19:23 cbradney File Added: Screenshot 2016-09-15 21.22.29.png
2016-09-15 19:23 cbradney Note Added: 0042010
2016-09-16 04:01 shreeshrii Note Added: 0042013
2016-12-03 22:18 cbradney Assigned To => Fahad
2016-12-03 22:18 cbradney Status acknowledged => resolved
2016-12-03 22:18 cbradney Resolution open => fixed
2016-12-03 22:18 cbradney Fixed in Version => 1.5.3.svn
2016-12-03 22:18 cbradney Note Added: 0042618
2016-12-05 20:21 cbradney Status resolved => closed
2016-12-08 21:41 cbradney Target Version => 1.5.3