View Issue Details

IDProjectCategoryView StatusLast Update
0003928ScribusNLSpublic2016-12-08 21:41
Reportermarkpeak Assigned ToFahad  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
PlatformAllOSOS Version
Product Version1.2.4.1 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0003928: Support line breaking for Thai text
DescriptionLine breaking is the big issue for Thai. Softwares without Thai line breaking are unusable for ordinary people, especially for DTP or graphics industry.

For your information, whitespaces are used to separate between "sentences" or "phrases", not "words" as Latin script. This is still different from East Asian languages (CJK) which each character means one word. So Thai line breaking needs dictionary to distinguish word boundary and insert break points for display.

There are some Thai linebreaking library available on major platforms (Windows, Linux, Mac):
- Windows applications can use Microsoft Uniscribe. IE done this.
- Mac applications can use Apple own library, integrated with OSX. Safari done this.
- Linux applications can use libthai, many GTK+ and Qt applications use libthai for line breaking already.
- Another alternative library is ICU, which available cross-platform too.

Since KDE handle line breaking issue perfectly via libthai and Scribus is Qt application. Adding line breaking for Scribus is big advantafe for Thai people. On Windows, it can use Uniscribe.
Tags#please_test, CJK, fixed, HOST-Oman, scribusctl
Patch

Relationships

related to 0002920 closedFahad Khmer script is rendered wrong 
related to 0001547 closedFahad Support for Indic Scripts 
related to 0003680 closedFahad Devanagari (Unicode U+09xx) glyph formation (vowels and conjunct consonants) not proper 
has duplicate 0009349 closedcbradney Can't write Japanese/Chinese/Korean in Scribus 
has duplicate 0010063 closedjghali Non roman fonts not displayed (but displayed well in editor) 
has duplicate 0010231 closedjghali not support with Thai font 
related to 0005937 confirmed Lao line wrapping and hyphenization 
child of 0003965 acknowledged Metabug: Support for non-latin languages 
child of 0003828 acknowledged Metabug: Hyphenation 

Activities

markpeak

2006-06-19 04:53

reporter   ~0011662

Libthai information can be found at http://linux.thai.net/plone/TLWG/libthai/

bountonw

2007-06-23 23:37

reporter   ~0016652

Last edited: 2016-03-22 23:19

View 2 revisions

This thread should also be added as a child of 0003828 Metabug:hypenization

bountonw

2009-01-30 07:47

reporter   ~0021046

What is the progress of this thread? It has been 2 1/2 years. When can Thai be used in Scribus?

cbradney

2009-01-30 20:44

administrator   ~0021047

when its ready.. I'm almost sure that wont be in 2009.

zhangweiwu

2009-07-09 17:58

reporter   ~0022152

This seems not a Thai-specific issue but common issue for any ideographic language. I guess it affects all CJK users.

In fact I filed a bug about this issue back in 2005 or 2006 and was closed because non-latin language was not supported (if I remember well) so it is not just 2.5 years old. So far it is perhaps 5 years old.

I reported the same bug to scribus' competitor pagestream and the issue was fixed in the following week. 8272 has an attachment shows the problem does not exist in pagestream. This problem also do not exist in OOO Draw which can be used for entry level DTP when there isn't text-frame linking requirement.

I hope who have the authority can change the subject of this bug to also include other keywords people might start searching by, add "Chinese, Japanese, Korean, ideograph" there.

cbradney

2009-07-09 18:44

administrator   ~0022155

We simply do not have the resources to work on non-Latin extensively at this point. What work is being done on fonts/layout is making progress. Right now, our priority is the 1.3.5 release.

zhangweiwu

2009-07-10 00:07

reporter   ~0022157

Last edited: 2009-07-10 00:10

Hi. Not mean to push or blame any one (you did a good job created scribus in the first place), but I think line-break is a small correction & should be easy.

In general there are many bugs in non-latin for the "correct" typography and many are hard to make right (e.g. space between ideographs), but most of them are not so obvious to ordinary reader. They probably feel something looks not so right but they cannot tell what is wrong. They think "oh this thing isn't perfect". Working on such issue is "working extensively".

This bug is different that people immediately tell it is wrong and where is wrong. Readers think "this is broken". Yet this issue doesn't sound difficult. It can be done by simply adding zero-width space before and after each ideograph, and there are library to do just this without covering all typography issue, for the very same reason (that line break issue is obvious to readers without typography knowledge) http://vimgadgets.sourceforge.net/liblinebreak/?. I am not sure, I guess such issue is not "working extensively".

So it's very appreciated if some developer can poke into it and see if this is really a hard nut before deciding not to crack it:)

Solving this problem makes Scribus from "unusable" to "usable". It is not correct typographic yet, while you have a large user base who don't care that much (which makes up most user base if you look at how generally typography is badly done here in China).

bountonw

2009-07-10 01:19

reporter   ~0022158

Glad to see someone is finally saying something here. Basically until this is resolved, scribus is not usable for Thai, Lao, and Khmer. We don't have scribus installed anymore on our 15 computers because. Using MS Publisher and InDesign for our publishing needs until scribus can handle the SE Asian scripts. Unfortunately I have had to advise others to do the same.

bountonw

2010-03-16 06:34

reporter   ~0023518

Ok. It has been nearly 4 years now since this bug was reported. Please assign this. Many Thais would love to have an open source solution to their publishing needs.

mhanski

2010-03-16 16:33

developer   ~0023521

<quote>Please assign this. Many Thais would love to have an open source solution to their publishing needs.</quote>

then I suggest, those many Thais should stop waiting and start contributing a little more to the solution. E.g. in finding a Thai software developer or a computer science student who would like to fix it. He could even apply with Google Summer of Code 2010 and get paid for it, see http://wiki.scribus.net/index.php/Category:GSOC_2010 and http://wiki.scribus.net/index.php/GSoC_2010_Ideas#Text for more.

zhangweiwu

2010-03-17 00:21

reporter   ~0023526

Last edited: 2010-03-17 00:25

View 4 revisions

This is not the attitude I usually see in other foss/opensource projects like Ubuntu, Drupal and many others. Basically you are saying "I don't care about you, you were not supposed to use scribus." (Or can you challange me you don't mean that?)

Usually, the developers would explain their effort is hindered by lack of knowledge or resource on particular issue, but meanwhile do not try to stop user from complaining or set a bar for those who wants to complain.

It is rather surprising to see such comments so many years after foss/opensource movement and so much effort from Ubuntu / other foss projects to develop usage centric software after just having fun. I admit I had some dejavu though, as I had frequented such comments (and common reference to "how to ask question the smart way") when I was still in college 7 years ago.

I also would prefer you to try to silent me, the Chinese, instead of the innocent messenger the bug reporter. Because we Chinese created all the trouble after all. Most of Asian languages who suffer from this ideograph layout bug are heavily influenced by Chinese on their roots, otherwise they might have invented a phonetic language instead of ideographs. Yet China have greatest population without contribution on solving this bug (most of them never even heard of foss, not to even mention Scribus). So subtle, an evangelist might want to win us by converting those who had previously doubted foss merits, and a medieval king, might declares us devil and kills us.

christoph_s

2010-03-17 00:34

administrator   ~0023527

>>Or can you challange me you don't mean that?

Knowing mhanski, I can assure you he doesn't mean that.

Instead, it would be helpful to have some programmers available who are familiar with the requirements of any of the non-Latin alphabets. Try to look at it this way: the programmers are located in European countries that use only a few special characters compared to the standard Latin/English alphabet. We needed (and still) some input from people who are writing Polish or a language that uses a Cyrillic alphabet. Since these alphabets are following the same principles, it was doable. Languages like Thai or Chinese follow entirely different principles, and we'd love to implement them, but the most effective way would be contributions from programmers who actually use these scripts, because they know what's important and what not (it's not just glyph shaping, obviously). For Thai that would be programmers from Thailand, for Chinese, programmers from China, etc.

No reason to be offended, really :)

cbradney

2010-03-17 19:43

administrator   ~0023540

You might also want to understand that the text system has been rewritten, so something other than latin languages could be rendered ok..


also, we currently have 3 main active coding developers, of which each have about 4h maximum spare per day.. and this could sometimes be less than 1h from 1 person per day.. so implementing something we know nothing about is not exactly easy. We are very open to code submissions that would allow us to support any added feature that makes sense, like this one.

bountonw

2010-03-25 11:29

reporter   ~0023606

Adding the zero-width word joiner if it is not already added, would be a start. Indesign does not support this character.

But on a different note, I have several potential helpers. Incrementally, step 1,2,3, where should I point them and what can they work on, specifically?

ale

2010-03-26 20:09

manager   ~0023611

bountonw: i have a small good news for you: the zero width space is already implemented in 1.3.6.

for the potential helpers: it's not easy to step in but i also think that every help is welcome!

the best would be if you could come into our irc channel (http://www.scribus.net/?q=irc) on an evening CET or through the weekend.

mhanski

2010-03-29 10:15

developer   ~0023624

@bountonw: alternatively, get in touch with scribus core team devs on this mailing list: http://lists.scribus.info/mailman/listinfo/scribus-dev

Kunda

2016-04-09 16:04

manager   ~0039964

Once CTL is merged we should test this to make sure it's been fixed.

user5122

2016-05-07 04:10

  ~0040860

Thai line breaking and any other scripts supported by ICU should work with CTL branch. We specifically tested Thai and to the best of our knowledge it works fine, but we would love confirmation from native Thai readers.

cbradney

2016-12-03 22:40

administrator   ~0042626

r21564

Issue History

Date Modified Username Field Change
2006-06-19 04:52 markpeak New Issue
2006-06-19 04:53 markpeak Note Added: 0011662
2006-07-02 21:49 mhanski Relationship added related to 0002920
2006-07-02 21:50 mhanski Relationship added related to 0001547
2006-07-02 21:51 mhanski Relationship added related to 0003680
2006-07-02 21:55 mhanski Relationship added child of 0003965
2006-07-03 09:31 avox Status new => confirmed
2007-01-04 09:09 cbradney Category Story Editor / Text Frames => NLS
2007-06-23 23:37 bountonw Note Added: 0016652
2007-06-28 10:20 avox Relationship added related to 0005937
2009-01-30 07:47 bountonw Note Added: 0021046
2009-01-30 20:44 cbradney Note Added: 0021047
2009-07-09 17:58 zhangweiwu Note Added: 0022152
2009-07-09 18:44 cbradney Note Added: 0022155
2009-07-10 00:07 zhangweiwu Note Added: 0022157
2009-07-10 00:08 zhangweiwu Note Edited: 0022157
2009-07-10 00:10 zhangweiwu Note Edited: 0022157
2009-07-10 01:19 bountonw Note Added: 0022158
2010-03-16 06:34 bountonw Note Added: 0023518
2010-03-16 16:33 mhanski Note Added: 0023521
2010-03-17 00:21 zhangweiwu Note Added: 0023526
2010-03-17 00:22 zhangweiwu Note Edited: 0023526 View Revisions
2010-03-17 00:23 zhangweiwu Note Edited: 0023526 View Revisions
2010-03-17 00:25 zhangweiwu Note Edited: 0023526 View Revisions
2010-03-17 00:34 christoph_s Note Added: 0023527
2010-03-17 19:43 cbradney Note Added: 0023540
2010-03-25 11:29 bountonw Note Added: 0023606
2010-03-26 20:09 ale Note Added: 0023611
2010-03-29 10:15 mhanski Note Added: 0023624
2010-09-08 19:02 cbradney Relationship added has duplicate 0009349
2011-06-21 11:12 jghali Relationship added has duplicate 0010063
2011-09-01 06:40 jghali Relationship added has duplicate 0010231
2016-03-22 23:19 Kunda Note Edited: 0016652 View Revisions
2016-03-22 23:21 Kunda Relationship added child of 0003828
2016-04-09 05:28 Kunda Tag Attached: scribusctl
2016-04-09 16:04 Kunda Tag Attached: #please_test
2016-04-09 16:04 Kunda Tag Attached: fixed
2016-04-09 16:04 Kunda Tag Attached: HOST-Oman
2016-04-09 16:04 Kunda Note Added: 0039964
2016-05-07 04:10 user5122 Note Added: 0040860
2016-11-17 11:55 Kunda Tag Attached: CJK
2016-12-03 22:40 cbradney Assigned To => Fahad
2016-12-03 22:40 cbradney Status confirmed => resolved
2016-12-03 22:40 cbradney Resolution open => fixed
2016-12-03 22:40 cbradney Fixed in Version => 1.5.3.svn
2016-12-03 22:40 cbradney Note Added: 0042626
2016-12-05 20:21 cbradney Status resolved => closed
2016-12-08 21:41 cbradney Target Version => 1.5.3