View Issue Details

IDProjectCategoryView StatusLast Update
0003911ScribusStory Editor / Text Framespublic2006-12-22 22:19
Reporterchristoph_s Assigned Toavox  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformanyOSanyOS Versionany
Product Version1.3.4cvs 
Target VersionFixed in Version1.3.4cvs 
Summary0003911: Enable "forced" hyphenation
DescriptionCurrently it is impossible to enforce hyphenation for single words without changing the preferences (e.g. smallest word, consecutive hyphenations allowed, language). There are, however, situations that require a hyphenation despite of the general rules for a document. IMHO it would be useful if Scribus would either allow "forced hyphenation" in the prefs (checkbox or something like that), meaning that a Ctrl+ - will override the settings, or a special shortcut for this purpose.
Additional InformationCharacter styles won't be a satisfying solution here, because creating a separate style for each required hyphenation is too time consuming.
TagsNo tags attached.
Patch

Relationships

related to 0000577 closedcbradney Paragraph Styles -> Kerning and language options missing 
related to 0001155 acknowledged Support non-breakable text blocks 
related to 0001108 assignedavox Let user specify hyphenation exceptions 
related to 0002576 acknowledged Add a GUI to create user dictionaries for hyphenation and short words (and spellchecking) 
related to 0003094 acknowledged Add "hyphenation space" to hyphenation features (AKA hyphenation zone for ragged text) 
related to 0000417 acknowledged hyphenate word by minimum *letters* options 
child of 0003828 acknowledged Metabug: Hyphenation 

Activities

avox

2006-06-15 19:13

administrator   ~0011646

what's wrong with Insert->Smart Hyphen ?

christoph_s

2006-06-15 19:19

administrator   ~0011647

Smart hyphens don't work if they don't fit with the "smallest word" and "consecutive hyphenations allowed" settings. E.g. if only 2 consecutive hyphenations are allowed, one can't add a third one as an exception. We need an option to override the settings under special circumstances.

avox

2006-06-16 17:40

administrator   ~0011649

Currently a forced linebreak doesn't justify the current line (which I consider a bug).

If a forced linebreak did not change the alignment of the current line, you could just type
'hyphen SHIFT-ENTER' to achieve your goal, no? Or would you prefer that "smarthyphen
SHIFT-ENTER" also expands the smarthyphen?
The current behaviour could be retrieved by typing "TAB SHIFT_ENTER", once we have a default
right tab at the column end.

Please note that with NLS a simple SHIFT-ENTER will pull words from previous lines to fill the
manually broken one.

christoph_s

2006-06-16 23:25

administrator   ~0011651

avox, I might be asleep at the wheel, but what is NLS?

avox

2006-06-17 00:07

administrator   ~0011652

NLS = new layout system.

The one that does linebreak optimisation for whole paragraphs. Kind of like in TeX.

christoph_s

2006-06-17 22:47

administrator   ~0011660

avox, I'm not sure we are talking about the same issue here. I was thinking of a real hyphen, not just a dash. By hyphen I mean something that will disappear if the word moves left or right/next line and the linebreak becomes obsolete -- just as a smart hyphen. The only difference in my proposal is that a forced hyphen would ignore the preferences, compared to a normal smart hyphen.

As sn alternative, it would be possible to have an option in the hyphenation preferences "Allow overriding by smart hyphens" or something like that. But this approach would be a bit more inflexible.

avox

2006-06-19 20:47

administrator   ~0011663

christoph,

until now I thought a forced hyphen implied a linebreak.
How would a forced hyphen become obsolete? Or other way round,
when would a forced hyphen be used to break the line?

christoph_s

2006-06-19 21:27

administrator   ~0011665

Andreas, it's possible I haven't been clear enough. What I am thinking of is a "rude" smart hyphen that will force a linebreak (if it makes sense), no matter what the settings for consecutive hyphenation and/or smallest word are. Example:

(-: automatic hyphen, =: smart hyphen, _: rude hyphen, 2 consectutive hyphenations permitted
Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Ut a sapien. Ali-
quam aliquet purus molestie dolor. Integer quis eros ut erat posuere dic=
tum. Curabitur dignissim. Integer orci. Fusce vulputate lacus at ipsum. Quis_
que...

BUT:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Ut a sapien. Ali-
quam aliquet purus molestie dolor. Integer quis eros ut erat posuere dic-
tum. Curabitur dignissim. Integer orci. Fusce vul_pu=tate lacus at ipsum.

In the second case, no hyphenation would occur, since it wouldn't make any sense, and the regular smart hyphen doesn't work, because only 2 consecutive hyphenations are allowed.

This is one possibility. Another one would be "brute force" hyphenation, i.e. hyphenation in any case.

Maybe it's necessary to offer both possibilities. The more I think about it, the more useful both options appear to me?

Can you follow me? ;)

avox

2006-06-19 21:39

administrator   ~0011666

I think so but it sounds too complicated. You want another kind of smart hyphen which ignores the "max consecutive hyphens" setting? How would you explain that to users?

IMO automatic hyphen, smart hyphen and hyphen+unconditional break are enough (plus some
possibility to manually disallow hyphenation, e.g by placing a smart hyphen before a word).

christoph_s

2006-06-19 22:06

administrator   ~0011667

>>>How would you explain that to users?

E.g. by mentioning the feature in the docs. It would be enough to explain how the two types of smart hyphens work: 1. will only hyphenate if the settings permit 2. will hyphenate even if they don't.

From a usability point of view, I really don't see a big issue here.

>>>(plus some possibility to manually disallow hyphenation, e.g by placing a smart hyphen before a word)

That'd be more like 2576, wouldn't it?

As for the rest, the unconditional break may be enough. It's just that the "stronger" smart hyphen still might be a bit more sophisticated, because if column width or text size change, the hyphenation would disappear when it doesn't make sense any more. A forced break OTOH will remain in place.

PLucAuclair

2006-06-20 16:11

reporter   ~0011670

christoph_s, that's the way it works in InDesign right? Using Ctrl+Shift+- IIRC?

christoph_s

2006-06-20 16:25

administrator   ~0011671

>>>christoph_s, that's the way it works in InDesign right?

PLucAuclair, I have no idea, because I don't have ID. Currently I can't even tell the Quark way since I have a new hard drive and freshly bought WinXP, and QXP has yet to be installed :(

louisdesjardins

2006-06-21 02:43

developer   ~0011673

I will check this with Quark and ID tomorrow and get back to you guys. :)

louisdesjardins

2006-06-22 12:04

developer   ~0011682

Quark:
Hyphenation & Justification is set to max 3 consecutive hyphens. You have 2 ways to introduce a 4th consecutive hyphen. 1) Put a hard hyphen and SHIFT-RETURN (this is the most unelegant workaround) or 2) Change the H & J settings to 4 consecutive hyphens max. Note that the H & J settings applies to whole paragraphs and can be part of a stylesheet.

I will get back with ID just as soon as I can.

The idea of having a "smart-override-settings-hyphen" is very interesting.

PLucAuclair

2006-06-24 21:04

reporter   ~0011693

Here's how the user-set hyphenation works in InDesign (I verified when I got had to work on it):

To disable completely hyphenation of a word, you put the cursor before a word (e.g. |word) and activate Ctrl+Shift+-.

When you want to force hyphenate somewhere, put the cursor where you want it (e.g. abs|tract) and once again activate Ctrl+Shift+-.

louisdesjardins

2006-06-27 01:52

developer   ~0011701

Yes but Quark also works that way. Exactly. The no-hyphen for "this" word prevents "this" word from being hyphenated no matter what the H & J settings is. The "hyphen here if needed" does not work against the general H & J settings. Si basically Quark has no answer to this particular bug report.

You don't answer the question whether in ID the discretionary hyphen you introduce would ever force ID to put 4 hyphens (thus going against the rule the user establishes considering he/she puts 3 hyphens in a row maximum) in a row in a single paragraph.

I am sorry I haven't had a chance to have a look at this at the office. Again, as soon as I can, I will check. Or you will, before I do!

PLucAuclair

2006-07-03 21:44

reporter   ~0011785

That's right, I was not able so enforce it without inserting a non-breaking hyphen and a forced line return.

avox

2006-11-15 07:55

administrator   ~0013412

Ok, manual SmartHyphens are rude now.

Now there's also a difference between SmartHyphens inserted by extras->hyphenate and those manually inserted by insert->character. The latter is stored as Unicode character in the file, the other is a flag.

extras->dehyphenate currently only removes the hyphens inserted by hyphenate, manual hyphens can be deleted with backspace.

if a word contains a manual SmartHyphen, extras->hyphenate will *not* try to hyphenate that word.

avox

2006-11-15 08:02

administrator   ~0013413

Oh yes, I forgot. The manual breaks (new line / column break / frame break) now justify the last line, unless they follow a space. So the old behaviour can be regained by inserting a space before the manual break.

Issue History

Date Modified Username Field Change
2006-06-13 01:53 christoph_s New Issue
2006-06-13 01:54 christoph_s Relationship added child of 0003828
2006-06-13 01:54 christoph_s Relationship added related to 0000577
2006-06-13 01:55 christoph_s Relationship added related to 0001155
2006-06-13 01:56 christoph_s Relationship added related to 0001108
2006-06-13 01:56 christoph_s Relationship added related to 0002576
2006-06-13 01:57 christoph_s Relationship added related to 0003094
2006-06-13 01:58 christoph_s Relationship added related to 0000417
2006-06-13 01:59 christoph_s Additional Information Updated
2006-06-15 19:13 avox Note Added: 0011646
2006-06-15 19:19 christoph_s Note Added: 0011647
2006-06-16 17:32 avox Status new => assigned
2006-06-16 17:32 avox Assigned To => avox
2006-06-16 17:40 avox Note Added: 0011649
2006-06-16 23:25 christoph_s Note Added: 0011651
2006-06-17 00:07 avox Note Added: 0011652
2006-06-17 22:47 christoph_s Note Added: 0011660
2006-06-19 20:47 avox Note Added: 0011663
2006-06-19 21:27 christoph_s Note Added: 0011665
2006-06-19 21:39 avox Note Added: 0011666
2006-06-19 22:06 christoph_s Note Added: 0011667
2006-06-20 16:11 PLucAuclair Note Added: 0011670
2006-06-20 16:25 christoph_s Note Added: 0011671
2006-06-21 02:43 louisdesjardins Note Added: 0011673
2006-06-22 12:04 louisdesjardins Note Added: 0011682
2006-06-24 21:04 PLucAuclair Note Added: 0011693
2006-06-27 01:52 louisdesjardins Note Added: 0011701
2006-07-03 21:44 PLucAuclair Note Added: 0011785
2006-11-15 07:55 avox Status assigned => resolved
2006-11-15 07:55 avox Fixed in Version => 1.3.4cvs
2006-11-15 07:55 avox Resolution open => fixed
2006-11-15 07:55 avox Note Added: 0013412
2006-11-15 08:02 avox Note Added: 0013413
2006-12-22 22:19 avox Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames