View Issue Details

IDProjectCategoryView StatusLast Update
0004724ScribusGeneralpublic2014-09-14 12:57
Reporterchristoph_s Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version1.3 
Target VersionFixed in Version 
Summary0004724: Option to determine the size of a vector drawing at import time
DescriptionSome imported vector drawings appear really huge, often many times the size of a page. It would be useful if the user could determine x and y size at import time.
TagsNo tags attached.
Patch

Relationships

duplicate of 0012576 new limit the "size" of dropped vectors 
parent of 0010995 new Enable click and drag when importing a vector file (+ ability to set a specific size) 
related to 0007707 closed [Proposal] Trigger a dialog for dropped images (mockup included) 
Not all the children of this issue are yet resolved or closed.

Activities

fschmid

2006-12-05 08:31

administrator   ~0013763

Hmm, thats difficult, for EPS and SVG its relativly easy, but SXD and ODG files are problematic here. The OpenOffice formats are zipped archives which means that we must unpack them and that might be too slow for the preview.

christoph_s

2006-12-06 18:16

administrator   ~0013803

What does preview mean in this context? My thought was more of simple dialog that indicates the dimensions of the drawing if imported "as is" and lets the user change it as appropriate, e.g.

Vector Import (Caption):

X:_____
Y:_____

If users can see that the drawing has a height of, say 25 cm, they can easily change it to 5 cm, Fine tuning can be done afterwards. As it stands now, many vector drawings are larger than standard page sizes, and minimizing them requires another zoom factor, which can be annoying.

christoph_s

2014-07-30 20:33

administrator   ~0033093

The ODG importer has been rewritten now, and preview works. Moreover, I'd prefer a solution similar or identical to the handling of other items, not the least for the sake of consistency: click: dialog, Ctrl+click: fit to guides, click+drag: determine size.

ale

2014-07-31 08:30

manager   ~0033106

being able to define the size of imported vectors would be terrific.

but only the click and drag + fitting the guides (shift click...) behaviors should be supported...

please, no popup (it's faster to change the size in the PP or by dragging: the popup is just in the way).

a simple click should just place the vector. as it currently does.

Kunda

2014-09-14 12:38

updater   ~0033685

Last edited: 2014-09-14 12:55

View 2 revisions

christoph_s so do i understand you correctly that the OSG importer does ask the user to determine the size at import? Is this through a popup ?

EDIT:
Shall we continue the discussion in comment queue of 0012576 ?

Kunda

2014-09-14 12:57

updater   ~0033690

Closing issue in favor of having the discussion in one place: 0012576

Issue History

Date Modified Username Field Change
2006-12-04 11:35 christoph_s New Issue
2006-12-05 08:31 fschmid Note Added: 0013763
2006-12-06 18:16 christoph_s Note Added: 0013803
2014-07-30 20:15 Kunda Relationship added related to 0007707
2014-07-30 20:15 Kunda Relationship added related to 0012576
2014-07-30 20:33 christoph_s Note Added: 0033093
2014-07-31 08:30 ale Note Added: 0033106
2014-07-31 08:43 ale Relationship added parent of 0010995
2014-09-14 12:38 Kunda Note Added: 0033685
2014-09-14 12:55 Kunda Note Edited: 0033685 View Revisions
2014-09-14 12:55 Kunda Relationship replaced duplicate of 0012576
2014-09-14 12:57 Kunda Note Added: 0033690
2014-09-14 12:57 Kunda Status new => closed
2014-09-14 12:57 Kunda Resolution open => duplicate