View Issue Details

IDProjectCategoryView StatusLast Update
0007707ScribusUser Interfacepublic2014-09-14 12:53
ReporteraliB Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformDell Inspiron 9400OSLinuxOS VersionOpenSuSE 11.1
Product Version1.3.5svn 
Target VersionFixed in Version 
Summary0007707: [Proposal] Trigger a dialog for dropped images (mockup included)
DescriptionIf you drag an image from your filesystem into scribus, the image is placed with the original size. This is very annoying if you have a highres picture.

It would be nice to provide a dialog with some options (see screenshot)
TagsNo tags attached.
Patch

Relationships

duplicate of 0012576 new limit the "size" of dropped vectors 
related to 0010995 new Enable click and drag when importing a vector file (+ ability to set a specific size) 
related to 0004724 closed Option to determine the size of a vector drawing at import time 
related to 0012542 closedfschmid Picture Browser: Dragn'n'Drop doesn't work reliably 
related to 0012558 closedcbradney [PATCH] limit the "size" of dropped images 
related to 0012598 new [Proposal] Temporary (stackable) hint bubbles instead of unpopular popup dialogs 

Activities

2009-01-06 09:14

 

insertdialog.png (13,079 bytes)
insertdialog.png (13,079 bytes)

pygmee

2009-01-06 20:23

developer   ~0020882

Interesting but dangerous since the DTP software would have to resample pictures. I guess, this would be interesting to check at export time if pictures are OK. This would need some new batch features for picture handling in Scribus. This point have already been mentionned but Louis ans I during Phatch demo at LGM2008.

aliB

2009-01-06 20:39

reporter   ~0020883

Last edited: 2009-01-06 20:40

No, it would not.
You just set the framesize as selected in the dialog.
the last two options are ment to be the same as already exists in the register image of an image frame (last two options)

Crop the image on pdf export to the framesize would be another useful feature.

Kunda

2014-07-26 13:08

updater   ~0033023

+1 on this idea. Triggering a dialog gives the user some helpful options. If they don't like it, they check 'do not popup dialog'. This would also solve 0010995

ale

2014-07-26 18:55

manager   ~0033034

-1 to this idea.

this can be better solved by making the PP accessible.

if you want to further control how the image is shown when dropped into scribus, just create an image frame (or duplicate an existing one) before dropping the image!

still, one sane enhancement that i extract from the proposal, is to limit the size of the newly created frame to the size of the page. i'll create a ticket with this proposition.

imho a "don't annoy me" button is the sign that the solution "stinks" :-)
(the problem might be real, though...)

Kunda

2014-07-30 20:35

updater   ~0033094

ale, Christoph has a rebuttal here: 0004724:0033093

ale

2014-07-31 08:27

manager   ~0033105

imo, the pop up on click without drag should be removed.

we discussed it in leipzig and nobody could come up with a reason for wanting it.
if you don't drag after clicking, the frame should simple be created at a default size (defined in the settings)

the only reason why people are seeing the dialog is, because they made an error and the dialog is an annoyance to click away before the next action is performed (mostly, deleting the item and start again; sometimes resizing it by draggin its handles)

i'll make a ticket for this.

ale

2014-07-31 08:32

manager   ~0033107

as also noted in the other ticket, being able to set the size of the imported vector would be terrific!

i'm all for it.

just the popup is really unneeded. the mouse or the PP are the better and faster solution.

Kunda

2014-09-14 12:53

updater   ~0033689

Merged this discussion in to 0012576:0033686
Closing issue as duplicate

Issue History

Date Modified Username Field Change
2009-01-06 09:14 aliB New Issue
2009-01-06 09:14 aliB File Added: insertdialog.png
2009-01-06 20:23 pygmee Note Added: 0020882
2009-01-06 20:39 aliB Note Added: 0020883
2009-01-06 20:40 aliB Note Edited: 0020883
2014-07-26 12:50 Kunda Tag Attached: duplicate content
2014-07-26 12:54 Kunda Relationship added related to 0010995
2014-07-26 12:58 Kunda Tag Detached: duplicate content
2014-07-26 12:59 Kunda Summary Better handling for dropped images => [Proposal] Trigger a dialog for dropped images (mockup included)
2014-07-26 13:00 Kunda Relationship added related to 0012542
2014-07-26 13:08 Kunda Note Added: 0033023
2014-07-26 18:55 ale Note Added: 0033034
2014-07-26 19:02 ale Relationship added related to 0012558
2014-07-30 19:57 ale Relationship added related to 0012576
2014-07-30 20:15 Kunda Relationship added related to 0004724
2014-07-30 20:35 Kunda Note Added: 0033094
2014-07-31 08:27 ale Note Added: 0033105
2014-07-31 08:32 ale Note Added: 0033107
2014-08-11 18:52 Kunda Relationship added related to 0012598
2014-09-14 12:52 Kunda Relationship replaced duplicate of 0012576
2014-09-14 12:53 Kunda Note Added: 0033689
2014-09-14 12:53 Kunda Status new => closed
2014-09-14 12:53 Kunda Resolution open => duplicate