View Issue Details

IDProjectCategoryView StatusLast Update
0005435ScribusImport / Exportpublic2007-12-28 09:04
Reporterharaldmebus Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformINTEL DUAL COREOSWIN XP PRO SP2OS Version
Product Version1.3.3.9cvs 
Target Version1.3.3.10Fixed in Version 
Summary0005435: Generated PDF-Forms do not show background color of fields in some PDF-readers
DescriptionI generated a PDF-form out of the attached *.SLA file and opened it in AcrobatReader 8.0 and FoxitReader 2.0.
Result:

- form field background color is not visible in AcrobatReader
- form field background color is visible in FoxitReader

This behaviour does only apply to the 1.3.3.9cvs version of Scribus. The 1.3.3.8 version works well.

Steps To ReproduceExport the PDF out of the attached SLA file in Scribus 1.3.3.9cvs and open the attached PDF-File in different PDF-Readers.
Do the same with 1.3.3.8.
TagsNo tags attached.
Patch

Relationships

related to 0005408 closedfschmid Generated PDF-form doesn't show/accept äöüÄÖÜ 
related to 0005442 closedfschmid PDF forms export broken: Scribus 1.3.3.9cvs generates forms without fields, checkboxes etc. 
child of 0003831 acknowledged Metabug: PDF Forms 
child of 0005640 closedplinnell 1.3.3.10 Release 

Activities

2007-03-08 13:19

 

1339cvs-Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.pdf (204,392 bytes)

2007-03-08 13:22

 

1339cvs-Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.sla (322,303 bytes)

2007-03-08 14:10

 

test2.pdf (144,727 bytes)

mhanski

2007-03-08 14:20

developer   ~0015500

confirming, since I've experimented with setting the bg color using JavaScript, and Scribus/Scribus generated PDF forms resisted to obey:) Changing border/text color works fine. See the attached demo form test2.pdf and click on the "run external js" button to see, how the colors of the date field changes. The javascript used in this case is:

var fld = this.getField("date1");
//Change border color
fld.strokeColor = ["RGB",0.5,0.5,1];

//Change fill/background color
//this won't work with Scribus!
fld.Color = ["RGB",0,0,0.7];

//Change text color
fld.textColor = ["RGB", 0.5, 0, 0.5];

BTW, haraldmebus, your PDF form proves pretty well the issue I've reported recently in 0005408 -- neither Adobe Reader 7.08/Cabaret on Linux nor Adobe Reader 7.05 on Windows diplays its form fields, checkboxes, and list boxes, your form doesn't contain any form elements.

haraldmebus

2007-03-08 14:57

reporter   ~0015502

Since I'm still busy generating forms that we use in our company it's a valuable fact to have things confirmed and corrected. I appreciate the current development speed of Scribus and will do my part by testing and finding bugs :-))
BTW: I'm missing the feature of importing OO-forms into Scribus since we start using OO instead of ...

2007-03-08 20:48

 

1339cvs-Auftrag-und-Leistungsnachweis-V1-scr-master-corrected.pdf (359,169 bytes)

fschmid

2007-03-08 20:50

administrator   ~0015503

Thats very odd, regenerated the PDF here with 1.3.3.9cvs and it works. Only thing i've change was that i've set all the Fonts to "Embedded" here. See the 133....-corrected.pdf

2007-03-08 21:30

 

kerning_kaputt.png (128,622 bytes)
kerning_kaputt.png (128,622 bytes)

mhanski

2007-03-08 21:33

developer   ~0015504

Franz, I've opened your *corrected.pdf in Acroread 7.08, and see what I've got (screenshot kerning_kaputt.png of your pdf form attached).

fschmid

2007-03-09 15:37

administrator   ~0015506

Thats weired, the same pdf works fine here

BTw, i've added an extra check to the Preflighter that might help fixing the problems.

plinnell

2007-07-09 23:06

viewer   ~0016760

Form field colors are showing fine in PDF exported from 1.3.3.10svn, but the kerning in the fields is definitely messed up. Could this be caused by the fix from tsdegeos relating to having to define /Helvetica ?

Helvetica is shown as a font in the doc properties, but Acro Reader is using Arial. They are not metrically the same from what I understand.

plinnell

2007-07-09 23:08

viewer   ~0016761

One other comment: I noticed that this doc has CMYK output and ICC profiles embedded. Odd to me for an interactive screen based PDF.

mhanski

2007-11-28 19:48

developer   ~0018035

tested, everything works fine (form fields background, kerning in form fields, unicode glyphs in form fields), well done jghali, closing

Issue History

Date Modified Username Field Change
2007-03-08 13:19 haraldmebus New Issue
2007-03-08 13:19 haraldmebus File Added: 1339cvs-Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.pdf
2007-03-08 13:22 haraldmebus File Added: 1339cvs-Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.sla
2007-03-08 14:08 mhanski Relationship added child of 0003831
2007-03-08 14:09 mhanski Relationship added related to 0005408
2007-03-08 14:10 mhanski File Added: test2.pdf
2007-03-08 14:20 mhanski Note Added: 0015500
2007-03-08 14:20 mhanski Status new => confirmed
2007-03-08 14:57 haraldmebus Note Added: 0015502
2007-03-08 19:42 plinnell Status confirmed => assigned
2007-03-08 19:42 plinnell Assigned To => fschmid
2007-03-08 20:48 fschmid File Added: 1339cvs-Auftrag-und-Leistungsnachweis-V1-scr-master-corrected.pdf
2007-03-08 20:50 fschmid Note Added: 0015503
2007-03-08 21:30 mhanski File Added: kerning_kaputt.png
2007-03-08 21:33 mhanski Note Added: 0015504
2007-03-09 15:37 fschmid Note Added: 0015506
2007-03-12 14:17 mhanski Relationship added related to 0005442
2007-07-09 23:06 plinnell Note Added: 0016760
2007-07-09 23:08 plinnell Note Added: 0016761
2007-07-09 23:08 plinnell Relationship added child of 0005640
2007-11-27 09:09 jghali Assigned To fschmid => jghali
2007-11-27 09:12 jghali Status assigned => resolved
2007-11-27 09:12 jghali Resolution open => fixed
2007-11-28 19:48 mhanski Status resolved => closed
2007-11-28 19:48 mhanski Note Added: 0018035
2007-12-20 22:50 cbradney Target Version => 1.3.3.10cvs
2007-12-28 09:04 cbradney Target Version 1.3.3.10cvs => 1.3.3.10