View Issue Details

IDProjectCategoryView StatusLast Update
0006017ScribusTranslationpublic2016-03-26 08:49
Reporternadavkav Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformlinuxOSdebianOS Versionsid unstable
Product Version 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0006017: when loading hebrew translation, ui (menus) should be justified to the right
Descriptionstarting scribus in hebrew mode:
LANG=he_IL.UTF-8 scribus

loads the hebrew translations to menus and dialogs but it is all justified as english ltr ui.
Steps To Reproduceput the attached Hebrew translation file in the qm folder and start scribus as described in the first section: "LANG=he_IL.UTF-8 scribus"
TagsNo tags attached.
PatchNo

Relationships

related to 0013814 closedjghali Main Window layout should be RTL when Arabic translation selected 
related to 0013839 new RTL: Main Window layout formatting is off 
child of 0003965 acknowledged Metabug: Support for non-latin languages 

Activities

2007-07-21 13:54

 

scribus.he_IL.qm (4,303 bytes)

cbradney

2007-07-21 21:20

administrator   ~0016846

If this is a submission of a GUI translation file, please submit the ts file. a qm file is not much use to us other than the final result.

nadavkav

2007-07-21 22:12

reporter   ~0016847

this is just a very basic sample file to show the UI's justification issue
(it's not a complete translation file)

Kunda

2016-01-29 18:46

manager   ~0038487

Please test this on r20744

cbradney

2016-01-29 19:24

administrator   ~0038491

It won't have changed, the menu system doesn't know about RTL changes.

Kunda

2016-03-22 23:31

manager   ~0039344

This should also worked because of 0013814
Why isn't hebrew in the languages ?

Kunda

2016-03-24 05:50

manager   ~0039374

Hebrew is fixed in language UI again after r21111

Kunda

2016-03-24 05:54

manager   ~0039375

fixed when jghali applied Fahad's patch in r21087
reference: 0013814

Issue History

Date Modified Username Field Change
2007-07-21 13:54 nadavkav New Issue
2007-07-21 13:54 nadavkav File Added: scribus.he_IL.qm
2007-07-21 14:00 mhanski Relationship added child of 0003965
2007-07-21 21:20 cbradney Note Added: 0016846
2007-07-21 22:12 nadavkav Note Added: 0016847
2015-11-28 20:05 Kunda Patch => No
2015-11-28 20:05 Kunda Target Version => 1.5.2
2015-11-29 13:29 Kunda Category User Interface => Translation
2016-01-23 17:15 cbradney Target Version 1.5.2 => 1.5.4.svn
2016-01-29 18:46 Kunda Note Added: 0038487
2016-01-29 19:24 cbradney Note Added: 0038491
2016-03-22 23:31 Kunda Note Added: 0039344
2016-03-22 23:32 Kunda Assigned To => cbradney
2016-03-22 23:32 Kunda Status new => assigned
2016-03-22 23:32 Kunda Target Version 1.5.4.svn => 1.5.2
2016-03-22 23:49 Kunda Relationship added related to 0013814
2016-03-22 23:49 Kunda Relationship added related to 0013839
2016-03-24 05:50 Kunda Note Added: 0039374
2016-03-24 05:54 Kunda Note Added: 0039375
2016-03-24 05:54 Kunda Status assigned => closed
2016-03-24 05:54 Kunda Assigned To cbradney => jghali
2016-03-24 05:54 Kunda Resolution open => fixed
2016-03-24 05:54 Kunda Fixed in Version => 1.5.2
2016-03-26 08:49 jghali Fixed in Version 1.5.2 => 1.5.2.svn