View Issue Details

IDProjectCategoryView StatusLast Update
0000083ScribusGeneralpublic2010-04-20 16:37
Reportercbradney Assigned Toale  
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
Product Version1.3 
Target VersionFixed in Version 
Summary0000083: Booklet functionality
DescriptionRobert wanted a way of converting 4 page to 1 larger page, eg A4 x4 to A3, or double sided.
TagsNo tags attached.
Patch

Relationships

has duplicate 0000124 closedcbradney Booklet Functionality 
has duplicate 0001116 closed Manual duplex helper 
has duplicate 0005666 closedplinnell Modèles proposés 
has duplicate 0008900 closedjghali [feature request] imposition plugin 
related to 0001113 assigned Small document size repeated on larger paper 
related to 0003813 acknowledged Metabug: Scripter 
related to 0003837 acknowledged Metabug: Master pages/Page templates 

Activities

cbradney

2004-01-08 21:17

administrator   ~0000153

Moved from bug 0000124. Note from DeeJay1.

Easy printing of booklets in Scribus would be nice. Propably it's needed to do such things:
1. count the pages 2. if number of pages isn't even then ask if an empty last page should be added (add, go to step 3) or still edit (exit) 3. put the last page together with the first on a higher format page in landscape/portrait (if page was A5/portrait the page = A4/landscape) 4. repeat 3 until page count = 0

cnuman

2004-04-12 14:55

reporter   ~0001026

Is this still being worked on? This is the one thing I would need from Scribus - to move from Microsoft Publisher to Scribus on Linux.

Thanks for all your work on Scribus!

cbradney

2004-04-12 15:00

administrator   ~0001027

We havent worked on this yet. After 1.2 is released.

deejay1

2004-04-12 19:23

developer   ~0001030

Maybe take a look at http://imagic.weizmann.ac.il/~dov/freesw/impose+/
I think this could help as a temporary workaround, but didn't have time to test it...

plinnell

2004-04-13 02:40

viewer   ~0001044

If CUPS support is compiled in, you can do this if via N-up printing in the CUPS options, when printing. I tested it tonight took 4 US letter pages, used N-up option and then printed in landscape mode.

What this does not do which a true booklet printer is automatically sort order of pages and adjust the margins between the center of two logical pages like an imposition application would do.

deejay1

2004-08-26 08:25

developer   ~0002256

Just a note for more imposing (?) posibilities:
one could also arrange the pages not for an entire booklet but in a series of 4 ( or x*4 ) pages, so they all can be glued/sewed/whatever together.

deejay1

2004-09-04 21:53

developer   ~0002286

Another hint for those who search for a solution (I mean a temporary one :)

Look at http://nashi.altmuehlnet.de/pipermail/scribus/2003-October/002438.html

Joeboy

2004-12-22 19:33

reporter   ~0003208

If you're doing this, I hope you'll include an 'adjust for creep' feature. Not in the cups N-up facility AFAIK.

iho

2005-04-15 19:58

reporter   ~0004257

Last edited: 2005-04-15 20:01

I just want to add my voice to this. Of course, it's maybe not needed for professional usage, but it sure would be nice for home/maybe small office usage.

And I admit I would like to have all possibilities ;-) Like print impositions for binding booklike binding. And the opposite, resize the pages, so you can print 2 or for pages on one sheet (to save paper / handouts of overhead prints / etc.) (see related issue).

I don`t know, could it be possible to add this via the scripting interface?

deejay1

2005-11-18 11:29

developer   ~0007476

De-assigned from me, ENOTIME && ENOPROZAC, sorry :/

avox

2005-11-19 16:46

administrator   ~0007486

What about this idea for impositions:
we could use special masterpages which describe the imposition. Such a masterpage would consist of empty linked frames. When printing impositions, Scribus would fill those frames with the normal pages, using the link-order of the frames. When all frames of the imposition masterpage are filled, it is printed and printing resumes with a clean imposition page and the remaining normal pages. On the last imposition page some frames might be left blank.

For larger signatures one would need several imposition masterpages and link their frames across.
Eg. with four imposition master pages:

IMP1: IMP2: IMP3: IMP4:
8 1 2 7 6 3 4 5

Since one could add other page items on the imposition masterpages (registers and stuff like that)
and the frames would be subject to scaling and rotation, this would be a very powerful and flexible mechanism.

One could then use Scripter to get more specialized functions:
* booklet printing would generate IMPs as above and fill in empty pages at the users discretion
* address labels would create an IMP according to label specs
* print shops could provide templates with their own IMPs
* true signature printing could create IMPs for sheets which are folded several times and take into account the slight rotation caused by this folding.

MrB, any chance to get the pageitem & print stuff into a shape where this would be implementable?

ringerc

2005-11-22 08:00

reporter   ~0007509

I do think it's a very good idea to be able to "link" in a Scribus document such that it appears in a frame. As PageItem is starting to get saner (thanks cbradney!) now, this is looking more promising. It'd probably have to wait until PageItems can contain PageItems though (groups, tables) ... where upon external documents might not be that much of a stretch.

I expect it'd also be useful to be able to place a page from the same document into a frame.

Eventually it might be nice to be able to add a special page type for impositions, so a doc could contain the normal pages, plus one or more impositions, and the user could pick which they want to print / export.

Combine that with a plug-in or even a PyQt script to automatically generate some common booklet impositions, and we're all set for booklet printing. Being able to build that on support for pages-in-frames would make it a LOT easier, great idea.

What's even better is that the user could edit the generated imposition, or create their own, or (as you suggested) script it. When you consider that PyQt works just fine in Scribus 1.3, that has a LOT of potential.

Of course, it all hinges on support for pages in frames. I think both external ("linked") and internal (from the same document, possibly by importing a page an linking it or by using an existing page) support is important.

michael_krauth

2005-11-22 15:39

reporter   ~0007510

I tried to write a script for duplicating and relocating a document on a larger page, but i failed because there is no copyObject() function in the Scripter API :-)
But if it is implemented or I find a workaround, i will continue my script :-)

Michael

ringerc

2005-12-05 10:39

reporter   ~0007635

Some notes on imposition and various possible approaches; please extend as desired:

http://wiki.scribus.net/index.php/Imposition

ale

2006-03-16 09:56

manager   ~0009331

i've created a wiki page for the implementation of the imposition features for scribus:

http://wiki.scribus.net/index.php/Imposition_proposal

please read it and comment it!

a.l.e

pierremarchand

2006-09-28 22:54

reporter   ~0012691

Last edited: 2006-09-28 23:01

About impose.tar.gz, it's a try to allow Scribus users to make simple imposition in Scribus itself.
For now, it (is supposed to) support linked frames and master pages and all more simples things, but not linked frames IN master pages. It also gives you a chance to put margins and gaps ( vert. and hor.) in your imposed documents. A big problem is that you have to save and reopen your imposed document to make it work correctly. If you're not yet disgusted, you can install it uncompressing the archive in your plugin directory ( in CVS tree ) and add the impose directory in the CMakeLists.txt ( echo "ADD_SUBDIRECTORY(impose)" >> CMakeLists.txt) and build and install the plugin with cmake. He, you can access this plugin under Extra.

And more important, there is only signature size available (in4), but if you did all this work for install this plugin, you can go in ImposeIpmpl::init() and put whatever you need into it, or wait that I have time to do a better job.

And, it does NOT make booklets as psutils or multivalent can do, I mean a virtual imposition and folding and cutting.

pierremarchand

2006-09-29 21:04

reporter   ~0012701

The new version of impose allow you to add new signatures with a simple text editor[1], and so even when Scribus is running :) But you always need to save and reopen the imposed doc to see the result.
md5sum:
587994d7f25c0ecdb89f83de422bdc63 impose-veryalpha-2.tar.gz

[1] impose.rc is in $PREFIX/share/scribus/plugins/ and is xml and is quite self explanatory (can i say that?)

pierremarchand

2006-09-30 07:54

reporter   ~0012708

Because of problem uploading files, I put impose plugin archives at :
http://aeda.free.fr/scribus/

mhanski

2007-12-21 18:09

developer   ~0018383

Last edited: 2007-12-21 18:11

Craig, I'm not sure, but since you've integrated the imposition plugin (Extras/Imposition) into 1.3.5cvs, couldn't this one be considered as resolved?

christoph_s

2007-12-21 19:24

administrator   ~0018384

The plug-in isn't finished, and the author has disappeared, leaving it behind in a non-functional state.

mhanski

2007-12-21 20:05

developer   ~0018385

that's too bad. Is anybody working on it, since it hasn't been removed from the 1.3.5cvs? Did he leave any other documentation apart from this?

http://wiki.scribus.net/index.php/Imposition_Plugin_Discussion

pierremarchand

2007-12-21 22:26

reporter   ~0018386

After having tried to write such a plugin, gave up, wrote a quick tool to do the same with PDF. I’m more than convinced that methods described at wiki page about "printing booklet" are largely enough for home printing, but actual imposition beyonds Scribus’ scope, IMO.
I think all attempts to provide such a plugin should be redirected to a dedicated project like EasyPose or whatever will be at edge at this time.

JLuc

2009-05-08 10:49

developer   ~0021698

http://easypose.die-buehne.net/ has disappeared.

ringerc

2009-05-13 03:37

reporter   ~0021717

FWIW, PoDoFo includes basic imposition support in the `podofoimpose' tool, and it'd be easy to add support for reading XML plan files that Scribus could generate.

ale

2009-08-26 19:03

manager   ~0022434

i think that there is an agreement, that scribus should not do any imposition and that the efforts should be in creating a good imposition tool with podofo (podofoimpose).

eventually, scribus will be able to create xml plans which could be read by podofoimpose (personally, i'd prefere to outsource the whole imposition to external tools, even the creation of a plan; scribus may include an existing plan into the pdf created, but should not create it!)

i close this bug, and hope that we will have a solution soon!

Issue History

Date Modified Username Field Change
2003-12-10 20:25 cbradney New Issue
2003-12-10 20:26 cbradney Priority normal => low
2004-01-08 21:17 cbradney Note Added: 0000153
2004-01-08 21:17 cbradney Summary More booklet flyer functionality builtin => Booklet functionality
2004-01-08 21:19 cbradney Relationship added has duplicate 0000124
2004-04-12 14:55 cnuman Note Added: 0001026
2004-04-12 15:00 cbradney Note Added: 0001027
2004-04-12 19:23 deejay1 Note Added: 0001030
2004-04-13 02:40 plinnell Note Added: 0001044
2004-08-26 08:25 deejay1 Note Added: 0002256
2004-09-04 21:53 deejay1 Note Added: 0002286
2004-09-21 06:21 deejay1 Relationship added related to 0001113
2004-09-21 06:41 deejay1 Status new => assigned
2004-09-21 06:41 deejay1 Assigned To => deejay1
2004-09-23 23:01 cbradney Product Version => 1.3
2004-10-04 13:06 deejay1 ETA none => > 1 month
2004-12-22 19:33 Joeboy Note Added: 0003208
2005-04-15 19:58 iho Note Added: 0004257
2005-04-15 20:01 iho Note Edited: 0004257
2005-11-18 11:28 deejay1 Assigned To deejay1 =>
2005-11-18 11:29 deejay1 Note Added: 0007476
2005-11-19 16:46 avox Note Added: 0007486
2005-11-22 08:00 ringerc Note Added: 0007509
2005-11-22 15:39 michael_krauth Note Added: 0007510
2005-12-05 10:39 ringerc Note Added: 0007635
2006-02-07 21:34 plinnell Priority low => high
2006-02-07 21:34 plinnell Status assigned => acknowledged
2006-02-07 21:34 plinnell ETA > 1 month => none
2006-02-07 21:35 plinnell Relationship added has duplicate 0001116
2006-03-07 08:32 ale Status acknowledged => assigned
2006-03-07 08:32 ale Assigned To => ale
2006-03-16 09:56 ale Note Added: 0009331
2006-05-13 21:08 christoph_s Relationship added related to 0003813
2006-05-18 18:31 christoph_s Relationship added related to 0003837
2006-09-25 20:58 pierremarchand File Added: impose.tar.gz
2006-09-28 22:30 cbradney File Deleted: impose.tar.gz
2006-09-28 22:32 pierremarchand File Added: impose.tar.gz
2006-09-28 22:54 pierremarchand Note Added: 0012691
2006-09-28 23:01 plinnell Note Edited: 0012691
2006-09-28 23:15 plinnell File Deleted: impose.tar.gz
2006-09-28 23:17 pierremarchand File Added: impose.tar.gz
2006-09-28 23:27 plinnell File Deleted: impose.tar.gz
2006-09-28 23:28 plinnell File Added: impose.tar.gz
2006-09-29 20:57 pierremarchand File Added: impose-veryalpha-2.tar.gz
2006-09-29 21:04 pierremarchand Note Added: 0012701
2006-09-30 07:54 pierremarchand Note Added: 0012708
2006-10-01 11:54 cbradney File Deleted: impose.tar.gz
2006-10-01 11:54 cbradney File Deleted: impose-veryalpha-2.tar.gz
2007-05-12 21:12 plinnell Relationship added has duplicate 0005666
2007-12-21 18:09 mhanski Note Added: 0018383
2007-12-21 18:11 mhanski Note Edited: 0018383
2007-12-21 19:24 christoph_s Note Added: 0018384
2007-12-21 20:05 mhanski Note Added: 0018385
2007-12-21 22:26 pierremarchand Note Added: 0018386
2009-05-08 10:49 JLuc Note Added: 0021698
2009-05-13 03:37 ringerc Note Added: 0021717
2009-08-26 19:03 ale Note Added: 0022434
2009-08-26 21:19 ale Status assigned => closed
2009-08-26 21:19 ale Resolution open => won't fix
2010-03-02 11:48 jghali Relationship added has duplicate 0008900