View Issue Details

IDProjectCategoryView StatusLast Update
0012439ScribusCanvaspublic2019-11-07 14:54
Reporterale Assigned Toale  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0012439: on canvas basepoint for rotation
Descriptionthere are a few partial requests for this feature. here a try to define something that can be implemented in an easy way...

(updated after getting some suggestions)

- there are 9 hot spots: top left, top center, top right, left center, center, right center, bottom left, bottom center, bottom right

- when using the rotation tool, the basepoint should be defined by using the opposite node to the one under the cursor (if you want to rotate around the top left corner you click on the bottom right corner and rotate; if you want to rotate around the center anywhere in the item area)

- in the PP you can choose one of the nine hot spots and it will be used in the PP itself.

if this proposal is accepted i could think about implementing it...
Tagsbasepoint, rotate
Patch

Relationships

related to 0000553 feedback two clicks on object enable rotating 
related to 0003612 resolvedjghali Changing width or height of rotated items behaves inconsistently depending on basepoint 
related to 0003751 new additional/clearer basepoint options for lines 
related to 0004783 new More basepoints for items 
related to 0009048 new Better control for the origin and basepoint of all frames 
related to 0007287 new Add to ability change basepoint of lines 
related to 0012434 new basepoint: different widgets for shapes and lines 
related to 0015915 assignedale Indigo UI: refactor the Color and Line panels 
related to 0015916 resolvedale Detect arrow keys while the rotation tool is active 

Activities

ale

2014-06-26 15:53

manager   ~0032324

this was the original proposition:

there are a few partial requests for this feature. here a try to define something that can be implemented in an easy way...

- there are 9 hot spots: top left, top center, top right, left center, center, right center, bottom left, bottom center, bottom right

- when using the rotation tool, the basepoint should be defined by using the opposite node to the one under the cursor (if you want to rotate around the top left corner you click on the bottom right corner and rotate)

- the last basepoint used is stored for the use in the PP.

- in the PP you can choose one of the nine hot spots

- the value of the current basepoint is stored for each item; a default value is set in the preferences and document settings.

- eventually, we could find a way to set the hot spot in use when rotating by clicking on the item area (useful in the case you've magnified the item for an exact rotation... but in that case you probably should use the PP anyway... ; but this would allow us to set the basepoint to other values than the hotspots; eventually also outside of the frame area; this would be a further step)

if this proposal is accepted i could think about implementing it...

ale

2019-11-07 14:54

manager   ~0047015

i close this, since the the only missing part is the nine point basepoint widget.

as soon as / if my patch for the new xyz panel is accepted it will be trivial to enable a 9 basepoint widget.

we just need to understand if it's really useful to have 9 point instead of 5. and this ticket does not help finding it out.

Issue History

Date Modified Username Field Change
2014-06-26 12:42 ale New Issue
2014-06-26 12:44 ale Relationship added related to 0000553
2014-06-26 12:46 ale Relationship added related to 0003612
2014-06-26 12:47 ale Relationship added related to 0003751
2014-06-26 12:48 ale Relationship added related to 0004783
2014-06-26 12:49 ale Relationship added related to 0009048
2014-06-26 12:50 ale Relationship added related to 0007287
2014-06-26 12:50 ale Relationship added related to 0012434
2014-06-26 15:53 ale Note Added: 0032324
2014-06-26 15:55 ale Description Updated View Revisions
2016-04-06 22:24 Kunda Tag Attached: rotate
2016-04-08 17:45 Kunda Tag Attached: basepoint
2019-11-05 13:58 ale Relationship added related to 0015915
2019-11-07 13:36 ale Relationship added related to 0015916
2019-11-07 14:54 ale Assigned To => ale
2019-11-07 14:54 ale Status new => closed
2019-11-07 14:54 ale Resolution open => no change required
2019-11-07 14:54 ale Note Added: 0047015