View Issue Details

IDProjectCategoryView StatusLast Update
0001079ScribusNLSpublic2017-05-28 22:35
Reportermunzirtaha Assigned ToFahad  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Platformx86OSMandrakelinuxOS Version10.1 beta
Product Version1.2 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0001079: Arabic is not supported in Scribus yet.
DescriptionWhen I type Arabic in Scribus it appeared broken (characters are not connected together) and also in reverse order. This happen in the text frame. In the story editor it's OK.
Steps To ReproduceJust type paste or type arabic in a text frame.
Additional InformationA screenshot is attached
Tags#please_test, fixed, HOST-Oman, RTL, scribusctl
Patch

Relationships

related to 0001364 closedFahad Hebrew script direction is different in the document and in the story editor 
has duplicate 0001341 closed bidi support ? ( Hebrew and Arabic ) 
has duplicate 0005535 closedjghali Arabic script not rendered properly. 
has duplicate 0005536 closedjghali Arabic script not rendered properly. 
has duplicate 0005718 closedcbradney arabic languge support 
has duplicate 0007055 closedcbradney Arabic letters is separated in Text editor 
has duplicate 0012267 closedjghali Allow RTL to apply to paragraphs and single words 
has duplicate 0012865 closedjghali don't support from RTL languages 
has duplicate 0014825 closedjghali Support Arabic text 
related to 0001288 closed Problem with the arabic font 
related to 0002834 closedFahad Urdu is displayed Left to Right with Nafees Nastaleeq font 
related to 0003680 closedFahad Devanagari (Unicode U+09xx) glyph formation (vowels and conjunct consonants) not proper 
child of 0003965 acknowledged Metabug: Support for non-latin languages 
child of 0007082 closed EPS Import with embedded fonts fails 

Activities

2004-09-14 22:02

 

fschmid

2004-09-14 22:48

administrator   ~0002379

You can enable the correct right-to-left writing order for the Textframes with the
Button "R" on the Properties Palette. The issue with the connecting and shaping of the letters is still open though.

munzirtaha

2004-09-15 15:01

reporter   ~0002380

Thanks for the tip, fschmid. Please, let me know if you need any help regarding the topic. This page http://freedesktop.org/Standards/bidi-spec may prove useful to you.

ringerc

2005-07-12 03:55

reporter   ~0005541

Text layout issues are due for a fix with the new layout engine planned in 1.3. Still no ETA.

edtrager

2006-04-10 20:04

reporter   ~0009796

I also just discovered this (which is a big disappointment! ):

(1) The problem is clearly Scribus, not a font issue. I tried Arabic text with several different Arabeyes (http://www.arabeyes.org) fonts, as well as "Nazli". However, I recommend that testers stick with the Open Source fonts from arabeyes.org as they are available to everyone -- try "ae_AlMohanad", for instance. This is a very "normal" text font.

(2) The problem is that Arabic letter-joining behaviour is missing. I don't really understand how this can occur. If you look at my attached image file (ScribusTestInternationalScripts-001.png), you will notice that Thai (the first text block) which is also a Complex Text Layout (CTL) script, is rendered correctly. But Arabic (the last text block) is not.

==> Tested using (1) Scribus 1.3.3 compiled from source on SuSE 9.3 and (2) Scribus 1.3.3 from RPM on SuSE 10.0 <==

- Ed Trager

2006-04-10 20:05

 

alMubarmij

2008-05-26 07:33

reporter   ~0019731

is it really resolved as in this report?

http://bugs.scribus.net/view.php?id=7055

plinnell

2008-05-26 07:38

viewer   ~0019732

>is it really resolved as in this report?

>http://bugs.scribus.net/view.php?id=7055 [^]

No, that means that bug is a duplicate of this one.

alMubarmij

2008-05-26 23:32

reporter   ~0019738

Can you tell me how long it is take ?
because the thread was started at: 2004-09-15.

hasenj

2009-12-13 00:07

reporter   ~0022954

Why is the severity marked as a feature? I think this is a major bug.

ale

2009-12-15 06:58

manager   ~0022963

@hasenj: it's marked as a feauture, because scribus currently does not support RTL languages nor complex script languages.

it just happens, that:
- some part of that languages' needs are supported for other reasons.
- the story editor is a pure QT application, built with standard elements. even if it automaticallly allows RTL scripts, its technology can't be used for the main scribus' workspace.

afaik, the team aknowledges that this is an important feature, which should be implemented as soon as possible, but many changes are needed to allow them

fscheuer

2011-10-17 12:20

reporter   ~0027030

Sorry, is this problem already solved?
I have exaxctly the same problem with scribus version 1.4.0 rc5 (Build ID: C-C-T-F-C1.8.10-64bit Ghostscript-Version: 8.70 )

Kernel: Linux 2.6.34.10-0.2-default x86_64
Distribution: openSUSE 11.3 (x86_64)
KDE: 4.4.4 (KDE 4.4.4) "release 3"

ale

2011-10-17 16:40

manager   ~0027034

it won't be supported in 1.4.

probably at some time ni 1.5, on the road to 1.6...

sorry...

sharno

2012-01-06 21:41

reporter   ~0027478

I need this bug to be fixed ASAP
We're in 2012 :)

munzirtaha

2013-01-12 17:44

reporter   ~0029700

We're in 2013 ;)
If I am alive I will try to come every 9 years to remind you of this bug!
Now, seriously, if some one is to pay to fix this bug, how much would it cost approximately? I might be able to help with this.

christoph_s

2013-01-12 22:47

administrator   ~0029701

It's the same reason as with Hebrew support. See my comments to 0001726. In short. Money isn't the problem, expertise with Arabic is. If you know a programmer who has the expertise, please tell him that he can help.

shamma

2013-12-24 22:58

reporter   ~0030954

Hi guys, hi Christoph_s
I'm Sam from Tunisia, i have used Scribus and liked it a lot. the only problem was with this bug, so my searches lead me here and I'd like to help fixing the bug.
I have knowledge of arabic language and basic programming, so I'll need some help myself to help resolve this.
Thanks for answering. You can contact me on my e-mail address.

JLuc

2013-12-25 09:27

developer   ~0030955

Last edited: 2013-12-25 09:37

View 9 revisions

Shamma, Working on this will be a big challenge.

Explain your project and your skills on the mailing list. Hang on irc. Dont expect for too much feedback but expect to do a lot by yourself. Expect to work on your own because not many programmers are available as for now for scribus... or build a project, raise interest, organise a team...

Somebody has worked on a 'indic language' version of scribus. You might be interested in trying this version https://launchpad.net/~ale-comp-06/+archive/scribus-git-indic and see if what works well and what does not (and do a public report afterward so everybody knows !) explore the patches that are in this version, learn from it. Explore the archives of the mailing lists and talk to the developper of this indic version (not 'ale', but 'anil'). The source is in the contributor's git repo see http://wiki.scribus.net/wiki/index.php?title=Git

And most important : gain the trust of the official scribus core team, so as to get your patches merged. So as to do so, create fixes for other simpler bugs, propose perfectly tested patches that perfectly work and have them merged. It will be perfect for you to learn scribus too + Keep in contact. Keep devs regularly informed.

Kunda

2015-05-19 17:01

manager   ~0035162

New effort to support Complex Text Layout started (http://lists.scribus.net/pipermail/scribus-dev/2015-May/002519.html) Please spread the word.

Kunda

2016-03-23 12:44

manager   ~0039352

According to HOST-Oman team, these issues are fixed in the new CTL branch!
See https://github.com/HOST-Oman/scribus/issues/75#issue-142809558 [^]
There will be a build provided soon to test this fix OR one can build their branch manually.

Kunda

2016-12-03 22:08

manager   ~0042614

Host-Oman CTL branch was merged in 1.5.3svn r21563

Issue History

Date Modified Username Field Change
2004-09-14 22:02 munzirtaha New Issue
2004-09-14 22:02 munzirtaha File Added: scribus_arabic_shaping1.png
2004-09-14 22:17 plinnell Severity major => feature
2004-09-14 22:48 fschmid Note Added: 0002379
2004-09-15 15:01 munzirtaha Note Added: 0002380
2004-11-10 18:52 plinnell Relationship added related to 0001288
2004-11-24 21:16 cbradney Relationship added has duplicate 0001341
2005-07-12 03:54 ringerc Status new => confirmed
2005-07-12 03:54 ringerc Relationship added related to 0001364
2005-07-12 03:55 ringerc Note Added: 0005541
2005-12-07 20:10 plinnell Relationship added related to 0002834
2005-12-15 17:57 plinnell Relationship added has duplicate 0002920
2006-04-10 20:04 edtrager Note Added: 0009796
2006-04-10 20:05 edtrager File Added: ScribusTestInternationalScripts-001.png
2006-04-20 16:59 mhanski Relationship added related to 0003680
2006-07-02 21:59 mhanski Relationship added child of 0003965
2007-01-04 08:45 cbradney Category Story Editor / Text Frames => NLS
2007-04-06 08:50 jghali Relationship added has duplicate 0005535
2007-04-06 08:50 jghali Relationship added has duplicate 0005536
2007-05-20 20:35 cbradney Relationship added has duplicate 0005718
2008-02-08 17:21 avox Relationship deleted has duplicate 0002920
2008-05-26 05:53 cbradney Relationship added has duplicate 0007055
2008-05-26 07:33 alMubarmij Note Added: 0019731
2008-05-26 07:38 plinnell Note Added: 0019732
2008-05-26 23:32 alMubarmij Note Added: 0019738
2008-06-09 19:50 plinnell Relationship added child of 0007082
2009-12-13 00:07 hasenj Note Added: 0022954
2009-12-15 06:58 ale Note Added: 0022963
2011-10-17 12:20 fscheuer Note Added: 0027030
2011-10-17 16:40 ale Note Added: 0027034
2012-01-06 21:41 sharno Note Added: 0027478
2013-01-12 17:44 munzirtaha Note Added: 0029700
2013-01-12 22:47 christoph_s Note Added: 0029701
2013-12-24 22:58 shamma Note Added: 0030954
2013-12-25 09:27 JLuc Note Added: 0030955
2013-12-25 09:28 JLuc Note Edited: 0030955 View Revisions
2013-12-25 09:30 JLuc Note Edited: 0030955 View Revisions
2013-12-25 09:30 JLuc Note Edited: 0030955 View Revisions
2013-12-25 09:33 JLuc Note Edited: 0030955 View Revisions
2013-12-25 09:34 JLuc Note Edited: 0030955 View Revisions
2013-12-25 09:36 JLuc Note Edited: 0030955 View Revisions
2013-12-25 09:36 JLuc Note Edited: 0030955 View Revisions
2013-12-25 09:37 JLuc Note Edited: 0030955 View Revisions
2014-04-23 14:52 jghali Relationship added has duplicate 0012267
2014-12-31 00:47 jghali Relationship added has duplicate 0012865
2015-05-19 17:01 Kunda Note Added: 0035162
2016-03-23 12:44 Kunda Note Added: 0039352
2016-03-23 12:44 Kunda Tag Attached: #please_test
2016-03-23 12:44 Kunda Tag Attached: fixed
2016-03-23 12:44 Kunda Tag Attached: HOST-Oman
2016-03-23 12:44 Kunda Tag Attached: RTL
2016-11-17 11:56 Kunda Tag Attached: scribusctl
2016-12-03 22:00 jghali Assigned To => Fahad
2016-12-03 22:00 jghali Status confirmed => resolved
2016-12-03 22:00 jghali Resolution open => fixed
2016-12-03 22:00 jghali Fixed in Version => 1.5.3.svn
2016-12-03 22:08 Kunda Note Added: 0042614
2016-12-05 20:21 cbradney Status resolved => closed
2016-12-08 21:39 cbradney Target Version => 1.5.3
2017-05-28 22:35 jghali Relationship added has duplicate 0014825