View Issue Details

IDProjectCategoryView StatusLast Update
0014999ScribusStory Editor / Text Framespublic2017-12-20 20:58
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0014999: "Scribus crashes due to Signal 0000011" if I try to insert a linebreak
DescriptionScribus 22163-1 built from SVN some hours ago on up-to-date Archlinux.

Scribus crashes if I try to add a linebreak to this file: [crashes if i try to add a line.sla.zip](https://github.com/scribusproject/scribus/files/1324537/crashes.if.i.try.to.add.a.line.sla.zip)

Doubleclick into the text-frame, so that the cursor is at the end of the "Ta" line, then hit Enter. "Scribus crashes due to Signal 0000011".



A backtrace:

$ gdb --args scribus file.sla
GNU gdb (GDB) 8.0.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from scribus...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/scribus file.sla
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffe31af700 (LWP 7992)]
[New Thread 0x7fffd8b78700 (LWP 7993)]
[New Thread 0x7fffd3fff700 (LWP 7994)]
[New Thread 0x7fffd37fe700 (LWP 7995)]
[New Thread 0x7fffd2dbb700 (LWP 7996)]
FFmpegImageStream::open : av_open_input_file() failed : AVERROR_NOENT
ReaderWriterTF::writeObject
Warning: dynamic library '/usr/lib/osgPlugins-3.4.1/osgdb_xine.so' exists, but an error occurred while trying to open it:
/usr/lib/osgPlugins-3.4.1/osgdb_xine.so: undefined symbol: xine_xmalloc_aligned
sizeof(TrkHeader)=1000
setBestEncoding for MyriadPro-Bold with 848 glyphs, hasNames= 512 , POST size= 32
Checking cmap 0 ( 0 , 3 , 0 ) format 4
found Unicode enc for Myriad Pro Bold as map 0 with 835 glyphs
Checking cmap 1 ( 1 , 0 , 0 ) format 6
Checking cmap 2 ( 3 , 1 , 0 ) format 4
found Unicode enc for Myriad Pro Bold as map 2 with 1670 glyphs
Checking cmap 3 ( 7 , 0 , 0 ) format -1
using Unicode enc for Myriad Pro Bold
setBestEncoding for MyriadPro-Regular with 848 glyphs, hasNames= 512 , POST size= 32
Checking cmap 0 ( 0 , 3 , 0 ) format 4
found Unicode enc for Myriad Pro Regular as map 0 with 835 glyphs
Checking cmap 1 ( 1 , 0 , 0 ) format 6
Checking cmap 2 ( 3 , 1 , 0 ) format 4
found Unicode enc for Myriad Pro Regular as map 2 with 1670 glyphs
Checking cmap 3 ( 7 , 0 , 0 ) format -1
using Unicode enc for Myriad Pro Regular
setBestEncoding for ArialMT with 1320 glyphs, hasNames= 512 , POST size= 12804
Checking cmap 0 ( 0 , 3 , 0 ) format 4
found Unicode enc for Arial Regular as map 0 with 1186 glyphs
Checking cmap 1 ( 1 , 0 , 0 ) format 0
Checking cmap 2 ( 3 , 1 , 0 ) format 4
found Unicode enc for Arial Regular as map 2 with 2372 glyphs
using Unicode enc for Arial Regular
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted

Thread 1 "scribus" received signal SIGSEGV, Segmentation fault.
0x00007fffef98057e in QTextCodec::fromUnicode(QString const&) const () from /usr/lib/libQt5Core.so.5
(gdb) bt
#0 0x00007fffef98057e in QTextCodec::fromUnicode(QString const&) const () at /usr/lib/libQt5Core.so.5
0000001 0x0000555555a45a8b in Hyphenator::slotHyphenateWord(PageItem*, QString const&, int) ()
0000002 0x0000555555b32214 in PageItem_TextFrame::handleModeEditKey(QKeyEvent*, bool&) ()
0000003 0x000055555598e040 in CanvasMode_Edit::keyPressEvent(QKeyEvent*) ()
0000004 0x0000555555e0b53f in ScribusView::eventFilter(QObject*, QEvent*) ()
0000005 0x00007fffef91f89c in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
0000006 0x00007ffff0646e28 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
0000007 0x00007ffff064feb3 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
0000008 0x00007fffef91fbd0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
0000009 0x00007ffff06a667c in () at /usr/lib/libQt5Widgets.so.5
0000010 0x00007ffff0646e4c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
0000011 0x00007ffff064e926 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
0000012 0x00007fffef91fbd0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
0000013 0x00007fffefe7ecb2 in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () at /usr/lib/libQt5Gui.so.5
0000014 0x00007fffefe83d26 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /usr/lib/libQt5Gui.so.5
0000015 0x00007fffefe5b4ac in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Gui.so.5
0000016 0x00007fffe5389cc1 in () at /usr/lib/libQt5XcbQpa.so.5
0000017 0x00007fffeae6ba57 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
0000018 0x00007fffeae6bc88 in () at /usr/lib/libglib-2.0.so.0
0000019 0x00007fffeae6bd1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
0000020 0x00007fffef97a061 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
0000021 0x00007fffef91dffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
0000022 0x00007fffef927048 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
0000023 0x00005555562692d5 in mainApp(int, char**) ()
0000024 0x00007fffeea0ff6a in __libc_start_main () at /usr/lib/libc.so.6
0000025 0x000055555587be7a in _start ()
TagsNo tags attached.
PatchNo

Activities

ale

2017-09-22 12:46

manager  

crashes.if.i.try.to.add.a.line.sla.zip (4,146 bytes)

ale

2017-09-22 12:50

manager   ~0044441

reported as https://github.com/scribusproject/scribus/issues/92

jghali

2017-09-22 17:36

administrator   ~0044442

Unable to reproduce that one on Windows.

jghali

2017-09-22 17:37

administrator   ~0044443

Moreover it looks like the crash occurs in a Qt function, not in Scribus.

jghali

2017-09-22 17:41

administrator   ~0044444

It also looks like the backtrace was generated with a non debug enabled Scribus. Scribus must be configured with -DWANT_DEBUG=1 to produce a correct backtrace.

jghali

2017-09-22 19:43

administrator   ~0044445

It seems gcc on ArchLinux has code generation bugs:
- https://www.reddit.com/r/archlinux/comments/6e0g7c/gcc_711_is_in_core : "Chances are latest GCC has a nasty code generation bug. Debug builds of my software always use address sanitizer and it crashes somewhere in usual sqlite call. Didnt happen with previous version of GCC, does not happen with clang either."
- https://bugs.launchpad.net/sbcl/+bug/1697528 : mention that gcc issue causes memory corruption

As we have already met recently such issue caused by gcc on ArchLinux, I'd suggest using clang for compiling any program on ArchLinux until gcc bugs are fixed.

PeterBenedek

2017-09-23 17:20

developer   ~0044446

Last edited: 2017-09-23 17:21

View 2 revisions

Tested in: Qt 5.9.1
I can reproduce on Linux Mint 18.2.

jghali

2017-09-23 20:59

administrator   ~0044447

In the end I found the cause of the crash. But the document is broken as it lacks a language in its default character style. So the language of default character style should be reassigned explicitly in style manager for things such as hyphenator to work.

PeterBenedek

2017-09-24 07:10

developer   ~0044450

Tested Linux Mint 18.2; r22165

Works well!

Issue History

Date Modified Username Field Change
2017-09-22 12:46 ale New Issue
2017-09-22 12:46 ale File Added: crashes.if.i.try.to.add.a.line.sla.zip
2017-09-22 12:50 ale Note Added: 0044441
2017-09-22 13:41 jghali Category - => Story Editor / Text Frames
2017-09-22 17:36 jghali Note Added: 0044442
2017-09-22 17:37 jghali Note Added: 0044443
2017-09-22 17:41 jghali Note Added: 0044444
2017-09-22 19:43 jghali Note Added: 0044445
2017-09-23 17:20 PeterBenedek Note Added: 0044446
2017-09-23 17:21 PeterBenedek Note Edited: 0044446 View Revisions
2017-09-23 20:59 jghali Assigned To => jghali
2017-09-23 20:59 jghali Status new => resolved
2017-09-23 20:59 jghali Resolution open => fixed
2017-09-23 20:59 jghali Fixed in Version => 1.5.4.svn
2017-09-23 20:59 jghali Note Added: 0044447
2017-09-24 07:10 PeterBenedek Note Added: 0044450
2017-12-20 20:58 cbradney Status resolved => closed