View Issue Details

IDProjectCategoryView StatusLast Update
0001512ScribusStory Editor / Text Framespublic2005-04-24 06:58
ReporterJeanL Assigned Tocbradney  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
Platformx86OSLinux (Fedora Core 3)OS Versionkernel 2.6
Product Version1.2 
Target VersionFixed in Version 
Summary0001512: Impossibility to use french characters
DescriptionWhen entering "accentuated" characters, the characters available
by a single keypress (eg "é", "à", "è", etc.) are working fine
but "composite" characters (eg "^ e", which should give "ê") are
entered, Scribus crashes.

Before crashing, Scribus outputs the following on the console:

sending IMEnd with 1 chars to 0xa1c2378, text=ê
receiving IMEnd with 1 chars

This line does *not* appear when entering non-composite accentuated
character.

Then, if trying to select the "e circumflex" in the Story Editor,
Scribus crashes with Segfault / Signal 11. All the time.

gdb's bt included in "Additional Information".

Note that all other applications on this machine have no problem
handling those characters.


Steps To Reproduce1. Launch Scribus
2. Create a new document
3. Create a text form
4. Open the Story Editor.
5. Enter a "composite" french character (like the very common
"e circumflex" that appears in many french words)
6. Try to "update" the document : nothing appears on the screen
(although the "e circumflex" appears in the Story Editor).
7. Select, in the Story Editor, the "composite" character.

Instant crash.
Additional Information(gdb) bt
#0 0x01149cf4 in QString::operator= () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000001 0x08104d0c in SEditor::copyStyledText ()
0000002 0x08107a4f in SEditor::copy ()
0000003 0x00fd2f23 in QTextEdit::copyToClipboard ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000004 0x00fe47ab in QTextEdit::contentsMouseReleaseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000005 0x00f8fd69 in QScrollView::viewportMouseReleaseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000006 0x00f920f1 in QScrollView::eventFilter ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000007 0x00fe2dd5 in QTextEdit::eventFilter ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000008 0x00e7f972 in QObject::activate_filters ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000009 0x00e7fa2b in QObject::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000010 0x00eb7d8a in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000011 0x00e23849 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000012 0x00e23a89 in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000013 0x00dc29de in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000014 0x00dc1278 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000015 0x00dd3686 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000016 0x00e38e75 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000017 0x00e22a71 in QApplication::enter_loop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000018 0x08110b47 in StoryEditor::exec ()
0000019 0x04000000 in ?? ()
0000020 0x00e8130b in QObject::connect () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000021 0xfefa6ca0 in ?? ()
0000022 0x09c442d0 in ?? ()
0000023 0x00000000 in ?? ()
(gdb)
TagsNo tags attached.
Patch

Relationships

has duplicate 0001713 closedcbradney Crash when selecting accentuated character 
has duplicate 0001720 closedcbradney Composite characters won't work in text frames 

Activities

JeanL

2005-01-09 22:06

reporter   ~0003423

Same bug with version 1.2.1 using the latests Fedora RPMs.

I also compiled the latest version from CVS (1.2.1) with debug enabled.

Then I reproduced the bug under gdb.

When I enter characters in the Story Editor, nothing suspiscious
shows up in the console.

But when I compose a "multi keys" character, then I can see something like:

sending IMEnd with 1 chars to 0x9c351c8, text=ê
receiving IMEnd with 1 chars
if I select that char (in the Story Editor), there's a segfault / signal 11

Note that if modify X Window System (stock x.org accompanying Fedora Core 3)
by assigning "ecircumflex" directly to a key, there's no crash (but if I
type on the key assigned to keycode "dead_diaeresis" then on "e", then try
to select that char, it segfaults).

I'm pretty sure this is exactly the same bug (the steps to reproduce are
identical) as bug 0001493 (the submitter is also using FC3 btw).

Here's a bt where I open the Story Editor, enter the dead key "^" followed
by an "e" (which results in an "ê" appearing in the Story Editor), then I try
to select (using the mouse) that "ê" and it segfaults.

(gdb) bt
#0 0x07261cf4 in QString::operator= () from /usr/lib/qt-3.3/lib/libqt -mt.so.3
0000001 0x08141423 in SEditor::copyStyledText (this=0x9c351c8) at story.cp p:572
0000002 0x08143bc7 in SEditor::copy (this=0x9c351c8) at story.cpp:1185
0000003 0x070eaf23 in QTextEdit::copyToClipboard ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000004 0x070fc7ab in QTextEdit::contentsMouseReleaseEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000005 0x070a7d69 in QScrollView::viewportMouseReleaseEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000006 0x070aa0f1 in QScrollView::eventFilter ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000007 0x070fadd5 in QTextEdit::eventFilter ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000008 0x06f97972 in QObject::activate_filters ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000009 0x06f97a2b in QObject::event () from /usr/lib/qt-3.3/lib/libqt-mt. so.3
0000010 0x06fcfd8a in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt. so.3
0000011 0x06f3b849 in QApplication::internalNotify ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000012 0x06f3ba89 in QApplication::notify ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000013 0x06eda9de in QETWidget::translateMouseEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000014 0x06ed9278 in QApplication::x11ProcessEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000015 0x06eeb686 in QEventLoop::processEvents ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000016 0x06f50e75 in QEventLoop::enterLoop ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000017 0x06f3aa71 in QApplication::enter_loop ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000018 0x0814bee6 in StoryEditor::exec (this=0x9978ae8) at story.cpp:1692
0000019 0x0837919c in ScribusApp::slotStoryEditor (this=0x96c3ba8)
at scribus.cpp:9268
0000020 0x08360586 in ScribusApp::ModeFromTB (this=0x96c3ba8, m=3)
at scribus.cpp:5189
0000021 0x0833caa2 in ScribusApp::qt_invoke (this=0x96c3ba8, _id=174,
_o=0xfef96190) at scribus.moc:945
0000022 0x06f9a3a0 in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/libqt-mt.

leo

2005-02-21 22:03

reporter   ~0003785

Sorry I just realized that I duplicated this bug.
Only the *selection* of accentuated character makes Scribus crash.

If you do not see your accentuated character, that means your font does not support it. The default font on my system appears to be by default... Kochi Mincho Regula, which is a Japanese font which does not support accentuated characters. Yet you can set in your preferences, in the tool section, the default font. I chose Arial. Every text frame your create will be of the default font and you'll be able to see them.

Just don't select them for now.

cbradney

2005-02-22 07:23

administrator   ~0003786

No crash here at all. Please try 1.2.2cvs.

2005-02-22 22:08

 

Screenshot.png (91,777 bytes)
Screenshot.png (91,777 bytes)

leo

2005-02-22 22:09

reporter   ~0003790

It does not work on 1.2.2cvs either (at least on my pc). See the screenshot attached.

cbradney

2005-02-22 22:17

administrator   ~0003792

Can you please try it with a Bitstream Charter or similarly regular font.

leo

2005-02-23 19:53

reporter   ~0003802

It is the same with Bitstream Charter Regular font.

louisdesjardins

2005-02-24 00:07

developer   ~0003809

I cannot reproduce this on 1.2.2 CVS 14 Feb, 2005.
I have all my French accents.
Tried with many many fonts, including Bitsream Charter.

plinnell

2005-04-08 08:43

viewer   ~0004174

can you try this with 1.2.2cvs ?cannot replicate it here

cbradney

2005-04-22 20:37

administrator   ~0004368

Have tried with current 1.2.2CVS and the same font and no error occurs. There have been a lot of updates recently and I'm quite convinced there is no more issue.

Issue History

Date Modified Username Field Change
2005-01-08 19:47 JeanL New Issue
2005-01-09 22:06 JeanL Note Added: 0003423
2005-02-21 22:03 leo Note Added: 0003785
2005-02-22 07:23 cbradney Note Added: 0003786
2005-02-22 07:24 cbradney Relationship added has duplicate 0001713
2005-02-22 22:08 leo File Added: Screenshot.png
2005-02-22 22:09 leo Note Added: 0003790
2005-02-22 22:17 cbradney Note Added: 0003792
2005-02-23 19:53 leo Note Added: 0003802
2005-02-23 20:26 cbradney Relationship added has duplicate 0001720
2005-02-24 00:07 louisdesjardins Note Added: 0003809
2005-04-08 08:43 plinnell Note Added: 0004174
2005-04-08 08:43 plinnell Status new => feedback
2005-04-08 08:43 plinnell Additional Information Updated
2005-04-22 20:37 cbradney Status feedback => resolved
2005-04-22 20:37 cbradney Resolution open => unable to reproduce
2005-04-22 20:37 cbradney Assigned To => cbradney
2005-04-22 20:37 cbradney Note Added: 0004368
2005-04-24 06:58 cbradney Status resolved => closed
2006-05-13 21:43 christoph_s Relationship added child of 0003813
2006-05-13 21:43 christoph_s Relationship deleted child of 0003813
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames