View Issue Details

IDProjectCategoryView StatusLast Update
0015512ScribusUsabilitypublic2019-06-04 20:55
Reporterpascal.fleury Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015512: Moving control points when editing shape crashes Scribus
DescriptionMoving the control points when editing a shape, and then doing a mouse right-click will crash the program. I tried this in both 1.5.4 and 1.5.4.svn.
Steps To Reproduce1. Load the attached carte.sla file (it contains an SVG and an image frame. The image is not part of it, but is not needed to reproduce the bug)
2. Select the picture frame on the bottom most layer
3. Click 'Shape > Edit' in the object properties.
4. Select 'edit control points' (I could crash it with both independently and symmetrically)
5. Select a control point with left-mouse, move it and while moving it right click.

It will print an issue of a png not found (the cursor I guess from the name), not sure it's related though. Also it tried to get this from the 1.5.1 directory in the resources.
Additional Informationthis is the 1.5.4.svn stack-trace: (In the 1.5.4 it seems to be in the finishTransaction2() method)

Reading symbols from scribus-trunk...(no debugging symbols found)...done.
(gdb) run carte.sla
Starting program: /usr/bin/scribus-trunk carte.sla
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe4050700 (LWP 29210)]
[New Thread 0x7fffd5d8c700 (LWP 29211)]
[New Thread 0x7fffd5499700 (LWP 29212)]
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted
QPixmap::scaled: Pixmap is a null pixmap
pathForIcon: Unable to load icon /usr/share/scribus-trunk/icons/1_5_1/handc.png: File not found

Thread 1 "scribus-trunk" received signal SIGSEGV, Segmentation fault.
0x0000555555da9354 in QVector<FPoint>::operator==(QVector<FPoint> const&) const ()
(gdb) bt
#0 0x0000555555da9354 in QVector<FPoint>::operator==(QVector<FPoint> const&) const ()
0000001 0x0000555555da92c3 in QVector<FPoint>::operator!=(QVector<FPoint> const&) const ()
0000002 0x0000555555da621d in NodeEditContext::finishTransaction1(PageItem*) ()
0000003 0x0000555555cde32a in CanvasMode_NodeEdit::mouseReleaseEvent(QMouseEvent*) ()
0000004 0x0000555556185cbb in ScribusView::eventFilter(QObject*, QEvent*) ()
0000005 0x00007ffff260368c in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000006 0x00007ffff3381805 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000007 0x00007ffff338964f in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000008 0x00007ffff26039a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000009 0x00007ffff3388622 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000010 0x00007ffff33db14b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000011 0x00007ffff33dd7ba in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000012 0x00007ffff338182c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000013 0x00007ffff33890f4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000014 0x00007ffff26039a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000015 0x00007ffff2bc5523 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000016 0x00007ffff2bc6ff5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000017 0x00007ffff2b9e2eb in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000018 0x00007fffe68541c0 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
0000019 0x00007fffef328387 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
0000020 0x00007fffef3285c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
0000021 0x00007fffef32864c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
0000022 0x00007ffff265c8ef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000023 0x00007ffff26019ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000024 0x00007ffff260aa84 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000025 0x0000555556761395 in mainApp(int, char**) ()
0000026 0x00005555567612ef in main ()
(gdb)
TagsNo tags attached.
PatchNo

Activities

pascal.fleury

2018-12-16 15:21

reporter  

carte.sla (204,498 bytes)

pascal.fleury

2018-12-19 22:05

reporter   ~0045729

Installed 1.5.5svn on Ubuntu 18.04.1 and I still get the crashes (I just lost some time in increments of 5 minutes, my rough save frequency).
Everytime I click the right mouse button (I usually do it inadvertently).

pascal.fleury

2018-12-19 22:07

reporter   ~0045730

Also, let me know if you need more info, or if I should run a particular build to get the fix.
My version:
Scribus Version 1.5.5.svn
07 November 2018
Build ID: C--T-F-C1.15.10-64bit
Using Ghostscript version 9.26

jghali

2018-12-19 22:45

administrator   ~0045731

Last edited: 2018-12-20 12:12

View 2 revisions

>> Installed 1.5.5svn

How? By building yourself? From a PPA?
If I look at the builds available at https://code.launchpad.net/~scribus/+archive/ubuntu/ppa , they are too old. You need at least svn revision r22791 to get the fix for your issue.

ale

2018-12-20 12:13

manager   ~0045733

looking at the build date, scribus-trunk seems to be up to date...

jghali

2018-12-20 12:38

administrator   ~0045734

Last edited: 2018-12-20 12:48

View 2 revisions

Last commit has been done yesterday, so the date specified in the scribus-trunk package version shows it is out of date.
The svn revision number in the package version shows also it is out of date. Last commit performed on December 16th (CET) is r22794, not r22789.

Issue History

Date Modified Username Field Change
2018-12-16 15:21 pascal.fleury New Issue
2018-12-16 15:21 pascal.fleury File Added: carte.sla
2018-12-16 19:41 jghali Assigned To => jghali
2018-12-16 19:41 jghali Status new => resolved
2018-12-16 19:41 jghali Resolution open => fixed
2018-12-16 19:41 jghali Fixed in Version => 1.5.5.svn
2018-12-19 22:05 pascal.fleury Status resolved => feedback
2018-12-19 22:05 pascal.fleury Resolution fixed => reopened
2018-12-19 22:05 pascal.fleury Note Added: 0045729
2018-12-19 22:07 pascal.fleury Note Added: 0045730
2018-12-19 22:07 pascal.fleury Status feedback => assigned
2018-12-19 22:45 jghali Note Added: 0045731
2018-12-19 22:47 jghali Status assigned => resolved
2018-12-19 22:47 jghali Resolution reopened => fixed
2018-12-20 12:12 ale Note Edited: 0045731 View Revisions
2018-12-20 12:13 ale Note Added: 0045733
2018-12-20 12:38 jghali Note Added: 0045734
2018-12-20 12:48 jghali Note Edited: 0045734 View Revisions
2019-06-04 20:55 cbradney Status resolved => closed