View Issue Details

IDProjectCategoryView StatusLast Update
0002908ScribusGeneralpublic2005-12-09 23:37
ReporterplinnellAssigned Tocbradney  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.2cvs 
Fixed in Version1.3.2cvs 
Summary0002908: Flipping a group of objects triggers crash
DescriptionSelect a group of objects, then flip from the properties palette. Splat.
Additional InformationProgram received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1073896224 (LWP 28825)]
0x08288b5e in NodePalette::HaveNode (this=0x8a9a318, have=false, mov=false)
    at frameedit.cpp:470
470 if (doc->EditClipMode == 0)
(gdb) bt
#0 0x08288b5e in NodePalette::HaveNode (this=0x8a9a318, have=false, mov=false)
    at frameedit.cpp:470
0000001 0x0828957c in NodePalette::qt_invoke (this=0x8a9a318, _id=81, _o=0xbfa88cf8)
    at frameedit.moc:194
0000002 0x412bdf89 in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000003 0x08493e59 in ScribusView::HavePoint (this=0x8d6b578, t0=false, t1=false)
    at scribusview.moc:1052
0000004 0x084ab4f4 in ScribusView::MarkClip (this=0x8d6b578, currItem=0x8ff72f8,
    cli=@0xbfa890e0, once=true) at scribusview.cpp:5538
0000005 0x084ab9ee in ScribusView::MirrorPolyV (this=0x8d6b578) at scribusview.cpp:5660
0000006 0x082f5b1d in Mpalette::DoFlipV (this=0x8a09470) at mpalette.cpp:2772
0000007 0x083123dc in Mpalette::qt_invoke (this=0x8a09470, _id=113, _o=0xbfa89218)
    at mpalette.moc:754
0000008 0x412bdf89 in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000009 0x412be430 in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000010 0x41607a8c in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
0000011 0x41352846 in QButton::mouseReleaseEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000012 0x412f7c48 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
0000013 0x4125e281 in QApplication::internalNotify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000014 0x4125f3e8 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000015 0x411f9218 in QETWidget::translateMouseEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000016 0x411f803b in QApplication::x11ProcessEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000017 0x4120c12a in QEventLoop::processEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
0000018 0x41275179 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
0000019 0x41275076 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000020 0x4125dbcf in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000021 0x086199ed in mainApp (argc=1, argv=0xbfa89a84) at main_nix.cpp:69
0000022 0x08619a3a in main (argc=1, argv=0xbfa89a84) at main_nix.cpp:44
TagsNo tags attached.
Patch

Relationships

child of 0003812 acknowledged Metabug: Grouped objects 

Activities

cbradney

2005-12-09 09:29

administrator   ~0007679

Cannot reproduce

2005-12-09 09:39

 

cbradney

2005-12-09 09:55

administrator   ~0007681

Ok got it now

plinnell

2005-12-09 23:37

viewer   ~0007685

tested. fixed.

Issue History

Date Modified Username Field Change
2005-12-08 23:49 plinnell New Issue
2005-12-08 23:50 plinnell Status new => assigned
2005-12-08 23:50 plinnell Assigned To => cbradney
2005-12-09 09:29 cbradney Note Added: 0007679
2005-12-09 09:39 plinnell File Added: Scribus_devel-logo_0.sla.gz
2005-12-09 09:55 cbradney Note Added: 0007681
2005-12-09 20:16 cbradney Status assigned => resolved
2005-12-09 20:16 cbradney Fixed in Version => 1.3.2cvs
2005-12-09 20:16 cbradney Resolution open => fixed
2005-12-09 23:37 plinnell Status resolved => closed
2005-12-09 23:37 plinnell Note Added: 0007685
2006-05-13 17:10 christoph_s Relationship added child of 0003812