View Issue Details

IDProjectCategoryView StatusLast Update
0003173ScribusNLSpublic2016-01-23 22:11
ReporterZeimusu Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindowsOS VersionXP
Product Version1.3.4cvs 
Target VersionFixed in Version1.5.1svn 
Summary0003173: Japanese (CJK) text in story editor is not entered into text frame. Frequent crashes.
DescriptionIf Japanese text is entered in the story editor, it is not copied to the text frame.

There are frequent crashes, the crash window explains:
 "Scribus crashes due to following exception: EXCEPTION_ACCESS_VIOLATION"
Steps To ReproduceCreate text frame.
Open story editor.
Turn IME on.
Enter Japanese text.
If it doesn't crash, save and close.
Additional InformationI see this on both a English XP pro OS, and a Japanese XP Home OS
TagsNo tags attached.
PatchNo

Relationships

related to 0003740 closedjghali Story editor losing accented characters 
related to 0003765 closedjghali Program crashes and loses all unsaved data when I try to change font in Story Editor 
related to 0008987 confirmed Word-wrapping CJK fonts malfunction 
has duplicate 0005018 closedcbradney Input Japanese with scim crashes scribus 
has duplicate 0006060 closedjghali Can't handle Chinese Charecters 
has duplicate 0006380 closedjghali Partially disabled Japanese IME causes crash 
has duplicate 0007128 closedcbradney Crash during using Traditional Chinese 
has duplicate 0008899 closedjghali Not good support Chinese 
has duplicate 0009349 closedcbradney Can't write Japanese/Chinese/Korean in Scribus 
related to 0001493 closed Highlight a chinese character in the input box causes signal 0000011 
related to 0012697 closedKunda CJK (Chinese, Japanese, Korean) text not processed. 
related to 0008471 closed Crash during Microsoft IMEs (Chinese, Japanese, Korean) 
related to 0013612 confirmed No input method preedit when one inputs CJ text directly into a text frame 
child of 0003965 acknowledged Metabug: Support for non-latin languages 

Activities

plinnell

2006-02-04 20:42

viewer   ~0008570

can you provide us with some japanese text to test this with. We have not tested with IME as no one on our team knows Japanese.

Zeimusu

2006-02-05 12:20

reporter   ~0008590

Last edited: 2006-02-05 12:26

If you just want something to copy and paste go to Japanese wikipedia. I can't enter it here, as this page is Windows 1252 encoding, which doesn't support Japanese.

But turning on the IME in windows isn't tricky.

For direct input the IME is disabled by Scribus, but cut and paste of Japanese is possible (separate bug?). The Japanese text which has been cut and pasted can be viewed, edited (in Japanese) and saved from the story editor. But new paragraphs are truncated at the first Japanese character.

This probably affects Korean and Chinese users too.

Hope this helps.

Zeimusu

2006-03-31 02:34

reporter   ~0009577

This issue continues to be present in 1.3.3

ringerc

2006-03-31 08:19

reporter   ~0009578

I've seen reports of similar issues, and suspect there's an encoding issue in there somewhere. I've seen reports of this problem but never been able to reproduce it myself. I'm not sure if it happens under Linux.

I'll give it a go when I'm next around in Windows.

Zeimusu

2006-06-03 12:50

reporter   ~0011564

Developers are probably aware of this, but to turn on the IME in Win XP is straight forward see (for example) http://www.msu.edu/~bellbri2/ime.html#_Windows_XP_Installation
The crashes are Seg faults. Gdb hints at an array being out of range somewhere in qt-mt3.dll.
Would a backtrace be useful? Are debug builds made?

jghali

2006-06-03 16:07

administrator   ~0011565

There is a known issue triggering these EXCEPTION_ACCESS_VIOLATION which was caused indeed by out of bounds array access. It appeared when Scribus was run in other languages than en_us and was solved in 1.3.3.2 (released some days ago). Upgrade, it should not solve your issue with IME (text not copied to frame), but will reduce crashes.

Zeimusu

2006-06-05 13:40

reporter   ~0011579

The crashes are not the ones that jghali mentioned. I'm running 1.3.3.2 (May 29 build) and I'm using the English interface. Scribus still crashes.

mgushee

2006-07-10 00:37

reporter   ~0011827

Last edited: 2006-07-10 00:38

To ringerc: yes, the issue does affect Linux. At least, Japanese text does not get copied to the frame. As for the crashes, I'm not sure how severe it is--I haven't yet attempted to create any substantial Japanese documents (what would be the point?), but I did cause a crash by doing the following:

 1) Entered Japanese text in the story editor
 2) Closed-with-save the story editor
 3) Saved the document
 4) Opened the story editor for the same frame again
 5) Entered some Japanese text, during which ...
 ** CRASH (signal 11) **

This is the first time I have tried steps 3 & 4, and the first time Scribus has crashed.

ringerc

2006-07-10 08:47

reporter   ~0011831

Given that this only affects IME-entered text, not unicode text pasted in, I'm wondering if this is being caused by an assumption somewhere that one keystroke == one unichar that's being broken by the IME.

I'll have to look up how to actually use the Japanese IME on win32 and see if I can reproduce the fault. Ideally it'd be traced in a debugger but I don't have a useful debug env working under win32 yet.

mgushee

2006-07-11 02:12

reporter   ~0011845

Here's a little additional info, though it seems mainly to confirm what is already known. I imported a UTF-8 text file with mainly Japanese characters into the story editor, and found that the Japanese text *was* inserted into the text frame.

BTW, I am running Scribus 1.3.3.2 on Linux with glibc 2.4 and Qt 3.3.6.

Anything else I can do to help? I would like to see this bug resolved soon. Unfortunately, I don't know much C++ and am unfamiliar with the Qt API, but I'm reasonably knowledgeable about CJK issues.

mgushee

2006-07-15 20:21

reporter   ~0011887

Here is a bit of good news: I am using SCIM (not SKIM) with Anthy for Japanese input on Linux. I have found that if I set 'XIM Input Style' to 'Over the Spot' in qtconfig, Japanese text is properly transferred from the story editor to the text frame. In fact, this is addressed in the SCIM FAQ:

  http://tinyurl.com/l6oxz

Of course, I cannot say that this will eliminate crashes, but I did save a file with several paragraphs of Japanese text, then reopen it, enter additional text, and Scribus did not crash.

I'm not very familiar with MS-IME, but perhaps it has a similar setting that would have similar results.

Zeimusu

2006-07-20 15:45

reporter   ~0011944

Windows IME doesn't support over the spot, only on the spot, or root window.

tisiphone

2007-02-05 02:46

reporter   ~0015096

Just want to add some more info.

I am using Scribus 1.3.3.7 on WinXP SP2.

Right now, the only way for me to use Chinese or Japanese characters in Scribus is to do the following:

1. Enter the texts in a separate TXT file
2. Import that into Scribus with the "Get Text" function
   
   <but see bug below>

Otherwise if the characters were just typed in directly into the story editor, they would appear in it but won't show up in the text frame after update, just as others had described.

To add another somewhat related bug:
Since it is not possible to use paragraph style to pre-set the font of a new text box. When the Chinese or Japanese TXT file is first imported, the texts would appear as a "red block" instead of the real characters. However, that problem can be gotten around if the correct font was explicitly chosen in the story editor or in the Properties box.

Zeimusu

2007-05-07 14:17

reporter   ~0016116

I've just tried this with 1.3.4cvs (win XP). The results are pleasing. I was able to enter Japanese text into the story editor, and see the result on the page. I couldn't get it to crash.

I can't enter japanese text directly into a frame, the IME is disabled, and mixing Japanese and latin fonts is fiddly. And I haven't been able to align text vertially. These are separate bugs. For now I think this bug can be closed.

Zeimusu

2007-05-07 14:19

reporter   ~0016117

Addendum, just now it did crash when converting kana->kanji in the story editor.

jghali

2008-05-08 14:56

administrator   ~0019640

I'll try to release a 1.3.5 preview sometime soon, the story editor has been partially rewritten in the hope to better support IME. It will be interesting to test story editor in this version

user2155

2008-05-09 21:42

  ~0019651

As for me, japanese input in 1.3.5svn using Anthy on linux doesn't work at all. Neither directly in text frame nor in story editor.

Kunda

2015-08-09 13:04

manager   ~0035979

jghali, does this bug still crash Scribus on Windows?

jghali

2015-08-09 13:27

administrator   ~0035980

Only a CJK user can tell.

ftake

2015-08-10 02:10

reporter   ~0035985

On Linux
Japanese input method (ibus-mozc) works without crash although there are still the following limitations
- No input method preedit when we input CJ text directly into a text frame.
  We can say CJ users must use the story editor to input text.
- No xim support; however since ibus and fcitx-qt5 works, not serious problem

On Windows
Now, I have no mobile windows environment. I will check later (maybe next weekend).

Kunda

2015-11-21 11:22

manager   ~0037567

Ftake, can you followup and check if the crash still occurs on Windows ?

ftake

2015-12-18 14:40

reporter   ~0037940

1.5.0 does not crash on Windows as far as I tested.

Kunda

2015-12-22 11:59

manager   ~0037951

ftake,
Thanks for the update. So this is not a crash bug anymore?

Also are their bugs open for:
Japanese input method (ibus-mozc) works without crash although there are still the following limitations
- No input method preedit when we input CJ text directly into a text frame.
  We can say CJ users must use the story editor to input text.
- No xim support; however since ibus and fcitx-qt5 works, not serious problem

Kunda

2015-12-22 12:02

manager   ~0037953

The bug seems to have been fixed in 1.5.x
But a new bug needs to be opened per @ftake comment: 0003173:0035985

Kunda

2015-12-22 12:11

manager   ~0037955

CJ text not working in a text frame bug reported at 0013612

Kunda

2016-01-23 21:39

manager   ~0038379

Closing since crash has been fixed. The rest of the ticket has been moved to 0013612

Issue History

Date Modified Username Field Change
2006-02-04 03:48 Zeimusu New Issue
2006-02-04 20:42 plinnell Note Added: 0008570
2006-02-05 12:20 Zeimusu Note Added: 0008590
2006-02-05 12:22 Zeimusu Note Edited: 0008590
2006-02-05 12:26 Zeimusu Note Edited: 0008590
2006-02-08 10:03 plinnell Status new => acknowledged
2006-02-08 10:03 plinnell Relationship added related to 0001493
2006-03-31 02:34 Zeimusu Note Added: 0009577
2006-03-31 07:41 jo-hannes Product Version 1.3.2 => 1.3.4cvs
2006-03-31 08:19 ringerc Note Added: 0009578
2006-06-03 12:50 Zeimusu Note Added: 0011564
2006-06-03 16:07 jghali Note Added: 0011565
2006-06-03 17:58 mhanski Relationship added related to 0003740
2006-06-03 17:59 mhanski Relationship added related to 0003765
2006-06-05 13:40 Zeimusu Note Added: 0011579
2006-07-10 00:37 mgushee Note Added: 0011827
2006-07-10 00:38 mgushee Note Edited: 0011827
2006-07-10 08:47 ringerc Note Added: 0011831
2006-07-10 09:25 mhanski Relationship added child of 0003965
2006-07-11 02:12 mgushee Note Added: 0011845
2006-07-15 20:21 mgushee Note Added: 0011887
2006-07-20 15:45 Zeimusu Note Added: 0011944
2006-12-28 10:35 cbradney Relationship added has duplicate 0005018
2007-01-04 09:05 cbradney Category Story Editor / Text Frames => NLS
2007-02-05 02:46 tisiphone Note Added: 0015096
2007-05-07 14:17 Zeimusu Note Added: 0016116
2007-05-07 14:19 Zeimusu Note Added: 0016117
2007-08-03 07:57 jghali Relationship added has duplicate 0006060
2007-10-18 19:10 jghali Relationship added has duplicate 0006380
2008-05-08 14:56 jghali Note Added: 0019640
2008-05-09 21:42 user2155 Note Added: 0019651
2008-07-09 19:07 cbradney Relationship added has duplicate 0007128
2010-03-02 09:25 jghali Relationship added has duplicate 0008899
2010-09-08 19:03 cbradney Relationship added has duplicate 0009349
2014-07-25 05:41 Kunda Target Version => 1.5.0
2014-09-11 02:34 Kunda Severity crash => block
2014-09-17 15:58 Kunda Relationship added related to 0008987
2014-09-17 15:59 Kunda Relationship added related to 0012697
2015-02-25 21:21 cbradney Patch => No
2015-02-25 21:21 cbradney Target Version 1.5.0 =>
2015-06-30 16:54 Kunda Relationship added related to 0008471
2015-08-09 13:04 Kunda Note Added: 0035979
2015-08-09 13:27 jghali Note Added: 0035980
2015-08-10 02:10 ftake Note Added: 0035985
2015-11-21 11:22 Kunda Note Added: 0037567
2015-12-18 14:40 ftake Note Added: 0037940
2015-12-22 11:59 Kunda Note Added: 0037951
2015-12-22 12:02 Kunda Note Added: 0037953
2015-12-22 12:02 Kunda Status acknowledged => resolved
2015-12-22 12:02 Kunda Resolution open => fixed
2015-12-22 12:02 Kunda Assigned To => Kunda
2015-12-22 12:10 Kunda Relationship added related to 0013612
2015-12-22 12:11 Kunda Note Added: 0037955
2016-01-23 21:39 Kunda Note Added: 0038379
2016-01-23 21:39 Kunda Assigned To Kunda =>
2016-01-23 21:39 Kunda Status resolved => closed
2016-01-23 21:39 Kunda Fixed in Version => 1.5.1
2016-01-23 22:11 Kunda Fixed in Version 1.5.1 => 1.5.1svn