View Issue Details

IDProjectCategoryView StatusLast Update
0010701ScribusUsabilitypublic2012-11-13 20:31
Reporterpygmee Assigned ToChelen  
PriorityhighSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0010701: Multiple image import
DescriptionSince it can be very long to import several picture in a document (see catalogs for examples), it maight be nice to be able to import several images at once. using a key might help browsing into the to-be imported picture before clicking onthe frame it might be linked to. Then going on for each image. Time saved might be quite important this way
Steps To Reproduce1. Open Import window
2. Select multiple files and validate
3. use arrow (or other) to choose the right image between selected
4. click on the page (created frame automatically) / click into frame links to that frame

repeat 3+4 for each image

As an extra, using a modifier could place all the image on the page : the user would just have to move them at the right place
TagsNo tags attached.
Patch

Activities

Chelen

2012-07-18 16:35

developer   ~0028505

I did it in my branch and test loks good. If you want, it can be commited

gpittman

2012-07-31 02:01

developer   ~0028695

I'd like to be able to make documentation for this...

Chelen

2012-07-31 11:00

developer   ~0028701

It is now in the trunk. If you want specific information, I am on IRC :-)

pygmee

2012-08-08 10:02

developer   ~0028784

i built from trunk and unfortunately, it crashes here :
(gdb) bt
#0 0x00000000 in ?? ()
0000001 0xb5d67cf0 in QPainter::end (this=0xbfffdfec)
    at painting/qpainter.cpp:1963
0000002 0xb5d67e98 in QPainter::~QPainter (
    this=0xbfffdfec, __in_chrg=<optimized out>)
    at painting/qpainter.cpp:1519
0000003 0x083a4c61 in ?? ()
0000004 0x083a4714 in ?? ()
0000005 0x0871dc91 in ?? ()
0000006 0x087d475d in ?? ()
0000007 0x083e0e46 in ?? ()
0000008 0x087ecb14 in ?? ()
0000009 0xb57ccb16 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9009408, receiver=
    0xa553b48, event=0xbfffe6f4)
    at kernel/qcoreapplication.cpp:986
0000010 0xb5bf4ea2 in notify_helper (e=0xbfffe6f4,
    receiver=0xa553b48, this=0x9009408)
    at kernel/qapplication.cpp:4555
0000011 QApplicationPrivate::notify_helper (
    this=0x9009408, receiver=0xa553b48, e=0xbfffe6f4)
    at kernel/qapplication.cpp:4531
0000012 0xb5bfb024 in QApplication::notify (
    this=0x9009408, receiver=0xa553b48, e=0xbfffe6f4)
    at kernel/qapplication.cpp:4102
0000013 0xb57cc97e in QCoreApplication::notifyInternal (
    this=0xbfffef04, receiver=0xa553b48,
    event=0xbfffe6f4)
    at kernel/qcoreapplication.cpp:876
0000014 0xb5bf5e95 in sendEvent (event=<optimized out>,
    receiver=<optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
0000015 QApplicationPrivate::sendMouseEvent (receiver=
    0xa553b48, event=0xbfffe6f4,
    alienWidget=0xa553b48, nativeWidget=0x9ab6788,
    buttonDown=0xb6589cf4, lastMouseReceiver=...,
    spontaneous=true) at kernel/qapplication.cpp:3170
0000016 0xb5c82074 in QETWidget::translateMouseEvent (
    this=0x9ab6788, event=0xbfffebac)
    at kernel/qapplication_x11.cpp:4617
0000017 0xb5c80c0d in QApplication::x11ProcessEvent (
    this=0xbfffef04, event=0xbfffebac)
    at kernel/qapplication_x11.cpp:3732
0000018 0xb5cadeac in x11EventSourceDispatch (
    s=0x900c4a8, callback=0, user_data=0x0)
    at kernel/qguieventdispatcher_glib.cpp:146
0000019 0xb4a3ed86 in g_main_context_dispatch ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
0000020 0xb4a3f125 in ?? ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
0000021 0xb4a3f201 in g_main_context_iteration ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
0000022 0xb57ff887 in QEventDispatcherGlib::processEvents
    (this=0x9009ed0, flags=...)
    at kernel/qeventdispatcher_glib.cpp:424
0000023 0xb5cadaaa in QGuiEventDispatcherGlib::processEvents (this=0x9009ed0, flags=...)
    at kernel/qguieventdispatcher_glib.cpp:204
0000024 0xb57cb50d in QEventLoop::processEvents (this=
    0xbfffeea4, flags=...)
    at kernel/qeventloop.cpp:149
0000025 0xb57cb7a9 in QEventLoop::exec (this=0xbfffeea4,
    flags=...) at kernel/qeventloop.cpp:204
0000026 0xb57d0eba in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:1148
0000027 0xb5bf2a74 in QApplication::exec ()
    at kernel/qapplication.cpp:3820
0000028 0x08bcbac6 in ?? ()
0000029 0x08bcba4f in ?? ()
0000030 0xb4ff24d3 in __libc_start_main ()
   from /lib/i386-linux-gnu/libc.so.6
0000031 0x082d48f1 in ?? ()

gpittman

2012-08-08 12:54

developer   ~0028785

It's odd, since a few days ago it was working...mine crashes now too.

Chelen

2012-08-10 17:47

developer   ~0028801

mine too when I use the trunk repo. I did some test with different version and the issue doesn't appear on my repo but it appears after that MrB applied the diff files I sent to him. MrB, did you change somethink in the diff files I sent to you (commit 7f277afd37c75570810ccf5f9f02b10073ed7874)? Otherwise it may be an issue with merge ...

Chelen

2012-08-10 18:58

developer   ~0028802

looking at the bt, here is the diff file to fix the bug :

diff --git a/Scribus/scribus/canvasmode_imageimport.cpp b/Scribus/scribus/canvas
index 0500cdd..6ebc1ad 100644
--- a/Scribus/scribus/canvasmode_imageimport.cpp
+++ b/Scribus/scribus/canvasmode_imageimport.cpp
@@ -83,11 +83,9 @@ void CanvasMode_ImageImport::newToolTip(QString name)
                tipText = "<p align=\"center\"><img src=\"data:image/png;base64,
        }
        else
- {
- p.end();
                tipText = "<p align=\"center\">" + name.right(name.lastIndexOf("
- }
        QToolTip::showText(QPoint(Mx,My), tipText, qApp->activeWindow());
+ p.end();
 }
 
 void CanvasMode_ImageImport::drawControls(QPainter* p)

jghali

2012-08-11 10:44

administrator   ~0028804

Fix committed to trunk (r17756)

pygmee

2012-08-20 20:53

developer   ~0028847

perfect, thanks chelen

Issue History

Date Modified Username Field Change
2012-05-03 12:57 pygmee New Issue
2012-07-10 22:13 ale Assigned To => Chelen
2012-07-10 22:13 ale Status new => assigned
2012-07-18 16:35 Chelen Note Added: 0028505
2012-07-26 08:04 Chelen Status assigned => resolved
2012-07-26 08:04 Chelen Fixed in Version => 1.5.0svn
2012-07-26 08:04 Chelen Resolution open => fixed
2012-07-31 02:01 gpittman Note Added: 0028695
2012-07-31 11:00 Chelen Note Added: 0028701
2012-08-08 10:02 pygmee Note Added: 0028784
2012-08-08 12:54 gpittman Note Added: 0028785
2012-08-10 17:47 Chelen Note Added: 0028801
2012-08-10 18:58 Chelen Note Added: 0028802
2012-08-11 10:44 jghali Note Added: 0028804
2012-08-20 20:53 pygmee Note Added: 0028847
2012-11-13 20:31 cbradney Status resolved => closed