View Issue Details

IDProjectCategoryView StatusLast Update
0015788ScribusUsabilitypublic2019-08-29 04:01
ReporterPeterBenedek Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx64OSLinux MintOS Version19 (64bit)
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015788: A style may still be used after being deleted
DescriptionRelated: 0014099

Original ticket text:
- Make new document
- Open Style Manager (Edit -- Styles)
- Make new Paragraph Style (01) -> Enter (or right click of style -> New xxx style)
- Make new Paragraph Style (New Style)
- Right click "New Style"
- Delete
- Click OK
- Click the Style Manager window EDIT>> Button

The deleted style (New Style) appears in the editor and modifiable.

-----
And now...

Delete the last character of the style name.
Re-enter it.
Additional Information(gdb) bt
#0 0x0000555555f20929 in QTreeWidgetItem::text(int) const ()
0000001 0x00005555566df852 in StyleManager::slotNameChanged(QString const&) ()
0000002 0x0000555555be8df6 in ?? ()
0000003 0x00007ffff2aba5b5 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000004 0x00007ffff394acd2 in QLineEdit::textChanged(QString const&) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000005 0x00007ffff3951109 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000006 0x00007ffff2aba5b5 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000007 0x00007ffff3951c65 in QWidgetLineControl::textChanged(QString const&) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000008 0x00007ffff3954fa1 in QWidgetLineControl::finishChange(int, bool, bool) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000009 0x00007ffff39581b8 in QWidgetLineControl::processKeyEvent(QKeyEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000010 0x00007ffff394ae2a in QLineEdit::keyPressEvent(QKeyEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000011 0x00007ffff3848867 in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000012 0x00007ffff3950992 in QLineEdit::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
---Type <return> to continue, or q <return> to quit---
0000013 0x00007ffff380982c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000014 0x00007ffff3812632 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000015 0x00007ffff2a8b9a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000016 0x00007ffff38657a5 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000017 0x00007ffff380982c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000018 0x00007ffff38110f4 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000019 0x00007ffff2a8b9a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000020 0x00007ffff304a090 in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000021 0x00007ffff304efd5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000022 0x00007ffff30262eb in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000023 0x00007fffe50ca1c0 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
0000024 0x00007fffef7af417 in g_main_context_dispatch ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
0000025 0x00007fffef7af650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
0000026 0x00007fffef7af6dc in g_main_context_iteration ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
0000027 0x00007ffff2ae48ef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000028 0x00007ffff2a899ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000029 0x00007ffff2a92a84 in QCoreApplication::exec() ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000030 0x00005555567622c7 in mainApp(int, char**) ()
0000031 0x0000555556762221 in main ()
TagsNo tags attached.
PatchNo

Activities

PeterBenedek

2019-08-26 18:13

developer  

Crash_01.gif (522,297 bytes)
Crash_01.gif (522,297 bytes)
Crash_02.gif (303,511 bytes)
Crash_02.gif (303,511 bytes)

ale

2019-08-27 07:07

manager   ~0046548

yes, clicking on the "edit" button (without picking a new style first) leads to a crash...

PeterBenedek

2019-08-29 04:01

developer   ~0046566

Tested in r23167; Linux Mint 19; Qt 5.12.0

I can't reproduce anymore. Works well.

Issue History

Date Modified Username Field Change
2019-08-26 18:13 PeterBenedek New Issue
2019-08-26 18:13 PeterBenedek File Added: Crash_01.gif
2019-08-26 18:13 PeterBenedek File Added: Crash_02.gif
2019-08-27 07:07 ale Note Added: 0046548
2019-08-28 12:25 jghali Summary Scribus crash if you deleted the style, but after delete you use it again this style. => A style may style be used after being deleted
2019-08-28 12:30 jghali Summary A style may style be used after being deleted => A style may still be used after being deleted
2019-08-28 12:30 jghali Assigned To => jghali
2019-08-28 12:30 jghali Status new => resolved
2019-08-28 12:30 jghali Resolution open => fixed
2019-08-28 12:30 jghali Fixed in Version => 1.5.6.svn
2019-08-29 04:01 PeterBenedek Note Added: 0046566
2019-08-29 04:01 PeterBenedek Status resolved => closed