View Issue Details

IDProjectCategoryView StatusLast Update
0005431ScribusStory Editor / Text Framespublic2007-05-14 21:45
Reporterhhielscher Assigned Toavox  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformi586OSMandriva LinuxOS VersionCooker
Product Version1.3.4cvs 
Target VersionFixed in Version1.3.4cvs 
Summary0005431: crash at editing text frame
DescriptionSteps to reproduce:
1. open attached document
2. double click and place cursor at the end of the first or second line
3. hit Enter (Return)
4. hit Del
Additional Information[Thread debugging using libthread_db enabled]
[New Thread -1209174320 (LWP 4767)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209174320 (LWP 4767)]
0x0897f43f in Style::parentStyle ()
(gdb) bt
#0 0x0897f43f in Style::parentStyle ()
0000001 0x08980213 in CharStyle::update ()
0000002 0x0897f555 in Style::validate ()
0000003 0x084564ef in PageItem_TextFrame::DrawObj_Item ()
0000004 0x08408a40 in PageItem::DrawObj ()
0000005 0x08728791 in ScribusView::DrawPageItems ()
0000006 0x0872bc2e in ScribusView::drawContents ()
0000007 0x4f0cb1c3 in QScrollView::drawContentsOffset () from /usr/lib/qt3/lib/libqt-mt.so.3
0000008 0x4f0ccfa3 in QScrollView::viewportPaintEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000009 0x4f0cde4f in QScrollView::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
0000010 0x4efbbc3c in QObject::activate_filters () from /usr/lib/qt3/lib/libqt-mt.so.3
0000011 0x4efbbcab in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
0000012 0x4eff3d7c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
0000013 0x4ef5edd7 in QApplication::internalNotify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000014 0x4ef5fc29 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000015 0x4ef31fd4 in QWidget::repaint () from /usr/lib/qt3/lib/libqt-mt.so.3
0000016 0x4ef6070c in QApplication::sendPostedEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
0000017 0x4ef60806 in QApplication::sendPostedEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
0000018 0x4ef0fbc2 in QEventLoop::processEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
0000019 0x4ef747b2 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
0000020 0x4ef74676 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000021 0x4ef5e78f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000022 0x08395b75 in mainApp ()
0000023 0x08395bd2 in main ()
TagsNo tags attached.
Patch

Relationships

child of 0003964 closedplinnell 1.3.4 Release Metabug 
child of 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

2007-03-07 17:40

 

crash_at_del.sla (54,890 bytes)

christoph_s

2007-03-07 19:23

administrator   ~0015497

Confirmed under SUSE 10.2.

jghali

2007-05-12 15:56

administrator   ~0016152

Andreas, here are some things which may help you solving that issue :
- pressing the delete key imply executing StoryText::removeParSep()
- in this case removeParSep() delete the ScText paragraph style and hence the paragraph style StyleContextProxy member
- that StyleContextProxy seems to be used elsewhere
- the crash will be triggered in layout() for a == 44, when trying to access a garbled StyleContext

Issue History

Date Modified Username Field Change
2007-03-07 17:40 hhielscher New Issue
2007-03-07 17:40 hhielscher File Added: crash_at_del.sla
2007-03-07 19:23 christoph_s Note Added: 0015497
2007-03-07 19:23 christoph_s Status new => confirmed
2007-03-07 19:23 christoph_s Status confirmed => assigned
2007-03-07 19:23 christoph_s Assigned To => avox
2007-05-11 14:35 jghali Severity minor => crash
2007-05-12 15:56 jghali Note Added: 0016152
2007-05-12 22:10 cbradney Relationship added child of 0003964
2007-05-13 17:13 avox Status assigned => resolved
2007-05-13 17:13 avox Fixed in Version => 1.3.4cvs
2007-05-13 17:13 avox Resolution open => fixed
2007-05-14 21:45 cbradney Status resolved => closed
2007-05-23 21:03 christoph_s Relationship added child of 0003157
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames