View Issue Details

IDProjectCategoryView StatusLast Update
0014909ScribusGraphics / Image Framespublic2018-04-07 00:12
Reporterphilchan2008 Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows 10 HomeOS VersionWin10-1703
Product Version1.5.4.svn 
Target Version1.5.4Fixed in Version1.5.4.svn 
Summary0014909: Crash when moving an image frame closed to the edge of a text frame
DescriptionWhen move a text frame which "Shape" set to "Use Frame Shape" close to the edge of the Chinese text frame which using "Noto Sans CJK TC" which is the yellow box area inside the .sla document will crash the Scribus.
Steps To Reproduce1. Ensure you installed the "Noto Sans CJK TC" fonts which could be download from Google https://noto-website.storage.googleapis.com/pkgs/NotoSansCJKtc-hinted.zip
2. Open the document with Scribus 1.5.4svn
3. move the Red highlighted image to the Yellow box area, then it will crash immediately.
TagsNo tags attached.
PatchNo

Relationships

has duplicate 0015252 closedjghali Crashes with "Scribus crashes due to Signal 0000011

Activities

philchan2008

2017-07-12 08:09

reporter  

move-obj-crash.gz.gz.sla (37,377 bytes)

PeterBenedek

2017-07-12 14:14

developer   ~0044168

Tested: Linux Mint 18.2; r22106

I can reproduce.

(gdb) bt
#0 0x00007ffff287e428 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
0000001 0x00007ffff288002a in __GI_abort () at abort.c:89
0000002 0x00007ffff2876bd7 in __assert_fail_base (fmt=<optimized out>,
    assertion=assertion@entry=0x5555568193f7 "false",
    file=file@entry=0x555556819388 "/build/scribus-trunk-R123sm/scribus-trunk-1.5.3svn~r22106~20170711~ppa69~ubuntu16.04.1/scribus/scribuscore.cpp",
    line=line@entry=89,
    function=function@entry=0x555556819740 "void abort_on_error(QtMsgType, const QMessageLogContext&, const QString&)") at assert.c:92
0000003 0x00007ffff2876c82 in __GI___assert_fail (
    assertion=0x5555568193f7 "false",
    file=0x555556819388 "/build/scribus-trunk-R123sm/scribus-trunk-1.5.3svn~r22106~20170711~ppa69~ubuntu16.04.1/scribus/scribuscore.cpp", line=89,
    function=0x555556819740 "void abort_on_error(QtMsgType, const QMessageLogContext&, const QString&)") at assert.c:101
0000004 0x0000555556000c02 in ?? ()
0000005 0x00007ffff3545468 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000006 0x00007ffff3546f69 in QMessageLogger::fatal(char const*, ...) const ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000007 0x00007ffff3542151 in qt_assert_x(char const*, char const*, char const*, int) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000008 0x0000555555d44cd1 in QList<GlyphCluster>::operator[](int) ()
---Type <return> to continue, or q <return> to quit---
0000009 0x0000555555d25a0a in PageItem_TextFrame::layout() ()
0000010 0x0000555555d28369 in PageItem_TextFrame::DrawObj_Item(ScPainter*, QRectF)
    ()
0000011 0x0000555555c9287f in PageItem::DrawObj(ScPainter*, QRectF) ()
0000012 0x0000555555b28cd5 in Canvas::DrawPageItems(ScPainter*, ScLayer&, QRect, bool) ()
0000013 0x0000555555b25db1 in Canvas::drawContents(QPainter*, int, int, int, int)
    ()
0000014 0x0000555555b24e1a in Canvas::fillBuffer(QPaintDevice*, QPoint, QRect) ()
0000015 0x0000555555b2437e in Canvas::adjustBuffer() ()
0000016 0x0000555555b24eb5 in Canvas::paintEvent(QPaintEvent*) ()
0000017 0x00007ffff406ffc8 in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000018 0x00007ffff402d05c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000019 0x00007ffff4032516 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000020 0x00007ffff373a38b in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000021 0x00007ffff4068ab9 in QWidgetPrivate::sendPaintEvent(QRegion const&) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000022 0x00007ffff4069101 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000023 0x00007ffff403a856 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000024 0x00007ffff403aa8c in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000025 0x00007ffff4058c5f in QWidgetPrivate::syncBackingStore() ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000026 0x00007ffff406fdc8 in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000027 0x00007ffff4185dbb in QMainWindow::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000028 0x00007ffff402d05c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000029 0x00007ffff4032516 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000030 0x00007ffff373a38b in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000031 0x00007ffff373c786 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000032 0x00007ffff37903c3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000033 0x00007ffff0352197 in g_main_context_dispatch ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000034 0x00007ffff03523f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
0000035 0x00007ffff035249c in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000036 0x00007ffff37907cf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000037 0x00007ffff3737b4a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000038 0x00007ffff373fbec in QCoreApplication::exec() ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000039 0x00005555565f8d14 in mainApp(int, char**) ()
0000040 0x00005555565f8c7d in main ()

philchan2008

2017-07-13 13:08

reporter   ~0044169

I find that adding space to the last line of the paragraph e.g. "他上禮,我禮前夕,啊! "<add space until new line> then it will crash too.

philchan2008

2017-07-13 13:26

reporter   ~0044170

Here is the sample .sla file created in Scribus 1.5.3, I find that adding one more space into the paragraph then scribus will also crash.

add-space-to-newline-crash.sla (15,135 bytes)

PeterBenedek

2017-07-17 04:42

developer   ~0044178

Tested: Linux Mint 18.2; r22112

I cannot reproduce animore.

Issue History

Date Modified Username Field Change
2017-07-12 08:09 philchan2008 New Issue
2017-07-12 08:09 philchan2008 File Added: move-obj-crash.gz.gz.sla
2017-07-12 10:41 jghali Target Version => 1.5.4
2017-07-12 14:14 PeterBenedek Note Added: 0044168
2017-07-13 13:08 philchan2008 Note Added: 0044169
2017-07-13 13:26 philchan2008 File Added: add-space-to-newline-crash.sla
2017-07-13 13:26 philchan2008 Note Added: 0044170
2017-07-16 00:59 jghali Summary Crash when move an image frame closed to the edge of (Noto font Chinese) text frame => Crash when move an image frame closed to the edge of text frame
2017-07-16 01:00 jghali Summary Crash when move an image frame closed to the edge of text frame => Crash when moving an image frame closed to the edge of a text frame
2017-07-16 01:01 jghali Assigned To => jghali
2017-07-16 01:01 jghali Status new => resolved
2017-07-16 01:01 jghali Resolution open => fixed
2017-07-16 01:01 jghali Fixed in Version => 1.5.4.svn
2017-07-17 04:42 PeterBenedek Note Added: 0044178
2017-12-20 20:58 cbradney Status resolved => closed
2018-04-07 00:12 jghali Relationship added has duplicate 0015252