View Issue Details

IDProjectCategoryView StatusLast Update
0002435ScribusGeneralpublic2006-02-26 16:13
ReporterplinnellAssigned ToTsoots  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.1cvs 
Fixed in Version1.3.3cvs 
Summary0002435: Trying to undo actions done on Master Page Objects whilst in operating on normal Pages triggers a crash.
DescriptionSteps to repeat:

New Doc

Add a new Master Page with a simple object like a circle.

Apply the new master page

Then use the undo arrow to undo the apply master page step
Additional InformationProgram received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1073880832 (LWP 31018)]
0x082f2810 in PageItem::locked (this=0x0) at pageitem.cpp:3726
3726 return Locked;
(gdb) bt
#0 0x082f2810 in PageItem::locked (this=0x0) at pageitem.cpp:3726
0000001 0x083c41ea in ScribusView::MoveItemI (this=0x8d37780, newX=-206, newY=0,
    ite=0, redraw=false) at scribusview.cpp:5092
0000002 0x083caabf in ScribusView::SizeItem (this=0x8d37780, newX=1, newY=1,
    pi=0x8da1b70, fromMP=false, DoUpdateClip=true, redraw=true)
    at scribusview.cpp:6055
0000003 0x082f6d89 in PageItem::restoreResize (this=0x8da1b70, state=0x89dd1e0,
    isUndo=true) at pageitem.cpp:4426
0000004 0x082f5867 in PageItem::restore (this=0x8da1b70, state=0x89dd1e0,
    isUndo=true) at pageitem.cpp:4279
0000005 0x084a2eee in UndoManager::doTransactionUndo (this=0x86f1da8,
    tstate=0x88ca930) at undomanager.cpp:492
0000006 0x084a2a5f in UndoManager::doUndo (this=0x86f1da8, steps=1)
    at undomanager.cpp:430
0000007 0x084a2913 in UndoManager::undo (this=0x86f1da8, steps=1)
    at undomanager.cpp:404
0000008 0x084a0cd1 in UndoManager::qt_invoke (this=0x86f1da8, _id=9, _o=0xbfffe480)
    at undomanager.moc:218
0000009 0x412be5be in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000010 0x412bebed in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000011 0x08385aca in ScrAction::activatedData (this=0x8700278, t0=1)
---Type <return> to continue, or q <return> to quit---
    at scraction.moc:128
0000012 0x08386a72 in ScrAction::activatedToActivatedData (this=0x8700278)
    at scraction.cpp:105
0000013 0x08385fee in ScrAction::qt_invoke (this=0x8700278, _id=14, _o=0xbfffe5b0)
    at scraction.moc:205
0000014 0x412be5be in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000015 0x412bed66 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000016 0x41632cc9 in QAction::activated () from /usr/lib/qt3/lib/libqt-mt.so.3
0000017 0x41632d2c in QAction::qt_emit () from /usr/lib/qt3/lib/libqt-mt.so.3
0000018 0x08386287 in ScrAction::qt_emit (this=0x8700278, _id=2, _o=0xbfffe6e0)
    at scraction.moc:224
0000019 0x412be5f1 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000020 0x412bed66 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000021 0x4161831c in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
0000022 0x41356ed4 in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000023 0x412f4ba5 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
0000024 0x4125be0f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
---Type <return> to continue, or q <return> to quit---
0000025 0x4125e1b6 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000026 0x411f928e in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000027 0x411f8146 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000028 0x41208d68 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
0000029 0x41273da1 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
0000030 0x41273be6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000031 0x4125d89f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000032 0x08514567 in mainApp (argc=1, argv=0xbffff194) at main.cpp:69
0000033 0x085144da in main (argc=1, argv=0xbffff194) at main.cpp:44
(gdb)
TagsNo tags attached.
Patch

Relationships

related to 0002977 closedcbradney Importing Master Pages produces signal 11 crashes (sometimes) and always imports the page into another master 
child of 0003837 acknowledged Metabug: Master pages/Page templates 
child of 0005745 closed Metabug: Undo/Redo issues 

Activities

cbradney

2005-08-13 21:36

administrator   ~0006109

The pointer in:
void ScribusView::MoveItemI(double newX, double newY, int ite, bool redraw)
{
    PageItem *currItem = void ScribusView::MoveItemI(double newX, double newY, int ite, bool redraw)
{
    PageItem *currItem = Doc->Items.at(ite);
    if ((currItem->locked()) || (!currItem->ScaleType))Doc->Items.at(ite);
    if ((currItem->locked()) || (!currItem->ScaleType))

is not NULL, so it must be pointing to a doc item instead of a master page item.

The whole distinction between these variables is confusing IMO. esp other code like:
    if (doc->masterPageMode)
        doc->MasterItems = doc->Items;
    else
        doc->DocItems = doc->Items;

This is just weird, seems unnecessary.

fschmid

2005-08-14 12:14

administrator   ~0006115

It doesn't crash whilst undoing the "Apply Masterpage" it does crash on trying to undo the creation of the Masterpage Object.

plinnell

2005-12-30 00:15

viewer   ~0007860

still there, but different backtrace:



Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1089528960 (LWP 29792)]
0x407710c9 in QString::QString () from /usr/lib/qt3/lib/libqt-mt.so.3
(gdb) bt
#0 0x407710c9 in QString::QString () from /usr/lib/qt3/lib/libqt-mt.so.3
0000001 0x0825b25c in Foi::family (this=0x0) at scfonts.h:75
0000002 0x08259a46 in FontComboH::setCurrentFont (this=0x89dd710, f=
      {static null = {static null = <same as static member of an already seen type>, d = 0x86760c0, static shared_null = 0x86760c0}, d = 0x86760c0, static shared_null = 0x86760c0}) at fontcombo.cpp:150
0000003 0x082f55be in Mpalette::setFontFace (this=0x89a5fc8, newFont=
      {static null = {static null = <same as static member of an already seen type>, d = 0x86760c0, static shared_null = 0x86760c0}, d = 0x86760c0, static shared_null = 0x86760c0}) at mpalette.cpp:1794
0000004 0x082de603 in Mpalette::qt_invoke (this=0x89a5fc8, _id=71, _o=0xbfffe030)
    at mpalette.moc:724
0000005 0x4049623a in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000006 0x404965dd in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000007 0x0831996f in PageItem::textFont (this=0x8df66b8, t0=Cannot access memory at address 0x14
) at pageitem.moc:506
0000008 0x08329cce in PageItem::setFont (this=0x8df66b8, newFont=@0xbfffe190)
    at pageitem.cpp:1789
0000009 0x084c2c9d in ScribusView::ItemFont (this=0x8f5aa38, fon=
      {static null = {static null = <same as static member of an already seen type>, d = 0x86760c0, static shared_null = 0x86760c0}, d = 0x86760c0, static shared_null = 0x86760c0}) at scribusview.cpp:9096
0000010 0x0832ef9b in PageItem::restoreFont (this=0x8df66b8, state=0x8fa2820, isUndo=true)
    at pageitem.cpp:2548
0000011 0x0832d01d in PageItem::restore (this=0x8df66b8, state=0x8fa2820, isUndo=true)
    at pageitem.cpp:2273
0000012 0x08586666 in UndoManager::doTransactionUndo (this=0x8784e30, tstate=0x88573e8)
    at undomanager.cpp:492
---Type <return> to continue, or q <return> to quit---
0000013 0x085861d7 in UndoManager::doUndo (this=0x8784e30, steps=1) at undomanager.cpp:430
0000014 0x0858608b in UndoManager::undo (this=0x8784e30, steps=1) at undomanager.cpp:404
0000015 0x08584449 in UndoManager::qt_invoke (this=0x8784e30, _id=9, _o=0xbfffe630)
    at undomanager.moc:218
0000016 0x404962ee in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000017 0x4049691d in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000018 0x0845e836 in ScrAction::activatedData (this=0x877f158, t0=1) at scraction.moc:128
0000019 0x0845f7de in ScrAction::activatedToActivatedData (this=0x877f158)
    at scraction.cpp:105
0000020 0x0845ed5a in ScrAction::qt_invoke (this=0x877f158, _id=14, _o=0xbfffe760)
    at scraction.moc:205
0000021 0x404962ee in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000022 0x40496a96 in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000023 0x407ff6b9 in QAction::activated () from /usr/lib/qt3/lib/libqt-mt.so.3
0000024 0x407ff71c in QAction::qt_emit () from /usr/lib/qt3/lib/libqt-mt.so.3
0000025 0x0845eff3 in ScrAction::qt_emit (this=0x877f158, _id=2, _o=0xbfffe890)
    at scraction.moc:224
0000026 0x40496321 in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000027 0x40496a96 in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
0000028 0x407e50bc in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
0000029 0x4052cdb4 in QButton::mouseReleaseEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000030 0x404cc045 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
0000031 0x4043471f in QApplication::internalNotify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000032 0x40436a88 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000033 0x403d3033 in QETWidget::translateMouseEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000034 0x403d1f0d in QApplication::x11ProcessEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000035 0x403e27c5 in QEventLoop::processEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
---Type <return> to continue, or q <return> to quit---
0000036 0x4044c3c1 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
0000037 0x4044c206 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000038 0x4043619f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000039 0x085ee243 in mainApp (argc=1, argv=0xbffff324) at main_nix.cpp:69
0000040 0x085ee1b6 in main (argc=1, argv=0xbffff324) at main_nix.cpp:44
(gdb)

plinnell

2005-12-30 00:16

viewer   ~0007861

win32 build alos crahes with an access violation exception

winfried_mb2

2006-02-19 15:15

reporter   ~0008809

Not sure if this is related but 1.3.2 also crashes when doing the following:
New document
edit->Master pages...
klik ¨import master pages from other document¨ button
import ¨normal¨ master page from other document
select ¨copy 0000001 of normal¨ and click trash bin button
confirm that you really want to delete the master page
Scribus crashed due to Signal 0000011

cbradney

2006-02-19 19:32

administrator   ~0008810

That sig11 is fixed in cvs.

plinnell

2006-02-26 16:13

viewer   ~0008929

tested. fixed.

Issue History

Date Modified Username Field Change
2005-08-13 20:54 plinnell New Issue
2005-08-13 21:34 cbradney Status new => assigned
2005-08-13 21:34 cbradney Assigned To => fschmid
2005-08-13 21:36 cbradney Note Added: 0006109
2005-08-14 12:14 fschmid Note Added: 0006115
2005-08-14 12:16 fschmid Assigned To fschmid => Tsoots
2005-08-14 12:16 fschmid Summary Apply of Undo of Master Page triggers crash => Trying to undo actions done on Master Page Objects whilst in operating on normal Pages triggers a crash.
2005-12-30 00:15 plinnell Note Added: 0007860
2005-12-30 00:16 plinnell Note Added: 0007861
2006-01-09 09:43 plinnell Relationship added related to 0002977
2006-02-19 15:15 winfried_mb2 Note Added: 0008809
2006-02-19 19:32 cbradney Note Added: 0008810
2006-02-26 00:28 Tsoots Status assigned => resolved
2006-02-26 00:28 Tsoots Fixed in Version => 1.3.3cvs
2006-02-26 00:28 Tsoots Resolution open => fixed
2006-02-26 16:13 plinnell Status resolved => closed
2006-02-26 16:13 plinnell Note Added: 0008929
2006-05-18 18:34 christoph_s Relationship added child of 0003837
2007-05-23 20:38 christoph_s Relationship added child of 0005745