View Issue Details

IDProjectCategoryView StatusLast Update
0003275ScribusUser Interfacepublic2007-10-06 17:39
ReporterPLucAuclair Assigned Tofschmid  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version1.3.5svn 
Summary0003275: Preview mode
DescriptionHi, we really need a preview mode! Right now the only semi-functional way of doing this is by doing a Print Preview. This method is just totally useless and unflexible. First, there's no color correction on this window and second, you can't move anything around!

Basically all it does is hide everything outside the page.

See attached file for example.
TagsNo tags attached.
Patch

Relationships

related to 0003519 closedfschmid Print preview: CMYK preview wrong 
related to 0003538 feedback "snap to..." options should be placed in guideline manager and in configuration 
related to 0004354 new Mini preview for page elements 

Activities

2006-02-21 19:42

 

preview_mode.zip (625,810 bytes)

cbradney

2006-02-21 20:10

administrator   ~0008852

Have you tried turning off all page marks (F11), have you tried hiding the rulers? (No, hiding the menus is not yet done)

PLucAuclair

2006-02-21 20:17

reporter   ~0008853

Last edited: 2006-02-21 20:18

This hasn't to do with hiding the menus or the page marks, this is about hiding the stuff outside the page. Maybe add a "Hide Content Outside Page" in the view? That would do the same thing. What I need is the parts of images/text that are outside the page area to be hidden and still editable.

mhanski

2006-03-24 10:35

developer   ~0009465

Reminder sent to: user715

this looks like one of the things you've mentioned

ringerc

2006-03-27 02:19

reporter   ~0009488

I think this makes sense. The canvas provides an accurate rendering with colour management, so all that'd really be required is a mode that turned off all rulers, frame borders, etc and clipped content outside the page / margins. The clipping might not need much more than a drawing mask to be set.

The behaviour I think I'd expect would be:

(a) preview mode turns off all rulers, grid, frame outlines, grab points, etc BUT remembers what the user's settings were
(b) If the user tries to re-activate any of those, preview mode is turned off and their previous settings get restored. This should help avoid the "what the hell just happened? what key did I press? ARGH!" issue one runs into in apps like MS Word, where all the things the user is used to using to change something just don't work because of some overriding mode / setting.
(c) Deactivating preview mode manually also restores all display settings

It might also be interesting to one day be able to preview individual plates on the native canvas.

fschmid

2006-04-02 12:03

administrator   ~0009595

Have found a way to display only the contents of the pages, not the objects on the canvas outside the pages (objects are clipped to the page borders). Drawback is that this code relies on the cairo lib, libart isn't able to provide the needed functionality.

Another way would be to use the ScribusView::PageToPixmap code for doing this.

PLucAuclair

2006-04-02 17:42

reporter   ~0009600

libart doesn't have some kind of masking/clipping?

fschmid

2006-04-15 09:01

administrator   ~0010000

Have made a first experimental implementation now.

PLucAuclair

2006-04-16 18:13

reporter   ~0010036

Is there a way to currently test it?

fschmid

2006-04-16 21:47

administrator   ~0010039

Yes, in current CVS there is a small button at the lower right edge of the window,
(the Button with the "Eye"). Just toggle this button to switch preview mode on or
off.

mhanski

2006-04-16 21:57

developer   ~0010041

i keep getting sig11 crashes after clicking on this "eye". this is with 1.3.4cvs

christoph_s

2006-04-16 22:07

administrator   ~0010042

Same here (SuSE 9.3)

PLucAuclair

2006-04-17 00:19

reporter   ~0010050

It does nothing here, not even crash, although I'm currently on a Cairo build.

I suggest it's moved in the View menu as a Show option too.

mhanski

2006-04-17 11:26

developer   ~0010055

BACKTRACE:
-----------------
(gdb)
(gdb) run
Starting program: /opt/scribus134/bin/scribus
[Thread debugging using libthread_db enabled]
[New Thread -1223903552 (LWP 13241)]
Qt: gdb: -nograb added to command-line options.
         Use the -dograb option to enforce grabbing.
ScimInputContextPlugin()

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1223903552 (LWP 13241)]
0xb7458043 in art_svp_render_aa_iter () from /usr/lib/libart_lgpl_2.so.2
(gdb)

plinnell

2006-04-17 12:35

viewer   ~0010057

This works fine here with --enable-cairo run at configure time, however, clicking on the eye with libart build triggers a consistent crash in current cvs.

rogram received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1073908512 (LWP 18281)]
0x41d8b423 in art_svp_render_aa_iter () from /usr/lib/libart_lgpl_2.so.2
(gdb) bt
#0 0x41d8b423 in art_svp_render_aa_iter () from /usr/lib/libart_lgpl_2.so.2
0000001 0x41d8c57b in art_svp_render_aa () from /usr/lib/libart_lgpl_2.so.2
0000002 0x086937f3 in ksvg_art_rgb_affine_clip (svp=0x0,
    dst=0x40833008 "����������������������������������������������������������������������������������������������������"..., x0=0, y0=0,
    x1=937, y1=559, dst_rowstride=3748, dst_channels=4, src=0x40a33998 "@@@", src_width=522, src_height=612,
    src_rowstride=2088, affine=0xbfac6398, alpha=255, mask=0x0) at art_kmisc.c:1103
0000003 0x0849ee56 in ScPainter::drawImage (this=0x8cdf858, image=0xbfac668c) at scpainter.cpp:935
0000004 0x0852fab1 in ScribusView::drawContents (this=0x8ec4ee0, clipx=90, clipy=10, clipw=937, cliph=559)
    at scribusview.cpp:341
0000005 0x413d7c13 in QScrollView::drawContentsOffset () from /usr/lib/qt3/lib/libqt-mt.so.3
0000006 0x413d9797 in QScrollView::viewportPaintEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
0000007 0x084e449e in ScribusView::viewportPaintEvent (this=0x8ec4ee0, p=0xbfac6d7c) at scribusview.cpp:274
0000008 0x413da685 in QScrollView::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
0000009 0x412bfbee in QObject::activate_filters () from /usr/lib/qt3/lib/libqt-mt.so.3
0000010 0x412bfc6b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
0000011 0x412fa31c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
0000012 0x4125f4c1 in QApplication::internalNotify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000013 0x4125fe49 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
0000014 0x41230088 in QWidget::repaint () from /usr/lib/qt3/lib/libqt-mt.so.3
0000015 0x41260f1b in QApplication::sendPostedEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
0000016 0x41260fe4 in QApplication::sendPostedEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
0000017 0x4120c6e0 in QEventLoop::processEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
0000018 0x41276558 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
0000019 0x41276456 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000020 0x4125ee0f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
0000021 0x0867b2ab in mainApp (argc=1, argv=0xbfac7104) at main_nix.cpp:76
0000022 0x0867b2f8 in main (argc=1, argv=0xbfac7104) at main_nix.cpp:52
(gdb)

fschmid

2006-04-17 21:23

administrator   ~0010071

Fixed the crash now, but i'm getting now lots of funny effects. It seems that
the ScPainters in ScribusView::PageToPixmap and ScribusView::drawContents are
affecting each other.

PLucAuclair

2006-04-22 22:12

reporter   ~0010341

I just did a build today, this is excellent! I am very happy. :)

I'm gonna say again at the risk of sounding like an ass, but this option in View would kick-ass (while retaining guides and all) too.

I would see it as F11 toggle instead of a feature in itself, but it's just me, say what you think.

fschmid

2006-04-22 22:22

administrator   ~0010342

Yes, the option should go into the view menue, but its still experimental because there are some bad effects with it when Scribus isn't build with cairo support.

christoph_s

2006-04-22 22:32

administrator   ~0010345

>>>Yes, the option should go into the view menue, but its still experimental because there are some bad effects with it when Scribus isn't build with cairo support.

I'd say, it should also go to the view menu. As it is now, it's not bad.

Issue History

Date Modified Username Field Change
2006-02-21 19:42 PLucAuclair New Issue
2006-02-21 19:42 PLucAuclair File Added: preview_mode.zip
2006-02-21 20:10 cbradney Note Added: 0008852
2006-02-21 20:17 PLucAuclair Note Added: 0008853
2006-02-21 20:18 PLucAuclair Note Edited: 0008853
2006-03-24 10:35 mhanski Note Added: 0009465
2006-03-27 02:19 ringerc Note Added: 0009488
2006-03-27 02:19 ringerc Status new => acknowledged
2006-03-28 11:28 mhanski Relationship added related to 0003519
2006-04-02 12:03 fschmid Note Added: 0009595
2006-04-02 17:42 PLucAuclair Note Added: 0009600
2006-04-15 09:01 fschmid Note Added: 0010000
2006-04-16 18:13 PLucAuclair Note Added: 0010036
2006-04-16 21:47 fschmid Note Added: 0010039
2006-04-16 21:57 mhanski Note Added: 0010041
2006-04-16 22:07 christoph_s Note Added: 0010042
2006-04-17 00:19 PLucAuclair Note Added: 0010050
2006-04-17 11:26 mhanski Note Added: 0010055
2006-04-17 12:35 plinnell Note Added: 0010057
2006-04-17 21:23 fschmid Note Added: 0010071
2006-04-22 22:12 PLucAuclair Note Added: 0010341
2006-04-22 22:22 fschmid Note Added: 0010342
2006-04-22 22:32 christoph_s Note Added: 0010345
2006-04-29 18:33 mhanski Relationship added related to 0003723
2006-04-29 18:33 mhanski Relationship deleted related to 0003723
2006-04-29 19:49 mhanski Relationship added related to 0003538
2006-10-03 23:18 christoph_s Relationship added related to 0004354
2007-10-06 09:33 plinnell Assigned To => fschmid
2007-10-06 09:33 plinnell Status acknowledged => resolved
2007-10-06 09:33 plinnell Resolution open => fixed
2007-10-06 09:33 plinnell Fixed in Version => 1.3.5svn
2007-10-06 17:39 plinnell Status resolved => closed