View Issue Details

IDProjectCategoryView StatusLast Update
0015248ScribusUsabilitypublic2018-04-06 05:30
ReporterPeterBenedek Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx86OSLinux MintOS Version18.3
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0015248: After changing the "Hyphenation Character", Scribus crashes
DescriptionTested r22463; Qt 5.5.1

Scribus crashes, if you open the test.sla document, and rerange it.

The document include:
-- Two stiles (SZ_00; SZ_01)
-- Align to baseline grid
-- Two columns
Steps To Reproduce-- Open test.sla
-- Resize TextFrame
-- Double click on TextFrame (This activate edit mode) and click-click

Crash

--- Edited ---

New test:
-- Open test.sla
-- Click on TextFrame
-- PP - TextProperties - Hyphenation (the hyphenation character can be changed!)
If you change it, the Scribus not crashes
-- Close document (not saved)

-- Open test.sla
-- Double click on TextFrame (This activate edit mode)
-- PP - TextProperties - Hyphenation (the hyphenation character can't be changed!)
-- Click on TextFrame
-- Resize
-- Double click on Text Frame

Crash
Additional Information(gdb) bt
#0 0x0000555555cf5977 in BaseStyle::BaseStyle(BaseStyle const&) ()
0000001 0x0000555555cf5aee in CharStyle::CharStyle(CharStyle const&) ()
0000002 0x0000555555cfa956 in QPair<CharStyle, CharStyle>::QPair(QPair<CharStyle, CharStyle> const&) ()
0000003 0x0000555555cfa9c1 in ScItemState<QPair<CharStyle, CharStyle> >::getItem() const ()
0000004 0x000055555602bbb4 in ScribusDoc::itemSelection_ApplyCharStyle(CharStyle const&, Selection*, QString) ()
0000005 0x00005555560227eb in ScribusDoc::itemSelection_SetHyphenChar(unsigned int, Selection*) ()
0000006 0x00005555564accec in PropertyWidget_Hyphenation::handleHyphenChar(QString const&) ()
0000007 0x0000555555ab4087 in ()
0000008 0x00007ffff3766d2a in QMetaObject::activate(QObject*, int, int, void**) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000009 0x00007ffff417a772 in QLineEdit::textChanged(QString const&) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000010 0x00007ffff4180f29 in () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000011 0x00007ffff3766d2a in QMetaObject::activate(QObject*, int, int, void**) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000012 0x00007ffff43cb465 in QWidgetLineControl::textChanged(QString const&) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000013 0x00007ffff4208c6a in QWidgetLineControl::finishChange(int, bool, bool) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000014 0x00007ffff4208fd1 in QWidgetLineControl::internalSetText(QString const&, int, bool) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000015 0x00007ffff417ca66 in QLineEdit::setText(QString const&) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000016 0x00005555564ad180 in PropertyWidget_Hyphenation::updateCharStyle(CharStyle const&) ()
0000017 0x0000555556486891 in PropertiesPalette_Text::updateCharStyle(CharStyle const&) ()
0000018 0x0000555555ab103f in ()
0000019 0x00007ffff3766d2a in QMetaObject::activate(QObject*, int, int, void**) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000020 0x0000555555a866e4 in ScribusView::ItemCharStyle(CharStyle const&) ()
0000021 0x0000555556095be6 in ScribusView::slotSetCurs(int, int) ()
0000022 0x0000555555b8a600 in CanvasMode_Edit::mousePressEvent(QMouseEvent*) ()
0000023 0x00005555560a0fd6 in ScribusView::eventFilter(QObject*, QEvent*) ()
0000024 0x00007ffff3738172 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000025 0x00007ffff402b03c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000026 0x00007ffff4030c19 in QApplication::notify(QObject*, QEvent*) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000027 0x00007ffff373838b in QCoreApplication::notifyInternal(QObject*, QEvent*) ()---Type <return> to continue, or q <return> to quit---
 at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000028 0x00007ffff402fb32 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000029 0x00007ffff40885bb in () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000030 0x00007ffff408ab7b in () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000031 0x00007ffff402b05c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000032 0x00007ffff4030516 in QApplication::notify(QObject*, QEvent*) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000033 0x00007ffff373838b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000034 0x00007ffff3a7a4e1 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000035 0x00007ffff3a7c1a5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
    at /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000036 0x00007ffff3a5ff08 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000037 0x00007fffe6a23200 in () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
0000038 0x00007ffff0350197 in g_main_context_dispatch (context=0x7fffdc0016f0)
    at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3154
0000039 0x00007ffff0350197 in g_main_context_dispatch (context=context@entry=0x7fffd---Type <return> to continue, or q <return> to quit---
c0016f0) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3769
0000040 0x00007ffff03503f0 in g_main_context_iterate (context=context@entry=0x7fffdc0016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3840
0000041 0x00007ffff035049c in g_main_context_iteration (context=0x7fffdc0016f0, may_block=1) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3901
0000042 0x00007ffff378e7cf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000043 0x00007ffff3735b4a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000044 0x00007ffff373dbec in QCoreApplication::exec() ()
    at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000045 0x000055555662ccca in mainApp(int, char**) ()
0000046 0x000055555662cc33 in main ()
TagsNo tags attached.
PatchNo

Activities

PeterBenedek

2018-04-05 10:30

developer  

test.sla (27,830 bytes)
output.gif (214,429 bytes)
output.gif (214,429 bytes)

PeterBenedek

2018-04-05 12:24

developer   ~0045145

Last edited: 2018-04-05 12:37

View 2 revisions

Retest:
-- Make new document
-- Make a TextFrame
-- Click on the TextFrame
-- pp - Text Properties - Hyphenation - Hyphenation character field
-- Change the character (0, 1, # or anything else)
-- Double click on the TextFrame
-- pp - Text Properties - Hyphenation - Hyphenation character field
-- Change the character
Crash

PeterBenedek

2018-04-05 12:38

developer  

Hyph_crash.gif (201,185 bytes)
Hyph_crash.gif (201,185 bytes)

PeterBenedek

2018-04-06 05:29

developer   ~0045148

Tested r22466

Works fine.

Thank you Jean.

Closed

Issue History

Date Modified Username Field Change
2018-04-05 10:30 PeterBenedek New Issue
2018-04-05 10:30 PeterBenedek File Added: test.sla
2018-04-05 10:30 PeterBenedek File Added: output.gif
2018-04-05 10:32 PeterBenedek OS => Linux Mint
2018-04-05 10:32 PeterBenedek OS Version => 18.3
2018-04-05 10:32 PeterBenedek Platform => x86
2018-04-05 11:30 PeterBenedek Summary Crashes maybe because of a style problem => After changing the "Hyphenation Character", Scribus crashes
2018-04-05 11:30 PeterBenedek Steps to Reproduce Updated View Revisions
2018-04-05 12:24 PeterBenedek File Added: retest.gif
2018-04-05 12:24 PeterBenedek Note Added: 0045145
2018-04-05 12:37 PeterBenedek Note Edited: 0045145 View Revisions
2018-04-05 12:37 PeterBenedek File Deleted: retest.gif
2018-04-05 12:38 PeterBenedek File Added: Hyph_crash.gif
2018-04-05 22:43 jghali Assigned To => jghali
2018-04-05 22:43 jghali Status new => resolved
2018-04-05 22:43 jghali Resolution open => fixed
2018-04-05 22:43 jghali Fixed in Version => 1.5.4.svn
2018-04-06 05:29 PeterBenedek Note Added: 0045148
2018-04-06 05:30 PeterBenedek Status resolved => closed