View Issue Details

IDProjectCategoryView StatusLast Update
0008256ScribusGraphics / Image Framespublic2009-09-27 21:30
Reporterjoolsr Assigned ToHerm  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.5svn 
Target VersionFixed in Version1.5.0svn 
Summary0008256: Trying Using 'Edit Source' scribus process goes to 95% and hangs Scribus
DescriptionScribus Version 1.3.5.rc3
29 June 2009
Build ID: C-C-T-F-C1.8.6
Using Ghostscript version 8.64

on Ubuntu 9.0.4 (Windows Xp worked fine)

Steps to Reproduce:-

1. Add a Latex Frame (contents do not matter)
2. Right Click the Latex Frame, and 'Edit Source'.

No editor appears, instead Scribus goes to 95% CPU trying to render Latex Editor Window without success.

This happens for each LaTeX frame I have. The frames are only a few lines long.
Additional InformationThe command to call Latex is the default ie 'pdflatex --interaction nonstopmode' which if you run on a cmd line itself appears to work ok.

Using the same Scribus File on Windows XP, 1.3.5 RC3 shows the Latex editor fine, although doesn't render the latex itself( Although I haven't got any Latex binaries installed on Windows)

PDFLatex is installed.
TagsNo tags attached.
Patch

Relationships

child of 0007647 acknowledgedHerm Metabug: Render Frames (LaTeX, GnuPlot, LilyPond, GraphViz, etc.) 

Activities

Herm

2009-07-12 11:17

administrator   ~0022166

I can't reproduce this bug.
Could you please do the following steps:
In a console start this command: "gdb scribus" (perhaps you first have to install gdb). Type "run", Scribus should start now. Create a Latex frame and start the editor. When Scribus has crashed press Ctrl+C in the gdb-console.
You'll see something like this (values and names will be different):
^C
Program received signal SIGINT, Interrupt.
[Switching to Thread 0xb67236f0 (LWP 23570)]
0xb6ccb0dd in poll () from /lib/libc.so.6

now type "bt" and add the output to a comment on this bug.

The output should look like this:
#0 0xb6ccb0dd in poll () from /lib/libc.so.6
0000001 0xb6a4f08b in g_poll () from /usr/lib/libglib-2.0.so.0
[...]
0000030 0x08b8e248 in mainApp ()
0000031 0x08b8e2c2 in main ()

joolsr

2009-07-13 09:14

reporter   ~0022169

Thanks

Here's the backtrace.

If you need any further debugging please let me know

Julian

(gdb) bt
#0 0xb718a39c in QRegExp::operator= () from /usr/lib/libQtCore.so.4
0000001 0xb718a625 in QRegExp::QRegExp () from /usr/lib/libQtCore.so.4
0000002 0xb7190f1c in QString::indexOf () from /usr/lib/libQtCore.so.4
0000003 0x0855de4e in LatexHighlighter::highlightBlock ()
0000004 0xb79a923b in ?? () from /usr/lib/libQtGui.so.4
0000005 0xb79a93ed in ?? () from /usr/lib/libQtGui.so.4
0000006 0xb79a9724 in QSyntaxHighlighter::qt_metacall () from /usr/lib/libQtGui.so.4
0000007 0x082388bc in LatexHighlighter::qt_metacall ()
0000008 0xb7255ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000009 0xb7256932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000010 0xb7d8d3af in QTextDocument::contentsChange () from /usr/lib/libQtGui.so.4
0000011 0xb79685c4 in ?? () from /usr/lib/libQtGui.so.4
0000012 0xb79943a4 in QTextCursor::endEditBlock () from /usr/lib/libQtGui.so.4
0000013 0xb79282d4 in ?? () from /usr/lib/libQtGui.so.4
0000014 0xb792867b in QTextControl::setPlainText () from /usr/lib/libQtGui.so.4
0000015 0xb7b8dfe2 in QTextEdit::setPlainText () from /usr/lib/libQtGui.so.4
0000016 0x08546948 in LatexEditor::revert ()
0000017 0x0854b8f5 in LatexEditor::startEditor ()
0000018 0x0862f6f9 in PageItem_LatexFrame::runEditor ()
0000019 0x08934200 in ScribusMainWindow::callImageEditor ()
0000020 0x082504e7 in ScribusMainWindow::qt_metacall ()
0000021 0xb7255ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000022 0xb72560e0 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
---Type <return> to continue, or q <return> to quit---
0000023 0xb76d2891 in QAction::triggered () from /usr/lib/libQtGui.so.4
0000024 0xb76d3e0f in QAction::activate () from /usr/lib/libQtGui.so.4
0000025 0xb7b4e01c in ?? () from /usr/lib/libQtGui.so.4
0000026 0xb7b5476b in ?? () from /usr/lib/libQtGui.so.4
0000027 0xb7b55242 in QMenu::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
0000028 0xb772fb43 in QWidget::event () from /usr/lib/libQtGui.so.4
0000029 0xb7b57629 in QMenu::event () from /usr/lib/libQtGui.so.4
0000030 0xb76d8e9c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000031 0xb76e1b11 in QApplication::notify () from /usr/lib/libQtGui.so.4
0000032 0xb723fa3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000033 0xb76e0b7e in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
0000034 0xb7750c06 in ?? () from /usr/lib/libQtGui.so.4
0000035 0xb774fca7 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
0000036 0xb777ac6a in ?? () from /usr/lib/libQtGui.so.4
0000037 0xb6716b88 in IA__g_main_context_dispatch (context=0x9f8f090)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
0000038 0xb671a0eb in g_main_context_iterate (context=0x9f8f090, block=1, dispatch=1, self=0x9f8c980)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
0000039 0xb671a268 in IA__g_main_context_iteration (context=0x9f8f090, may_block=1)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
0000040 0xb726b438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
0000041 0xb777a365 in ?? () from /usr/lib/libQtGui.so.4
0000042 0xb723e06a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
---Type <return> to continue, or q <return> to quit---
0000043 0xb723e4aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000044 0xb7b57361 in QMenu::exec () from /usr/lib/libQtGui.so.4
0000045 0x0839abcd in CanvasMode_Normal::createContextMenu ()
0000046 0x0839e0f4 in CanvasMode_Normal::mouseReleaseEvent ()
0000047 0x08a3ce7c in ScribusView::eventFilter ()
0000048 0xb723ec5a in QCoreApplicationPrivate::sendThroughObjectEventFilters ()
   from /usr/lib/libQtCore.so.4
0000049 0xb76d8e7a in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000050 0xb76e1b11 in QApplication::notify () from /usr/lib/libQtGui.so.4
0000051 0xb723fa3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000052 0xb76e0b7e in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
0000053 0xb775097e in ?? () from /usr/lib/libQtGui.so.4
0000054 0xb774fca7 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
0000055 0xb777ac6a in ?? () from /usr/lib/libQtGui.so.4
0000056 0xb6716b88 in IA__g_main_context_dispatch (context=0x9f8f090)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
0000057 0xb671a0eb in g_main_context_iterate (context=0x9f8f090, block=1, dispatch=1, self=0x9f8c980)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
0000058 0xb671a268 in IA__g_main_context_iteration (context=0x9f8f090, may_block=1)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
0000059 0xb726b438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
0000060 0xb777a365 in ?? () from /usr/lib/libQtGui.so.4
0000061 0xb723e06a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
---Type <return> to continue, or q <return> to quit---
0000062 0xb723e4aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000063 0xb7240959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
0000064 0xb76d8d17 in QApplication::exec () from /usr/lib/libQtGui.so.4
0000065 0x08c666a6 in mainApp ()
0000066 0x08c6671b in main ()

joolsr

2009-07-13 10:16

reporter   ~0022172

I should also add that a Scribus process is left running, so that if a user tries to open Scribus again, you end up with two Scribus processes, and doing any PDf exports etc, result in a PC that gets under load very quickly - giving a poor impression of Scribus and stability/speed

zaleksf

2009-08-11 20:18

reporter   ~0022310

Last edited: 2009-08-11 20:19

I have a similar behavior with the current release of 1.3.5.0 on Windows Vista.
When I attempt to Edit Source of the render frame, Scribus crashes. I have not seen an increase in CPU load nor does an instance of Scribus remain running.

My attempt at debugging with mingw32 has produced limited results (no info from backtrace) =>
******************************************************************************
GNU gdb 6.8
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-mingw32"...
(no debugging symbols found)
(gdb) run
Starting program: C:\Program Files\Scribus 1.3.5.0\scribus.exe
[New thread 5208.0x16f4]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New thread 5208.0x17a8]
(no debugging symbols found)
[New thread 5208.0x1540]
[New thread 5208.0x17b4]
[New thread 5208.0x148c]
(no debugging symbols found)
(no debugging symbols found)
Error: dll starting at 0x5960000 not found.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
warning: Lowest section in C:\Windows\system32\normaliz.dll is .text at 00401000

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
Error: dll starting at 0x6e860000 not found.
(no debugging symbols found)
(no debugging symbols found)
Error: dll starting at 0x6ddc0000 not found.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
BFD: C:\Windows\system32\SLC.dll: Warning: Ignoring section flag IMAGE_SCN_MEM_N
OT_PAGED in section .reloc
BFD: C:\Windows\system32\SLC.dll: Warning: Ignoring section flag IMAGE_SCN_MEM_N
OT_PAGED in section .reloc
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New thread 5208.0x11c0]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
Error: dll starting at 0x6cd0000 not found.
(no debugging symbols found)
(no debugging symbols found)
Error: dll starting at 0x6e230000 not found.
(no debugging symbols found)
Error: dll starting at 0x6c6f0000 not found.
(no debugging symbols found)
[New thread 5208.0x8e0]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
warning: Cannot mix incompatible Qt libraries

**(I believe this is where I attempt to edit the render frame)**

Program exited with code 01.
(gdb) Quit (expect signal SIGINT when the program is resumed)
(gdb) bt
No stack.
(gdb)
******************************************************************************

BTW, I do have the Qt-2009.03.1 SDK installed on my system, compiled with both gcc and msvc. I don't know if there may be "intereference" due to certain path variables, etc.

jghali

2009-08-11 22:13

administrator   ~0022311

There may be interference. On Windows C++ binaries compiled by different compilers are generally *totally* incompatible. This gonna be the case with gcc and msvc.

zaleksf

2009-08-12 04:36

reporter   ~0022313

Does Scribus have specific path variables that ensure it only uses the appropriate set of Qt libraries? My libraries are all kept "neatly" in their default build locations, but I do include those locations in my Windows PATH variable.

zaleksf

2009-08-12 13:15

reporter   ~0022315

Scribus-1.3.5.1
Windows XP sp3
'Edit Source' on render frame crashes Scribus application.

jghali

2009-08-12 17:38

administrator   ~0022316

>> Does Scribus have specific path variables that ensure it only uses the appropriate set of Qt libraries?
It doesn't need to

>> My libraries are all kept "neatly" in their default build locations
Ok

>> I do include those locations in my Windows PATH variable.
Not ok at all. Only one set of libraries can be in PATH, otherwise conflict guaranteed

John Jason Jordan

2009-08-12 18:23

reporter   ~0022317

I just discovered this bug this morning. I have 1.3.5 Rc3 on Ubuntu 9.0.4 x86_64, installed via Synaptic with the Scribus and tagancha repositories enabled. I can open a render frame, but when I right-click on it and select Edit Source Scribus hangs. The CPU speed does not change, nor do I get any error messages. It just hangs and I have to force quit to exit. When I force quit it quits completely and does not leave anything running. I can relaunch Scribus immediately without problem, but any attempt to edit the source of a render frame causes Scribus to hang.

The last time I used a render frame was with the last version before Rc1, and it worked fine then.

Herm

2009-08-12 21:35

administrator   ~0022319

That's strange. I think there were no changes to render frames during the RC series.

However the discussion about different libraries remembered me of something. On another project I wrote, which uses QRegExp as well suddenly stopped working when I copied it to a different machine with a slightly different version of QT4. The QRegExp functions returned invalid data, i.e. they returned matches of length zero for inputs that could not produce zero length matches.

So it might be a problem with the syntax highlighter which uses QRegExp and might go to an endless loop.
Please try the following: Download the attached file latex_nohighlighting.xml, then go to File->Preferences->External Tools->Render Frames. Delete everything in this list and add the downloaded file. Now create a NEW render frame and try opening the editor.

2009-08-12 21:36

 

latex_nohighlighting.xml (40,282 bytes)

John Jason Jordan

2009-08-12 21:49

reporter   ~0022320

Yay!

I followed Herm's instructions in the previous note and Edit Source now works perfectly.

I do wonder what I'll be missing having deleted all the other files in File > Preferences > External Tools > Render Frames.

Meantime, it's lovely to have discovered the source of the problem. Hope it solves the problem for everyone else.

Herm

2009-08-12 22:05

administrator   ~0022321

I'll write a fix that detects the broken QT versions and simply disables syntax highlighting in this case. In the mean time you can simply delete the highlighting rules from all the editorconfig files.

You should have a directory "editorconfig" somewhere (linux: /usr/share/scribus/editorconfig or /usr/local/share/scribus/editorconfig somewhere else on windows, just search for it), which contains the file 100_latex.xml and other .xml files. Just open them in an texteditor and delete all lines in the <highlighter> section at the top of the file.
They all should start with <rule ...

You can either add all files back by hand or simply delete everything from the list and restart scribus. It automatically refills the list if it is empty.

joolsr

2009-08-13 08:46

reporter   ~0022323

Yepp, Trying Herms fix, ie using the attached file in place of the existing latex one, does work for me on Scribus 1.3.5 now using Ubuntu Linux 9.0.4 and the latest Scribus from Malex's repo.

zaleksf

2009-08-13 14:07

reporter   ~0022324

In response to:
(0022316)
jghali (administrator)
09-Aug-12 19:38
-----------------------------------------------------------------------------
>> I do include those locations in my Windows PATH variable.
Not ok at all. Only one set of libraries can be in PATH, otherwise conflict guaranteed
------------------------------------------------------------------------------
Does this mean that Qt developers can not use Scribus? Maybe I should be more clear: the location of my Qt-4.5.2 binaries (...\bin) are in my PATH variable; dll files are in the \bin file as well as executables.

Anyway, I removed the location of the Qt binaries from my PATH variable and the same problem persists w/ Scribus-1.3.5.1.

Looking forward to the fix!

jghali

2009-08-13 15:17

administrator   ~0022325

>> Does this mean that Qt developers can not use Scribus?
No it means that multiple locations of Qt binaries compiled with different compilers must not be in the PATH at the same time.

Herm

2009-09-27 21:16

administrator   ~0022566

I added code to check if the values returned by QT are valid. If they are not highlighting is disabled. This should fix this bug. I'm sorry, but there is no sensible way to keep highlighting enabled when QT returns invalid data.
The bugfix is commited in the 1.3.5 (svn only!) and 1.5.0 branches.

plinnell

2009-09-27 21:30

viewer   ~0022567

fixed with a commit to SVN in1.3.6.svn and 1.5.0.svn

Issue History

Date Modified Username Field Change
2009-07-06 14:42 joolsr New Issue
2009-07-07 16:37 mhanski Relationship added child of 0007647
2009-07-12 09:03 Herm Status new => assigned
2009-07-12 09:03 Herm Assigned To => Herm
2009-07-12 11:17 Herm Note Added: 0022166
2009-07-12 11:17 Herm Status assigned => feedback
2009-07-13 09:14 joolsr Note Added: 0022169
2009-07-13 10:16 joolsr Note Added: 0022172
2009-08-11 20:18 zaleksf Note Added: 0022310
2009-08-11 20:19 zaleksf Note Edited: 0022310
2009-08-11 22:13 jghali Note Added: 0022311
2009-08-12 04:36 zaleksf Note Added: 0022313
2009-08-12 13:15 zaleksf Note Added: 0022315
2009-08-12 17:38 jghali Note Added: 0022316
2009-08-12 18:23 John Jason Jordan Note Added: 0022317
2009-08-12 21:35 Herm Note Added: 0022319
2009-08-12 21:36 Herm File Added: latex_nohighlighting.xml
2009-08-12 21:49 John Jason Jordan Note Added: 0022320
2009-08-12 22:05 Herm Note Added: 0022321
2009-08-13 08:46 joolsr Note Added: 0022323
2009-08-13 14:07 zaleksf Note Added: 0022324
2009-08-13 15:17 jghali Note Added: 0022325
2009-09-27 21:16 Herm Note Added: 0022566
2009-09-27 21:16 Herm Status feedback => resolved
2009-09-27 21:16 Herm Fixed in Version => 1.5.0svn
2009-09-27 21:16 Herm Resolution open => fixed
2009-09-27 21:30 plinnell Note Added: 0022567
2009-09-27 21:30 plinnell Status resolved => closed
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames