View Issue Details

IDProjectCategoryView StatusLast Update
0011994ScribusImport / Exportpublic2015-03-07 06:21
Reporterchristoph_s Assigned Tocbradney  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSOpenSUSE 64 BitOS Version13.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011994: The GraphicsMagick plug-in doesn't recognise all supported formats, even though they can be imported
DescriptionThe list of supported file formats that will be recognised if one chooses "GraphicsMagick File" in a file selector is incomplete. For example, I can import PCX and SGI files, but only if I select the option "All files" in a file dialog.

The latter option is not without issues, because trying to import an image format *not* supported by GM may result in a crash. Below you see a backtrace for an attempt to import an IM1 file (segfault).
Additional InformationLoading image "/home/christoph/Bilder/importvisio.im1" Tumbnail: false
Missing separate debuginfo for /usr/lib64/GraphicsMagick-1.3.18/modules-Q16/coders/sun.so
Try: zypper install -C "debuginfo(build-id)=0143f420e13f90f56641cb3d0c6330215848170e"

Program received signal SIGSEGV, Segmentation fault.
0x00007fffeedc5488 in _int_free () from /lib64/libc.so.6
(gdb) bt
#0 0x00007fffeedc5488 in _int_free () from /lib64/libc.so.6
0000001 0x00007fffc7dbc072 in ?? () from /usr/lib64/GraphicsMagick-1.3.18/modules-Q16/coders/sun.so
0000002 0x00007ffff2124536 in ReadImage () from /usr/lib64/libGraphicsMagick.so.3
0000003 0x00000000012a6a92 in ScImgDataLoader_GMagick::loadPicture (this=0x314fd80, fn=..., res=72, thumbnail=false)
    at /home/christoph/scribus15/Scribus/scribus/scimgdataloader_gmagick.cpp:158
0000004 0x0000000000c3bc72 in ScImage::loadPicture (this=0x2e63490, fn=..., page=0, cmSettings=...,
    requestType=ScImage::RGBData, gsRes=72, realCMYK=0x7fffffffae3f, showMsg=true)
    at /home/christoph/scribus15/Scribus/scribus/scimage.cpp:2285
0000005 0x0000000000c3b2db in ScImage::loadPicture (this=0x2e63490, cache=..., fromCache=@0x7fffffffae3e: false,
    page=0, cmSettings=..., requestType=ScImage::RGBData, gsRes=72, realCMYK=0x7fffffffae3f, showMsg=true)
    at /home/christoph/scribus15/Scribus/scribus/scimage.cpp:2193
0000006 0x0000000000a36d88 in PageItem::loadImage (this=0x2e63250, filename=..., reload=false, gsResolution=-1,
    showMsg=true) at /home/christoph/scribus15/Scribus/scribus/pageitem.cpp:8993
0000007 0x0000000000d8edce in ScribusDoc::loadPict (this=0x322ebe0, fn=..., pageItem=0x2e63250, reload=false,
    showMsg=true) at /home/christoph/scribus15/Scribus/scribus/scribusdoc.cpp:5810
0000008 0x00000000008e6c29 in CanvasMode_ImageImport::setImage (this=0x3aa1260, currItem=0x2e63250)
    at /home/christoph/scribus15/Scribus/scribus/canvasmode_imageimport.cpp:237
0000009 0x00000000008e5a14 in CanvasMode_ImageImport::setImageList (this=0x3aa1260, l=...)
    at /home/christoph/scribus15/Scribus/scribus/canvasmode_imageimport.cpp:56
0000010 0x0000000000d0873d in ScribusMainWindow::slotGetContent (this=0x1b407c0)
    at /home/christoph/scribus15/Scribus/scribus/scribus.cpp:4465
0000011 0x0000000000806674 in ScribusMainWindow::qt_static_metacall (_o=0x1b407c0,
    _c=QMetaObject::InvokeMetaMethod, _id=54, _a=0x7fffffffbcc0)
    at /home/christoph/scribus15/Scribus/scribus/moc_scribus.cpp:974
0000012 0x00007ffff76d5596 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQt5Core.so.5
0000013 0x00007ffff6dc9242 in QAction::triggered(bool) () from /usr/lib64/libQt5Widgets.so.5
0000014 0x00007ffff6dcb558 in QAction::activate(QAction::ActionEvent) () from /usr/lib64/libQt5Widgets.so.5
0000015 0x00007ffff6f35e1a in ?? () from /usr/lib64/libQt5Widgets.so.5
0000016 0x00007ffff6f3aef6 in ?? () from /usr/lib64/libQt5Widgets.so.5
0000017 0x00007ffff6f3f35a in QMenu::mouseReleaseEvent(QMouseEvent*) () from /usr/lib64/libQt5Widgets.so.5
0000018 0x00007ffff6e09e59 in QWidget::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
0000019 0x00007ffff6f3faab in QMenu::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
0000020 0x00007ffff6dd01ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib64/libQt5Widgets.so.5
0000021 0x00007ffff6dd5b49 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
0000022 0x00007ffff76af9cd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
0000023 0x00007ffff6dd3e71 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQt5Widgets.so.5
---Type <return> to continue, or q <return> to quit---
0000024 0x00007ffff6e2589d in ?? () from /usr/lib64/libQt5Widgets.so.5
0000025 0x00007ffff6e27803 in ?? () from /usr/lib64/libQt5Widgets.so.5
0000026 0x00007ffff6dd01ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib64/libQt5Widgets.so.5
0000027 0x00007ffff6dd52d6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
0000028 0x00007ffff76af9cd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
0000029 0x00007ffff67433c7 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*)
    () from /usr/lib64/libQt5Gui.so.5
0000030 0x00007ffff6744ec5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib64/libQt5Gui.so.5
0000031 0x00007ffff672f608 in QWindowSystemInterface::sendWindowSystemEventsImplementation(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Gui.so.5
0000032 0x00007fffe3719130 in ?? () from /usr/lib64/qt5/plugins/platforms/libqxcb.so
0000033 0x00007fffec596316 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000034 0x00007fffec596668 in ?? () from /usr/lib64/libglib-2.0.so.0
0000035 0x00007fffec59670c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000036 0x00007ffff76f69cc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQt5Core.so.5
0000037 0x00007ffff76ae71b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQt5Core.so.5
0000038 0x00007ffff6f3e2c8 in QMenu::exec(QPoint const&, QAction*) () from /usr/lib64/libQt5Widgets.so.5
0000039 0x000000000093db0a in CanvasMode_Normal::createContextMenu (this=0x37c8db0, currItem=0x2e63250, mx=294.75,
    my=237) at /home/christoph/scribus15/Scribus/scribus/canvasmode_normal.cpp:1918
0000040 0x000000000093785f in CanvasMode_Normal::mouseReleaseEvent (this=0x37c8db0, m=0x7fffffffd420)
    at /home/christoph/scribus15/Scribus/scribus/canvasmode_normal.cpp:1032
0000041 0x0000000000e1c882 in ScribusView::eventFilter (this=0x32cac30, obj=0x32cc540, event=0x7fffffffd420)
    at /home/christoph/scribus15/Scribus/scribus/scribusview.cpp:4341
0000042 0x00007ffff76afbf5 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) ()
   from /usr/lib64/libQt5Core.so.5
0000043 0x00007ffff6dd01cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib64/libQt5Widgets.so.5
0000044 0x00007ffff6dd5b49 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
0000045 0x00007ffff76af9cd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
0000046 0x00007ffff6dd3e71 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQt5Widgets.so.5
0000047 0x00007ffff6e25aef in ?? () from /usr/lib64/libQt5Widgets.so.5
0000048 0x00007ffff6e27803 in ?? () from /usr/lib64/libQt5Widgets.so.5
0000049 0x00007ffff6dd01ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib64/libQt5Widgets.so.5
0000050 0x00007ffff6dd52d6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
0000051 0x00007ffff76af9cd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
0000052 0x00007ffff67433c7 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*)
    () from /usr/lib64/libQt5Gui.so.5
0000053 0x00007ffff6744ec5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib64/libQt5Gui.so.5
0000054 0x00007ffff672f608 in QWindowSystemInterface::sendWindowSystemEventsImplementation(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Gui.so.5
0000055 0x00007fffe3719130 in ?? () from /usr/lib64/qt5/plugins/platforms/libqxcb.so
0000056 0x00007fffec596316 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000057 0x00007fffec596668 in ?? () from /usr/lib64/libglib-2.0.so.0
0000058 0x00007fffec59670c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000059 0x00007ffff76f69cc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQt5Core.so.5
0000060 0x00007ffff76ae71b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQt5Core.so.5
0000061 0x00007ffff76b4ca1 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
0000062 0x00000000012aad90 in mainApp (argc=1, argv=0x7fffffffddb8)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:86
0000063 0x00000000012aad20 in main (argc=1, argv=0x7fffffffddb8)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
Patch

Relationships

related to 0012525 confirmed GraphicsMagick won't export SLA because of SVG, "Failed to load an image mask" 

Activities

Kunda

2015-02-02 00:50

manager   ~0034418

soft bump + 0012525

christoph_s

2015-02-26 07:20

administrator   ~0034611

Is this really fixed? Scribus still fails to import TGA or PCX files.

cbradney

2015-03-01 11:00

administrator   ~0034628

Yes its fixed.
a) read the bug description - stop trying to get one issue fixed within another bug.

b).. download marbles.pcx from here: http://netghost.narod.ru/gff/sample/images/pcx/index.htm and you will see it works.

christoph_s

2015-03-04 06:28

administrator   ~0034643

Yes, sorry. PCX works, TGA does not.

cbradney

2015-03-05 20:21

administrator   ~0034651

It does.. get marbles.tga from http://www.fileformat.info/format/tga/sample/

The code is now correct around filetype availability, if the file doesn't open, its due to graphicsmagick or something else, but this bug is closed.

christoph_s

2015-03-07 06:21

administrator   ~0034667

OK then

Issue History

Date Modified Username Field Change
2014-01-18 06:52 christoph_s New Issue
2014-08-08 20:17 Kunda Relationship added related to 0012525
2014-08-08 20:18 Kunda Status new => confirmed
2014-08-08 20:18 Kunda Target Version => 1.5.0
2014-09-11 02:34 Kunda Severity crash => block
2014-11-06 13:59 Kunda Sticky Issue No => Yes
2015-02-02 00:50 Kunda Note Added: 0034418
2015-02-24 19:23 cbradney Assigned To => cbradney
2015-02-24 19:23 cbradney Status confirmed => assigned
2015-02-24 22:11 cbradney Status assigned => resolved
2015-02-24 22:11 cbradney Fixed in Version => 1.5.0svn
2015-02-24 22:11 cbradney Resolution open => fixed
2015-02-24 23:18 Kunda Sticky Issue Yes => No
2015-02-26 07:20 christoph_s Note Added: 0034611
2015-02-26 07:20 christoph_s Status resolved => feedback
2015-02-26 07:20 christoph_s Resolution fixed => reopened
2015-03-01 11:00 cbradney Note Added: 0034628
2015-03-01 11:00 cbradney Status feedback => resolved
2015-03-01 11:00 cbradney Resolution reopened => fixed
2015-03-04 06:28 christoph_s Note Added: 0034643
2015-03-04 06:29 christoph_s Status resolved => feedback
2015-03-04 06:29 christoph_s Resolution fixed => reopened
2015-03-05 20:21 cbradney Note Added: 0034651
2015-03-05 20:21 cbradney Status feedback => resolved
2015-03-05 20:21 cbradney Resolution reopened => fixed
2015-03-07 06:21 christoph_s Note Added: 0034667
2015-03-07 06:21 christoph_s Status resolved => closed